Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

fxs to fxs how to apply codecs

hi i have implemented a point to point voip solution using fxs cards at both the sides.and its working perfectly.the leased line bandwidth is 128 kbps.how can i apply codecs and minimize the voice packet bandwidth pls check the configuration of both the routers.

sh run

Building configuration...

Current configuration : 1278 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip cef

!

!

!

!

--More-- !

voice-card 0

!!

!

username cisco privilege 15 secret xxxx

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.10.5 255.255.255.0

duplex auto

--More-- speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1/0

ip address 128.10.x.x.255.255.252

!

ip route 192.168.x.x.255.255.0 128.10.10.1

!

ip http server

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0

--More-- !

voice-port 0/0/1

!

!

!

!

!

dial-peer voice 1 pots

destination-pattern 5577

port 0/0/0

!

dial-peer voice 2 voip

destination-pattern 5578

session target ipv4:128.x.10.2

!

dial-peer voice 3 pots

destination-pattern 5578

port 0/0/1

!

dial-peer voice 4 voip

destination-pattern 5577

session target ipv4:128.x.10.2

!

--More-- dial-peer voice 5 voip

destination-pattern 5575

session target ipv4:128.x.10.1

!

dial-peer voice 6 voip

destination-pattern 5576

session target ipv4:128.x.10.1

!

!

line con 0

line aux 0

line vty 0 4

password xxx

login

!

scheduler allocate 20000 1000

end

config of 2nd router.

sh run

Building configuration...

Current configuration : 2413 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname OETC-QURM

!

boot-start-marker

boot system flash c2801-ipvoice-mz.124-6.T2.bin

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

ip cef

!

!

--More-- !

!

ip domain name yourdomain.com

!

voice-card 0

!

!

username xxx privilege 15 secret xxxx

!

!

--More-- interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

ip address 192.168.1.2 255.255.255.0

speed auto

full-duplex

!

interface FastEthernet0/1

ip address 192.168.50.2 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1/0

ip address 128.10.x.x.255.255.252

!

ip route 0.0.0.0 0.0.x.x.10.10.2

!

ip http server

ip http authentication local

ip http timeout-policy idle 5 life 86400 requests 10000

!

!

!

!

--More-- control-plane

!

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

!

!

!

!

dial-peer voice 7 pots

destination-pattern 5575

port 0/0/0

!

dial-peer voice 8 voip

destination-pattern 5576

session target ipv4:128.10.10.1

!

dial-peer voice 9 pots

destination-pattern 5576

port 0/0/1

--More-- !

dial-peer voice 10 voip

destination-pattern 5575

session target ipv4:128.10.10.1

!

dial-peer voice 11 voip

destination-pattern 5577

session target ipv4:128.10.10.2

!

dial-peer voice 12 voip

destination-pattern 5578

session target ipv4:128.10.10.2

line con 0

login local

line aux 0

line vty 0 4

privilege level 15

password ocs

login

transport input telnet

line vty 5 15

privilege level 15

--More-- login local

transport input telnet

!

scheduler allocate 20000 1000

end

pls post your views, all the replys will be appreciated with proper ratings.

Regds

Binoy

6 REPLIES
New Member

Re: fxs to fxs how to apply codecs

If i am not mistaken. The default setting for VOIP is using codec G.729. No setting required

New Member

Re: fxs to fxs how to apply codecs

thanks for your reply.

have u seen the given configuration.G.729 is not configured on this, u mean to say by default cisco router will take G.729 if yes what will be the bandwidth of a voice call.

will it take 64 kbps for a single call.

if it takes 64 k how can i decrese its bandwidth.kindly suggest solution for this.

Regds

Binoy

New Member

Re: fxs to fxs how to apply codecs

Without any codec configuration on the dial-peer, G.729 will be used. G.729 is around 16kbps for single call. You can view the call detail by "show call history voice brief".

New Member

Re: fxs to fxs how to apply codecs

lee thanks for your reply.

can you give me some pdf's regding this for reference.and i need to do the "show call history voice brief" while calling or after the call from this commands output can i see the codec which is default in this routers.

which all other codecs i can use to save bandwidth. pls give some more details abt this.

Regds

Binoy.

New Member

Re: fxs to fxs how to apply codecs

Binoy,

If you want to specify the codec you have to add this command under the voip dial-peer

codec g729r8 bytes 40

g729r8 is the codec

40 is the payload which you can change according to your design

you can find all the commands in

"Cisco IOS Voice Command reference"

Regards

Omar

New Member

Re: fxs to fxs how to apply codecs

This link points to the document that shows in detail how bandwidth is calculated for different codecs and also explains the terms.

http://www.cisco.com/en/US/tech/tk652/tk698/technologies_tech_note09186a0080094ae2.shtml

Hope you find it helpful. Please rate all posts.

HTH,

Sulabh

240
Views
4
Helpful
6
Replies
CreatePlease to create content