Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

G729/Unity questions

We have our CM 3.1.3a(spf) call manager set to take calls from our WAN campus region and establish G711 calls within that region - and G729 calls outside that region.

We have confirmed that this is working and establishing G729 calls with both the show voice dsp command on the 3662 gateway - and with the double-"i" button press on the phones to check the active codec.

However, whenever a call to the remote campus gets forwarded to unity - (which is located in the central campus) G711 always results.

We have established voice classes as below as recommended at

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&CommCmd=MB%3Fcmd%3Ddisplay_location%26mode%3Dnew%26location%3D.ee81e9a

voice class codec 10

codec preference 4 g729br8

codec preference 5 g711ulaw

We also have the dial-peers setup as follows to force G729 on the WAN calls:

!

dial-peer voice 700 voip

destination-pattern 71..

progress_ind setup enable 3

translate-outgoing calling 1

voice-class codec 10

voice-class h323 10

session target ipv4:10.90.10.20

dtmf-relay h245-alphanumeric

ip precedence 5

no vad

!

dial-peer voice 701 voip

preference 2

destination-pattern 71..

progress_ind setup enable 3

translate-outgoing calling 1

voice-class codec 10

voice-class h323 10

session target ipv4:10.90.10.10

dtmf-relay h245-alphanumeric

ip precedence 5

no vad

!

Also - I checked the prescense of the G729br8 codec on unity as detailed at http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&CommCmd=MB%3Fcmd%3Ddisplay_location%26mode%3Dnew%26location%3D.ee836ca/3 and our Unity server does show the sipro G729a codec as present - *even though I do not recall ever having run the sl_g729a_setup.exe application* ... (should I "reinstall?")

Also - is there a way to tell from the Unity console while a call into Unity is active what codec Unity is using to converse with it?

Is there anything else I'm missing to troubleshoot this?

Thanks!!

- Ken

  • Other Collaboration Voice and Video Subjects
5 REPLIES
Gold

Re: G729/Unity questions

Can you confirm that the region that is gateway is in and the region that the Unity ports are in are set to use g.729?

Thanks,

Keith

New Member

Re: G729/Unity questions

Ok - yeah - actually I mispoke - we're not even going through the local gateway necessarily - if we just have our users at the remote campus (Austin) dial unity directly from thir IP phones - they go back across a standard WAN link (no voice gateways) to our Unity box at the center campus (Longview) they get G711 - all Austin phones (and the local PSTN gateway in Austin) are members of the DP-AUS (Austin) Device Pool - and it is a member of the RG-AUS Region - and that region is set to communicate G729 to the default region (which is Longview, where the Unity ports are). Each region is set to communicate G711 within the region itself though...

Does this make sense at all ? :-/ Thanks for your help :-)

Gold

Re: G729/Unity questions

Okay, so IP phone to Unity has this problem. What if you call from an IP phone in the RG-AUS region to an IP phone in the Default region? Any tanscoders involved here?

To CallManager, Unity is just another IP phone so I would expect you to see the same thing happen between the IP phones in different regions unless Unity is not advertising support for g.729 to CallManager during the call setup. Even in that case the call should get re-order (fail) rather than connect with the wrong codec.

Maybe you can post a CCM trace out here for me to look at...

Keith

New Member

Re: G729/Unity questions

Ken, I've had the same problem - resolved by installing the G729 codec on the Unity server (I'm assumin your 'region' settings are already correct in CM). I'm not sure what happened when, but it looks like the g729 codec was removed (no registry entries) when we uprgraded Unity to 3.1.3??

Jo

New Member

Re: G729/Unity questions

Hey thanks - that worked for me too! I'm not sure - I had never even installed the G729 - but it was showing up - I guess it was a ghost - reinstalling defintiely has me G729'ing into Unity - thanks all!

97
Views
0
Helpful
5
Replies