Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Get Enterprise Data Step fails

When trying to use the Get Enterprise Data step in IPCC Express, the following debug trace is printed. Any ideas of what may be happening here or what the CallID variable being looked for is?

16478: Mar 17 15:42:19.200 MST %MIVR-STEP_ENT_SRV-7-UNK:Prepare data for getEnterpriseDataListByCallId

16479: Mar 17 15:42:19.200 MST %MIVR-STEP_ENT_SRV-7-UNK:The 1th try ... getting Enterprise Data by callID

16480: Mar 17 15:42:19.200 MST %MIVR-STEP_ENT_SRV-7-UNK:CallID does not exist.

16481: Mar 17 15:42:19.403 MST %MIVR-STEP_ENT_SRV-7-UNK:The 2th try ... getting Enterprise Data by callID

16482: Mar 17 15:42:19.403 MST %MIVR-STEP_ENT_SRV-7-UNK:CallID does not exist.

16483: Mar 17 15:42:19.606 MST %MIVR-STEP_ENT_SRV-7-UNK:The 3th try ... getting Enterprise Data by callID

16484: Mar 17 15:42:19.606 MST %MIVR-STEP_ENT_SRV-7-UNK:CallID does not exist.

16485: Mar 17 15:42:19.809 MST %MIVR-STEP_ENT_SRV-7-UNK:The 4th try ... getting Enterprise Data by callID

16486: Mar 17 15:42:19.809 MST %MIVR-STEP_ENT_SRV-7-UNK:CallID does not exist.

16487: Mar 17 15:42:20.012 MST %MIVR-STEP_ENT_SRV-7-UNK:The 5th try ... getting Enterprise Data by callID

16488: Mar 17 15:42:20.012 MST %MIVR-STEP_ENT_SRV-7-UNK:data value list is:

16489: Mar 17 15:42:20.012 MST %MIVR-STEP_ENT_SRV-7-UNK:Failure to get Enterprise Data after 5-time retires

  • Other Collaboration Voice and Video Subjects
1 REPLY
Silver

Re: Get Enterprise Data Step fails

Hi,

Check if the Enterprise Data Subsystem is running. Are you trying to retrive ENT data before even accepting the call? What is that ED data which you are trying to get using this step(system defined / custom defined)? It appears as though you are trying to get data which is not configured in "Enterprise Configuration" in Desktop Administrator or trying to retrive enterprise data which is not present.

Cisco Desktop Administrator User's guide describes enterprise data configuration. Check out the following URL for the same...

http://www.cisco.com/univercd/cc/td/doc/product/voice/sw_ap_to/apps_3_5/english/admn_app/cad_admn.pdf

Check out the ICD section of Cisco Customer Response Application Editor Step Reference guide which describes the enterprise data steps. URL for the same is

http://www.cisco.com/univercd/cc/td/doc/product/voice/sw_ap_to/apps_3_5/english/admn_app/step.pdf

If you think your configurations are fine and still get the same error, do open a TAC case attaching MIVR logs and aef script.

Regards

Yogi

118
Views
0
Helpful
1
Replies
This widget could not be displayed.