Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Giving priority to voice

We have a point to point link of 64K from our branch office to our Head office. We are using 1750 router at our end. We have e&m card in our router. We are using that 64k link for data and voice both.

Whenever there is some data in the link...voice is getting affected. Voice is not clear.

HO is able to hear our voice clearly, but we are unable to hear their voice.

If we route data thru isdn and if we use Leased line for voice..then it is very clear.

I am pasting the router config

class-map match-all voice

match access-group 101

!

!

policy-map rpgc

class voice

bandwidth 40 config below. pl check and advice...

access-list 101 permit udp any any range 16384 32767

access-list 101 permit tcp any any eq 1720

The policy is applied to serial interface.

The same config is there on HO router also.

Pl let me know what config i have do.

3 REPLIES
New Member

Re: Giving priority to voice

You need to provide us with a little more information. Please post the entire config minus passwords.

Typical problems point to using the wrong compression for the voice. Are you using G711 or G729?

Another common error is that you must also have a bandwidth statement on the serial interfaces. Without a bandwidth statement, the software believes that it has the default bandwidth for the interface, 1.544mbps and it does not see any congestion problems.

The third is that for such a slow link, it would be good to emulate frame-relay so that you could do fragmentation of the large data packets.

Bronze

Re: Giving priority to voice

The first problem I see is that you are using the "Bandwidth" command instead of the "priority" command. The priority command will create a strict priority queue for the voice traffic, so queue latency is reduced.

New Member

Re: Giving priority to voice

Pl find the entire config below. I have configured the bandwidth.

We can not use frame relay as we dont have any frame relay switches.

and abt priority....i will check it out.

sh run

Building configuration...

Current configuration : 3410 bytes

!

version 12.2

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

logging rate-limit console 10 except errors

!

memory-size iomem 25

ip subnet-zero

no ip finger

!

no ip dhcp-client network-discovery

!

class-map match-all voice

match access-group 101

!

!

policy-map rpgc

class voice

bandwidth 40

!

isdn switch-type basic-net3

call rsvp-sync

!

!

!

!

!

!

!

!

interface Tunnel0

ip address 192.168.20.2 255.255.255.252

tunnel source BRI0

tunnel destination x.x.x.x

!

interface Multilink1

ip unnumbered FastEthernet0

ip tcp header-compression iphc-format

fair-queue 64 16 0

no cdp enable

ppp multilink

ppp multilink fragment-delay 10

ppp multilink interleave

multilink-group 1

ip rtp header-compression iphc-format

ip rtp priority 16384 16383 48

!

interface BRI0

bandwidth 64

ip address negotiated

ip nat outside

encapsulation ppp

dialer idle-timeout 30

dialer string 95802488140

dialer-group 1

isdn switch-type basic-net3

cdapi buffers regular 0

cdapi buffers raw 0

cdapi buffers large 0

ppp authentication pap callin

ppp pap sent-username xxxxx password 7 15001B0B0933382B3A36

!

interface FastEthernet0

ip address 10.67.1.1 255.255.0.0

ip access-group 103 in

ip nat inside

speed auto

!

interface Serial0

description lease line connection to HO Mumbai

mtu 256

bandwidth 64

ip address 192.168.50.9 255.255.255.252

encapsulation ppp

no ip mroute-cache

service-policy output rpgc

!

interface Serial1

no ip address

shutdown

!

ip nat inside source list 102 interface BRI0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 BRI0

ip route 0.0.0.0 0.0.0.0 Serial0 150

ip route 10.64.0.0 255.255.0.0 192.168.20.1

no ip http server

!

access-list 101 permit udp any any range 16384 32767

access-list 101 permit tcp any any eq 1720

access-list 102 permit ip 10.67.1.0 0.0.0.255 any

access-list 103 deny tcp any any eq www

access-list 103 permit ip any any

dialer-list 1 protocol ip permit

!

voice-port 2/0

input gain 5

bearer-cap Speech

operation 4-wire

type 5

signal immediate

!

voice-port 2/1

input gain 5

bearer-cap Speech

operation 4-wire

type 5

signal immediate

!

dial-peer voice 1 voip

destination-pattern 77...

session target ipv4:192.168.50.10

req-qos controlled-load

ip precedence 5

!

dial-peer voice 2 voip

destination-pattern 77...

session target ipv4:192.168.50.10

req-qos controlled-load

ip precedence 5

!

dial-peer voice 3 pots

destination-pattern 5...

port 2/0

!

dial-peer voice 4 pots

destination-pattern 5...

port 2/1

!

dial-peer voice 5 voip

destination-pattern 66...

session target ipv4:192.168.50.13

req-qos controlled-load

ip precedence 5

!

dial-peer voice 6 voip

destination-pattern 66...

session target ipv4:192.168.50.13

req-qos controlled-load

ip precedence 5

!

dial-peer voice 7 voip

destination-pattern 44...

session target ipv4:192.168.50.2

req-qos controlled-load

ip precedence 5

!

dial-peer voice 8 voip

destination-pattern 44...

session target ipv4:192.168.50.2

req-qos controlled-load

ip precedence 5

113
Views
0
Helpful
3
Replies