Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started.

New Member

H.323 gateway

Could someone post an h323 gateway config preferably one that is accepting DID. thanks.

  • Other Collaboration Voice and Video Subjects
3 REPLIES
New Member

Re: H.323 gateway

This is my config 3640 12.2(7a) pri connection- call manager 3.1

we have did's in the 6xxx -7960 phones- do i need dtmf-relay h245-alphnumeric ?

any obvious changes you can suggest are welcomed

User Access Verification

Password:

VoiceGW>en

Password:

CTI-VoiceGW#sh run

Building configuration...

Current configuration : 1625 bytes

!

version 12.2

no parser cache

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname VoiceGW

!

boot system flash:c3640-is-mz.122-7a.bin

enable password

!

voice-card 1

!

ip subnet-zero

!

!

no ip domain-lookup

!

isdn switch-type primary-5ess

call rsvp-sync

!

voice service pots

!

!

!

!

!

!

controller T1 1/0

framing esf

linecode b8zs

cablelength short 133

pri-group timeslots 1-24

!

!

!

interface FastEthernet0/0

ip address 192.168.1.235 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial1/0:23

no ip address

no logging event link-status

isdn switch-type primary-5ess

isdn incoming-voice voice

no cdp enable

!

no ip classless

ip route 0.0.0.0 0.0.0.0 192.9.250.254

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip route 192.9.250.0 255.255.255.0 192.168.1.100

ip route 192.168.1.0 255.255.255.0 192.9.250.254

no ip http server

ip pim bidir-enable

!

!

voice-port 1/0:23

!

voice-port 2/0/0

!

voice-port 2/0/1

!

voice-port 2/1/0

caller-id enable

signal groundStart

!

voice-port 2/1/1

caller-id enable

supervisory disconnect anytone

signal groundStart

!

voice-port 3/0/0

!

voice-port 3/0/1

!

voice-port 3/1/0

!

voice-port 3/1/1

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

destination-pattern *

direct-inward-dial

port 1/0:23

!

dial-peer voice 6000 voip

destination-pattern 6...

session target ipv4:192.168.1.240

codec g711ulaw

!

gateway

!

!

line con 0

line aux 0

password line line

speed 56000

line vty 0 4

password

login

!

end

VoiceGW#

Re: H.323 gateway

i have ddi's on my gateway as well and the only difference between your dial peer and mine is i have dtmf-relay h245-alphanumeric and progress_ind setup enable 3 on them

hope this helps, also check how many digits your supplier is send you might have to do some translation if they are sending more than the 4

dave

New Member

Re: H.323 gateway

thank you for your reply.

now if my service provider would get the @#%$ pri up I could actually test it

137
Views
0
Helpful
3
Replies