Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

H.323 Interoperability with PBR on Catalyst 3560

Hi Everyone,

Do anyone had experienced on this set-up:

Tandberg(H.323/SIP) Endpoint->Cat-3560(with PBR)->MPLS CE router1->WAN->remote MPLS CE router2-->Cat-6500(with PBR)

ON this setup, Policy-Based Routing was applied in L3 core switches because each site has two WAN links, and we want to use the link with bigger BW.

Problem: Tandberg endpoints in both ends can establish a call using SIP protocol. But, the call isn't established using H.323. Based on Tanberg, Q.931 & H.245 signalling doesn't reach end-to-end.

Troubleshooting Done:

-Without PBR, the route defaults to smaller/congested WAN link, but both SIP/H323 calls can be established.

-With PBR, SIP calls are established via bigger BW WAN link. But H323 fails

-On extended ACL during call test, no match is made on tcp/udp ports rules (using sh access-list)

Questions:

-Did I miss anythin on the ACL to handle H323 signaling traffic?

-Should I apply this command:

Router(config)# ip local policy route-map map-tag

and apply the PBR to loopback interface of this L3switch to enable policy-based routing for VoIP signaling packets? Isn't this applicable on packets originated only on this L3 switch?

Thanks in advance for you help guys!

Cheers,

Emmanuel

Here's my PBR Config summary at Cat-3560 switch (this PBR is applied on VLAN interface where Tandberg belongs):

ip access-list extended h323-sip

permit tcp 10.37.64.0 0.0.0.15 eq 1720 10.33.7.0 0.0.0.255

permit tcp 10.37.64.0 0.0.0.15 eq 1720 10.33.6.0 0.0.0.255

permit tcp 10.37.64.0 0.0.0.15 10.33.7.0 0.0.0.255 eq 1720

permit udp 10.37.64.0 0.0.0.15 eq 1719 10.33.7.0 0.0.0.255

permit udp 10.37.64.0 0.0.0.15 10.33.7.0 0.0.0.255 eq 1719

permit tcp 10.37.64.0 0.0.0.15 10.33.7.0 0.0.0.255 range 15000 19999

permit udp 10.37.64.0 0.0.0.15 10.33.7.0 0.0.0.255 range 15000 19999

permit ip 10.37.64.0 0.0.0.15 10.33.7.0 0.0.0.255

route-map h323-sip permit 10

match ip address h323-sip

set ip next-hop 10.37.0.14

2 REPLIES
New Member

Re: H.323 Interoperability with PBR on Catalyst 3560

Hi Guys,

Anyone who can give a feedback if any PBR issues with H.323?

Thanks in advance!

Cheers,

Emmanuel

New Member

H.323 Interoperability with PBR on Catalyst 3560

Emmanuel,

I wanted to do same confuration, Please share me you configuration details, if your problem has been resolved

-Sam

535
Views
0
Helpful
2
Replies
CreatePlease to create content