Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Home lab setup help

I have a callmanager 4.1 lab at my house with 4 IP phones. I'm trying to integrate it with my home phone (Packet8 IP phone) so when I dial 9 on the IP phone I get an outside line, and I can actually place calls. Also, all incoming calls will go to a certain phone in the house. My gateway is a 2621 running h323 with 2 FXO ports. The config is pasted below. I believe the only way I can do this is to have a PLAR set up on the router. ANy help in this endeavor would be greatly appreciated.

Thanks,

Mitch

Current configuration : 2784 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname 2621-Gateway

!

boot-start-marker

boot system flash c2600-is3x-mz.123-15a.bin

boot-end-marker

!

enable password

!

no aaa new-model

ip subnet-zero

ip cef

!

!

no ip domain lookup

!

!

!

!

!

!

voice class h323 15

h225 timeout setup 5

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description Outside Interface

ip address dhcp

ip nat outside

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 1 native

ip address 172.16.100.1 255.255.255.0

ip helper-address 172.16.200.5

ip helper-address 10.200.1.15

ip nat inside

no snmp trap link-status

!

interface FastEthernet0/1.5

encapsulation dot1Q 5

ip address 172.16.200.1 255.255.255.0

ip nat inside

no snmp trap link-status

!

interface FastEthernet0/1.71

encapsulation dot1Q 71

ip address 172.20.71.253 255.255.255.0

no snmp trap link-status

!

ip nat pool mynat 65.191.000.001 65.191.000.001 prefix-length 21

ip nat inside source list 101 pool mynat overload

ip nat inside source static udp 172.16.200.15 53 65.191.000.001 53 extendable

ip nat inside source static tcp 172.16.200.15 80 65.191.000.001 80 extendable

ip nat inside source static tcp 172.16.200.15 25 65.191.000.001 25 extendable

ip nat inside source static tcp 172.16.200.15 143 65.191.000.001 143 extendable

ip nat inside source static udp 172.16.200.15 143 65.191.000.001 143 extendable

ip nat inside source static tcp 172.16.200.15 110 65.191.000.001 110 extendable

ip nat inside source static tcp 172.16.200.15 53 65.191.000.001 53 extendable

ip http server

ip classless

ip route 10.1.1.0 255.255.255.0 172.16.100.7

ip route 10.200.40.0 255.255.255.0 172.20.71.254

ip route 10.200.150.0 255.255.255.0 172.20.71.254

ip route 172.20.65.0 255.255.255.0 172.20.71.254

ip route 172.20.72.0 255.255.255.0 172.20.71.254

!

!

access-list 1 permit 172.16.100.0 0.0.0.255

access-list 1 permit 172.16.200.0 0.0.0.255

access-list 101 permit ip 172.16.100.0 0.0.0.255 any

access-list 101 permit ip 172.16.200.0 0.0.0.255 any

!

!

voice-port 1/0/0

ring number 4

connection plar 29992

!

voice-port 1/0/1

!

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

incoming called-number .

destination-pattern 9T

direct-inward-dial

port 1/0/0

!

dial-peer voice 100 voip

incoming called-number 4570 Should this be the entire phone number?

destination-pattern 2....

session target ipv4:172.16.200.5

dtmf-relay h245-alphanumeric

codec g711ulaw

!

!

gatekeeper

shutdown

!

!

line con 0

exec-timeout 0 0

password

logging synchronous

login

line aux 0

line vty 0 4

exec-timeout 0 0

password

logging synchronous

login

!

!

end

8 REPLIES

Re: Home lab setup help

PLAR is the best setup in this case.

If you run IP Plus image, you can enable MGCP and add the gateway as an MGCP gateway in Callmanager. In the attendant DN field, you can specify which phone to ring.

HTH

New Member

Re: Home lab setup help

A problem I failed to point out that I'm trying to address is with the placing outgoing/incoming calls. After the 4th ring on an incoming call I get the busy signal. When I dial 9 to get an outside line, i get a different signal, it sort of sounds like a sick dialtone/busy signal mixture.

Thanks in advance.

Re: Home lab setup help

For dial out, on the route pattern on CM, uncheck the option "provide outside dial tone". Hope that fixes the problem.

For dial in, are you able to pick up the call on the ip phone ? Check CFwd settings on the phone, if its getting forwarded to voice mail, (CFNA). Unless you have a VOicemail server, you will get busy signal.

HTH

PS: please remember to rate helpful posts!

New Member

Re: Home lab setup help

I can dial out now. Thank-you so much that is awsome. After I unchecked the option of provide outside dial tone, I had to reboot the router. But then it worked great.

However, if you can help me with the dialing in, after the 4th ring I get a series of beeps (13) then it hangs up. Where do I enter the number for the phone I want it to ring for inbound calls?

Re: Home lab setup help

In case of H323 gateway and FXO , PLAR is the way to ring a phone. So you configure this on the gateway (as you have already done). Check your IP Phone whose extension is 29992, if CFNA and CFB are forwarded to any number (which is either voicemail or an external number). If a voicemail server is not available in your setup, it will give a fast busy.

New Member

Re: Home lab setup help

Thanks so much for all your help. Now the phone rings after I get the busy signal on the dialing phone (my cell phone), I have to pick up on the phone to make it stop ringing. I guess it's worth mentioning that I do have Unity setup but haven't got that part working.

Once again thanks for everything.

New Member

Re: Home lab setup help

Problem solved, I got rid of the command ring number 4 from the voice port 1/0/0 and the calls started coming in, thanks for the help Shanky.

Bronze

Re: Home lab setup help

I am using a call manager express with an FXO but using the 'connection plar opx xxxx' under the voice port.

Not sure if this will solve but may help.

voice-port 1/0/0

connection plar opx 29992

dial-peer voice 100 voip

destination-pattern 2....

session target ipv4:172.16.200.5

dtmf-relay h245-alphanumeric

codec g711ulaw

More info on PLAR <http://www.cisco.com/en/US/partner/tech/tk1077/technologies_configuration_example09186a00800942a5.shtml>

Interested to see how you go..

133
Views
14
Helpful
8
Replies
CreatePlease to create content