Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

how to dynamically do call admission control as traffic varies

Dear Forum,

My name is Yohan Gunawan from Indonesia.

I have a set up with requirement as below:

two cisco router 2621 back to back

bandwith 64kbps each

router ospf

LAN HQ=10.10.2.1/25

LAN Branch=10.1.1.1/25

HQ Branch

.241 10.1.1.240/30 .242 Link1

8801 P1 ---------------------- P1 1101

2621 2621

8802 P2 ---------------------- P2 1102

.245 10.1.1.244/30 .246 Link2

P1 & P2 is analog phone 1 & 2 with the number: 88xx @ HQ and 11xx @ branch

The requirements are (refer to the diagram):

1. Branch has 2 connection to HQ: link1 10.1.1.240/30 and link2 10.1.1.244/30

2. Routing Protocol: OSPF

3. link1 is for data; link2 for voice (say 2 channel voice)

4. upon link1 failure, data is routed through link2. Since link2 is shared by data and voice. voice channel need to be reduced to 1 channel only

I have tried RSVP to reserved 1st call, but how do I make the 2nd call (considering the way call-rsvp is configured in dial-peer)

If I reserved 2 call (as per config attached), then data will not use the bandwith as it is reserved by the voice traffic (ip rsvp bandwith 48)

I havent been able to deliver item 4 requirement with this idea (as per config I attach).

Do you have any idea how to do this. As far as I know cisco does not have a specific feature that match exactly with this requirement.

Thank you very much

Yohan

********************

router config:

********************

Branch_1#sh run

Building configuration...

Current configuration : 2105 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Branch_1

!

enable password cisco

!

memory-size iomem 10

ip subnet-zero

ip cef

!

!

no ip domain lookup

!

ip audit notify log

ip audit po max-events 100

!

!

!

voice call carrier capacity active

!

!

!

!

!

!

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

!

!

!

interface Loopback0

description Loopback Address for OSPF

ip address 10.1.1.254 255.255.255.255

!

interface Loopback1

description LOOPBACK FOR VOICE CONNECTIVITY

ip address 10.1.1.253 255.255.255.255

ip route-cache policy

ip policy route-map voice

h323-gateway voip bind srcaddr 10.1.1.253

!

interface FastEthernet0/0

description DATA Network

ip address 10.1.1.1 255.255.255.128

duplex auto

speed auto

!

interface Serial0/0

bandwidth 64

ip address 10.1.1.242 255.255.255.252

no fair-queue

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

bandwidth 64

ip address 10.1.1.246 255.255.255.252

fair-queue 64 256 2

ip rsvp bandwidth 48 48

!

router ospf 1

log-adjacency-changes

network 10.1.0.0 0.0.255.255 area 1

!

ip local policy route-map voice

ip classless

ip http server

!

!

access-list 110 permit ip host 10.1.1.253 any

access-list 110 permit tcp any any eq 1720

!

route-map voice permit 10

match ip address 110

set ip next-hop 10.1.1.245

!

route-map voice permit 20

set ip next-hop 10.1.1.241 10.1.1.245

!

call rsvp-sync

!

voice-port 1/0/0

!

voice-port 1/0/1

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

destination-pattern 1101

port 1/0/0

!

dial-peer voice 2 pots

destination-pattern 1102

port 1/0/1

!

dial-peer voice 10 voip

destination-pattern 88..

voice-class source interface Loopback1

session target ipv4:10.10.2.253

req-qos controlled-load

acc-qos controlled-load

ip qos dscp cs5 media

!

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

no exec

transport input all

line vty 0 4

exec-timeout 0 0

password cisco

logging synchronous

no login

!

!

end

Branch_1#

Branch_1#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IK8O3S-M), Version 12.2(11)T3, RELEASE SOFTWARE

(fc2)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sun 22-Dec-02 02:34 by ccai

Image text-base: 0x8000809C, data-base: 0x8181F4BC

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

Branch_1 uptime is 22 hours, 21 minutes

System returned to ROM by power-on

System image file is "flash:c2600-ik8o3s-mz.122-11.T3.bin"

cisco 2621 (MPC860) processor (revision 0x600) with 59392K/6144K bytes of memory

.

Processor board ID JAD05220NVS (4116991722)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

2 FastEthernet/IEEE 802.3 interface(s)

2 Serial(sync/async) network interface(s)

2 Voice FXS interface(s)

32K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Branch_1#

***********************

HQ_Voice_GW#sh run

Building configuration...

Current configuration : 2103 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname HQ_Voice_GW

!

enable password cisco

!

ip subnet-zero

ip cef

!

!

no ip domain lookup

!

ip audit notify log

ip audit po max-events 100

!

!

!

voice call carrier capacity active

!

!

!

!

!

!

!

!

!

mta receive maximum-recipients 0

!

!

!

!

interface Loopback0

description OSPF ROUTER ID

ip address 10.10.2.254 255.255.255.255

!

interface Loopback1

description LOOPBACK FOR VOICE CONNECTIVITY

ip address 10.10.2.253 255.255.255.255

ip route-cache policy

ip policy route-map voice

h323-gateway voip bind srcaddr 10.10.2.253

!

interface FastEthernet0/0

ip address 10.10.2.1 255.255.255.128

duplex auto

speed auto

!

interface Serial0/0

bandwidth 64

ip address 10.1.1.241 255.255.255.252

no fair-queue

clockrate 64000

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

bandwidth 64

ip address 10.1.1.245 255.255.255.252

--More--

*Mar 1 22:21:44.384: Writing Reservation Timer to Running Config 10000

fair-queue 64 256 2

clockrate 64000

ip rsvp bandwidth 48 48

!

router ospf 1

log-adjacency-changes

network 10.1.1.240 0.0.0.7 area 1

network 10.10.0.0 0.0.255.255 area 0

!

ip local policy route-map voice

ip classless

ip http server

!

!

access-list 110 permit ip host 10.10.2.253 any

access-list 110 permit tcp any any eq 1720

!

route-map voice permit 10

match ip address 110

set ip next-hop 10.1.1.246

!

route-map voice permit 20

set ip next-hop 10.1.1.242

!

call rsvp-sync

!

voice-port 1/0/0

!

voice-port 1/0/1

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 1 pots

destination-pattern 8801

port 1/0/0

!

dial-peer voice 2 pots

destination-pattern 8802

port 1/0/1

!

dial-peer voice 10 voip

destination-pattern 11..

voice-class source interface Loopback1

session target ipv4:10.1.1.253

req-qos controlled-load

acc-qos controlled-load

ip qos dscp cs5 media

!

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

exec-timeout 0 0

no exec

transport input all

line vty 0 4

exec-timeout 0 0

password cisco

logging synchronous

no login

!

!

end

HQ_Voice_GW#

HQ_Voice_GW#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IK8O3S-M), Version 12.2(11)T3, RELEASE SOFTWARE

(fc2)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sun 22-Dec-02 02:34 by ccai

Image text-base: 0x8000809C, data-base: 0x8181F4BC

ROM: System Bootstrap, Version 12.2(6r), RELEASE SOFTWARE (fc1)

HQ_Voice_GW uptime is 22 hours, 22 minutes

System returned to ROM by power-on

System image file is "flash:c2600-ik8o3s-mz.122-11.T3.bin"

cisco 2651 (MPC860P) processor (revision 0x00) with 125952K/5120K bytes of memor

y.

Processor board ID JAD06080GPD (3036985697)

M860 processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

2 FastEthernet/IEEE 802.3 interface(s)

2 Serial(sync/async) network interface(s)

2 Voice FXS interface(s)

32K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

HQ_Voice_GW#

1 REPLY
Bronze

Re: how to dynamically do call admission control as traffic vari

I think the support for this feature is not available currently. There is only fallback for call admission control.

253
Views
0
Helpful
1
Replies
CreatePlease to create content