Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How to prioritize voice traffic using c2621 and cisco IP telephones or other IP gateways through Frame Relay?

2621 is connected to Frame Relay and want to prioritize voice traffic going from Ethernet0/0 (other data traffic goes also via Ethernet 0/0)(using IP telephones or other IP gateways, which supports IP precedence)

Which type of queuing should we use (and how- the example would be the best) and what parameters should be set for FR links ?

  • Other Collaboration Voice and Video Subjects
3 REPLIES
Anonymous
N/A

Re: How to prioritize voice traffic using c2621 and cisco IP tel

IP precedence is really unecessary if you are

doing voip over frame-relay. The queuing mechanism would

be Ip rtp priority which create two queues. A high

queue for voip traffic and a low queue populated by the queue

mechanism used for data traffic. In the example below it is

WFQ.

Also to ensure good voice quality, large data packets

should be fragmented to reduce the propagation time across the link. The

frame relay tc should be kept at a small value to reduce

the maximum time we will need to wait for a token ( i.e. clocking of next frame on the wire)

Example below shown how these issues are addressed.

Interface ethernet 0

ip address 2.2.2.1 255.255.255.0

!

int ser 0/0

encap frame-relay

frame-relay traffic-shaping

no ip address

!

interface serial0/0.1 point-to-point

ip add 1.1.1.1 255.255.255.252

frame-relay interface-dlci 100

class voice

!

map-class frame-relay voice

frame cir 64000

frame bc 640

frame mincir 64000

frame-relay ip rtp priority 16384 16383 48

frame fragment 80

frame fair-queue 64 256

New Member

Re: How to prioritize voice traffic using c2621 and cisco IP tel

You don't want to use wieghted fair queueing becase voice priority will be non existent when the link becomes congested.

You can use low lantency queueing to mark and provide a low latency queue for high priority traffic over frame-relay.

On the LAN side it is important to provide a queueing mechanism in your core and access switches so that voice traffic is queued out LAN interfaces to your 2600 first.

-----------------------------------------------------------------------------------------------

There are 2 portions

RTP or constant voice traffic and Call control traffic wich does call setup and tear down. usually RTP is set up with an IP Precedence of 5 and Call Control has a precedence of 3. Only 8k of bandwidth is needed for call control traffic for hundreds of phones but depending on how many phones you have you can limit the priority or bandwidth in the policy.

!

!

!

map-class frame-relay voice

frame-relay cir 512000

frame-relay mincir 512000

service-policy output QOS-Policy

!

!

int serial0

Frame-relay traffic-shaping

!

int serial0/0.100

frame-relay class voice

!

!

!

class-map VoIP-RTP

match access-group 102

class-map VoIP-Control

match access-group 101

!

policy-map QOS-Policy

class VoIP-RTP

priority percent 100

class VoIP-Control

bandwidth 8

class class-default

fair-queue

!

access-list 102 permit udp any any range 16384 32767

access-list 102 permit ip any any precedence 5

access-list 102 permit ip any any dscp ef

!

access-list 101 permit tcp any any range 2000 2002

access-list 101 permit tcp any any eq 1720

access-list 101 permit tcp any any range 11000 11999

access-list 101 permit udp any any eq 2427

______________________________

This puts ip precedence 5 and 3 in different queues on my switch.

For my 6500

#qos

set qos enable

set qos map 2q2t tx 2 1 cos 3

set qos map 1p2q2t tx 2 1 cos 3

set qos wred 1p2q2t tx queue 1 40:80 70:100

set qos wred 1p2q2t tx queue 2 40:80 70:100

set qos cos-dscp-map 0 8 16 26 32 46 48 56

set qos ipprec-dscp-map 0 8 16 26 32 46 48 56

New Member

Re: How to prioritize voice traffic using c2621 and cisco IP tel

This sort of question is answered by attending the Cisco Deploying Quality of Service course ;)

It is a very good course actually.

664
Views
0
Helpful
3
Replies