Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

I am trying to figure out how to make/ensure there is ANI/Caller ID on outg

I am trying to figure out how to make/ensure there is ANI/Caller ID on outgoing POTS dial-peers. This has been a frustrating challenge…

I have T1 E&M connections to both a voicemail (Octel) and PBX using both a 3660 and 2651 gateway.

I simply want to know two things, how can I tell that ANI is being sent and what it is.

Here is an example configuration:

cas2600#show ver

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-JS-M), Version 12.2(liszt_dev1.0.1.0), CISCO DEVELOPMENT TEST VERSION

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Mon 11-Feb-02 16:07 by shawnk

Image text-base: 0x80008088, data-base: 0x81A17AFC

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

cas2600 uptime is 7 weeks, 1 day, 19 hours, 18 minutes

System returned to ROM by power-on

System restarted at 19:00:32 GMT Wed May 22 2002

System image file is "flash:c2600-js-mz-liszt_dev1.0.1.0.bin"

cisco 2651 (MPC860P) processor (revision 0x200) with 59392K/6144K bytes of memory.

Processor board ID JAB05410H6K (2064170137)

M860P processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

TN3270 Emulation software.

Primary Rate ISDN software, Version 1.1.

2 FastEthernet/IEEE 802.3 interface(s)

2 Channelized T1/PRI port(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

cas2600#show run

Building configuration...

Current configuration : 6504 bytes

!

! Last configuration change at 09:15:13 GMT Fri Jul 12 2002

! NVRAM config last updated at 16:45:33 GMT Wed Jun 26 2002

!

version 12.2

no parser cache

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname cas2600

!

boot system flash c2600-js-mz-liszt_dev1.0.1.0.bin

no logging buffered

logging console emergencies

enable secret 5 --moderator edit--

enable password gw2600

!

clock timezone GMT -8

voice-card 1

!

ip subnet-zero

!

!

ip ftp username root

ip ftp password password

ip domain-name sylantrolab.com

ip name-server 172.16.x.x

ip name-server 172.16.x.x

name-server 172.16.x.x

ip name-server 172.16.x.x

!

isdn switch-type primary-5ess

!

!

!

voice service voip

h323

!

voice class codec 1

codec preference 1 g711ulaw

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller T1 1/0

framing sf

clock source internal

linecode ami

ds0-group 0 timeslots 1-22 type e&m-wink-start

ds0-group 1 timeslots 23-24 type e&m-wink-start

description Octel VM

!

controller T1 1/1

framing esf

clock source internal

linecode b8zs

cablelength short 133

ds0-group 0 timeslots 1-24 type e&m-wink-start

description Chatterbox

!

translation-rule 1

Rule 1 null null

!

!

!

!

interface Tunnel1

no ip address

!

interface FastEthernet0/0

ip address 172.16.x.x 255..255.255.0

duplex auto

speed auto

no cdp enable

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

no cdp enable

!

interface Dialer100

no ip address

no ip mroute-cache

no cdp enable

!

ip default-gateway 172.16.x.x

ip classless

ip route profile

no ip http server

ip pim bidir-enable

!

!

no cdp run

!

!

call rsvp-sync

!

!

voice-port 1/0:0

output attenuation 3

echo-cancel coverage 32

timing clear-wait 1000

timing wink-duration 250

timing hookflash-in 600

station-id name Octel VM

station-id number xxxxxxxxxx

!

voice-port 1/0:1

output attenuation 3

echo-cancel coverage 32

timing clear-wait 1000

timing wink-duration 250

timing hookflash-in 600

station-id name MWI

station-id number xxxxxxxxxx

!

voice-port 1/1:0

output attenuation 3

echo-cancel coverage 32

timing clear-wait 1000

timing wink-duration 250

timing hookflash-in 600

station-id name chatterbox

station-id number xxxxxxxxxx

!

mgcp ip qos dscp cs5 media

mgcp ip qos dscp cs3 signaling

no mgcp timer receive-rtcp

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 5000 voip

preference 1

application castransfer

incoming called-number 5[1-4].%

destination-pattern [2-9]......T

progress_ind setup enable 3

voice-class codec 1

session protocol sipv2

session target sip-server

dtmf-relay rtp-nte

no vad

!

dial-peer voice 5010 voip

description MWI CAS

preference 1

application castransfer

destination-pattern *9[4-5]....

voice-class codec 1

session protocol sipv2

session target ipv4:172.16.x.x

dtmf-relay rtp-nte

no vad

!

dial-peer voice 5020 voip

description cas to pri call

preference 1

application castransfer

destination-pattern 1..........

voice-class codec 1

session protocol sipv2

session target ipv4:172.16.x.x

dtmf-relay rtp-nte

no vad

!

dial-peer voice 1010 pots

preference 2

application session

destination-pattern xxxx

port 1/0:0

!

dial-peer voice 1020 pots

preference 2

application session

destination-pattern xxxxxx

port 1/0:0

!

dial-peer voice 1030 pots

preference 2

application session

destination-pattern xxxxxxxxxx

port 1/0:0

!

dial-peer voice 1040 pots

description CAS VM integration

preference 2

application castransfer

destination-pattern 51.%

no digit-strip

port 1/0:0

!

dial-peer voice 1050 pots

description CAS VM integration

preference 2

application castransfer

destination-pattern 52....

no digit-strip

port 1/0:0

!

dial-peer voice 1060 pots

description CAS VM integration

preference 2

application castransfer

destination-pattern 53....

no digit-strip

port 1/0:0

!

dial-peer voice 1070 pots

description CAS VM integration

preference 2

application castransfer

destination-pattern 54....

no digit-strip

port 1/0:0

!

dial-peer voice 1080 pots

preference 2

application session

destination-pattern xxxx

port 1/1:0

!

dial-peer voice 1090 pots

preference 2

application session

destination-pattern xxxxxxxx

port 1/1:0

!

dial-peer voice 2000 pots

preference 2

application session

destination-pattern xxxxxxxxxx

port 1/1:0

!

gateway

!

sip-ua

max-forwards 2

retry invite 7

retry response 7

retry bye 7

retry cancel 7

timers trying 1000

timers expires 300000

timers connect 1000

timers disconnect 1000

no oli

sip-server ipv4:172.16.x.x

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

exec-timeout 0 0

password --moderator edit--

login

!

no scheduler allocate

ntp clock-period 17180508

ntp server 172.16.x.x

!

end

3 REPLIES

Re: I am trying to figure out how to make/ensure there is ANI/Ca

Since there has been no response to your post, it appears to be either too complex or too rare an issue for other forum members to assist you. If you don't get a suitable response to your post, you may wish to review our resources at the online Technical Assistance Center (http://www.cisco.com/tac) or speak with a TAC engineer. You can open a TAC case online at http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

Thank you for posting.

New Member

Re: I am trying to figure out how to make/ensure there is ANI/Ca

E&M Wink does not support Caller-ID. E&M Feature Group D does, but that's basically like ISDN PRI and usually costs as much if not more that PRI.

New Member

Re: I am trying to figure out how to make/ensure there is ANI/Ca

Thanks. I worked out that I have to configure the 2600 trunks and E&M-FGD. Unfortunately, the gateway does not provide dial-tone when configured as E&M-FGD.

227
Views
0
Helpful
3
Replies
CreatePlease to create content