Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

I'm having problems to activate LLQ QoS in a Data Network.

The data network is working appropriately. When I trying to activate LLQ QoS in the network, the voice listen with distortion although the LLQ queues are working. I have a Cisco 3660 in the primary site and Cisco 1750 in the remotes sites with Bandwith of 128 Kbps and Cir 128 Kbps.

To information way I must indicate that the connection is full almost all along but I have understood that when Quality activates on watch the voice would have to work with priority on the data.

  • Other Collaboration Voice and Video Subjects
7 REPLIES
New Member

Re: I'm having problems to activate LLQ QoS in a Data Network.

Can you post your configs so we can have a look?

Vance

Anonymous
N/A

Re: I'm having problems to activate LLQ QoS in a Data Network.

Here configs:

Principal Site:

ip subnet-zero

!

!

no ip domain-lookup

ip name-server 200.44.32.12

ip name-server 200.44.32.13

!

!

class-map match-all calidad

match access-group 102

class-map match-all signaling

match access-group 103

!

!

policy-map voice-policy

class calidad

priority 36

class signaling

bandwidth 8

class class-default

fair-queue

!

call rsvp-sync

!

!

!

!

!

fax interface-type modem

mta receive maximum-recipients 0

!

!

!

interface FastEthernet0/0

ip address 192.168.2.1 255.255.255.0 secondary

ip address 200.44.49.129 255.255.255.240

no ip mroute-cache

speed auto

half-duplex

h323-gateway voip interface

h323-gateway voip id BIBLIOTECA ipaddr 192.168.2.1 1718

h323-gateway voip h323-id central

h323-gateway voip bind srcaddr 192.168.2.1

!

interface Ethernet2/0

no ip address

shutdown

half-duplex

!

interface Serial2/0

description Enlace con Internet de CANTV

no ip address

encapsulation frame-relay

no ip mroute-cache

no fair-queue

!

interface Serial2/0.178 point-to-point

description Enlace CANTV

bandwidth 2048

ip address 200.44.108.142 255.255.255.252

ip nat outside

no ip mroute-cache

frame-relay interface-dlci 178

class voip1024

!

interface Serial2/1

description Enlace con las Localidades

no ip address

encapsulation frame-relay

frame-relay traffic-shaping

!

interface Serial2/1.30 point-to-point

bandwidth 64

ip address 192.168.11.1 255.255.255.252

ip nat inside

frame-relay interface-dlci 30

!

interface Serial2/1.100 point-to-point

description Enlace Fco Miranda

bandwidth 128

ip address 192.168.40.5 255.255.255.252

ip nat inside

no ip mroute-cache

frame-relay class voipovfr

frame-relay interface-dlci 100

!

interface Serial2/1.101 point-to-point

description Enlace con CORPOSALUD

bandwidth 256

ip address 192.168.60.9 255.255.255.252

ip nat inside

frame-relay class voip256

frame-relay interface-dlci 101

!

interface Serial2/1.105 point-to-point

description Enlace Meteorologia

bandwidth 128

ip address 192.168.40.29 255.255.255.252

ip nat inside

frame-relay interface-dlci 105

!

interface Serial2/1.110 point-to-point

description Enlace Cana de Azucar

bandwidth 256

ip address 192.168.40.1 255.255.255.252

ip nat inside

no ip mroute-cache

frame-relay interface-dlci 110

class voip256cir256

!

interface Serial2/1.120 point-to-point

description Enlace Ocumare

ip address 192.168.50.1 255.255.255.0

ip nat inside

no ip mroute-cache

frame-relay interface-dlci 120

class voipprueba

!

interface Serial2/1.405 point-to-point

description Enlace Hospital

bandwidth 128

ip address 192.168.40.13 255.255.255.252

ip nat inside

no ip mroute-cache

frame-relay interface-dlci 405

class voip128cir128

!

interface Serial2/1.410 point-to-point

description Conexion La Victoria

bandwidth 128

ip address 192.168.40.21 255.255.255.252

ip nat inside

no ip mroute-cache

frame-relay class voipovfr

frame-relay interface-dlci 410

frame-relay ip rtp header-compression

!

interface Serial2/1.415 point-to-point

description Enlace Villa de Cura

bandwidth 256

ip address 192.168.40.9 255.255.255.252

ip nat inside

no ip mroute-cache

frame-relay interface-dlci 415

class voip256cir256

!

interface Serial2/1.420 point-to-point

description Enlace INPOL

bandwidth 32

ip address 192.168.40.25 255.255.255.252

ip nat inside

no ip mroute-cache

frame-relay interface-dlci 420

!

interface Serial2/1.425 point-to-point

description Enlace Barbacoa

bandwidth 64

ip address 192.168.40.33 255.255.255.252

ip nat inside

no ip mroute-cache

frame-relay interface-dlci 425

class voip64cir64

!

ip nat translation timeout 600

ip nat translation tcp-timeout 600

ip nat pool BvMBvA 200.44.49.135 200.44.49.141 netmask 255.255.255.240

ip nat inside source list 2 pool BvMBvA overload

ip classless

ip route 0.0.0.0 0.0.0.0 200.44.108.141

ip route 10.0.0.0 255.255.255.0 192.168.11.2

ip route 10.10.1.0 255.255.255.0 192.168.40.26

ip route 10.29.0.0 255.255.0.0 192.168.60.10

ip route 100.100.0.0 255.255.0.0 192.168.60.10

ip route 192.168.1.0 255.255.255.0 192.168.40.30

ip route 192.168.3.0 255.255.255.0 192.168.40.2

ip route 192.168.4.0 255.255.255.0 192.168.40.6

ip route 192.168.6.0 255.255.255.0 192.168.40.14

ip route 192.168.7.0 255.255.255.0 192.168.50.2

ip route 192.168.8.0 255.255.255.0 192.168.40.34

ip route 192.168.9.0 255.255.255.0 192.168.40.22

ip route 192.168.10.0 255.255.255.0 192.168.40.10

no ip http server

ip pim bidir-enable

!

!

map-class frame-relay voip1024

frame-relay cir 1024000

no frame-relay adaptive-shaping

!

map-class frame-relay voipovfr

frame-relay cir 128000

frame-relay bc 1280

frame-relay mincir 128000

frame-relay fragment 80

no frame-relay adaptive-shaping

service-policy output voice-policy

!

map-class frame-relay voip256

frame-relay cir 256000

no frame-relay adaptive-shaping

frame-relay fair-queue

!

map-class frame-relay voip256cir256

frame-relay cir 256000

frame-relay bc 2560

frame-relay fragment 80

frame-relay ip rtp priority 16384 16383 40

no frame-relay adaptive-shaping

frame-relay fair-queue

!

map-class frame-relay voipprueba

frame-relay cir 128000

frame-relay bc 1280

frame-relay fragment 80

frame-relay ip rtp priority 16384 16383 40

no frame-relay adaptive-shaping

frame-relay fair-queue

!

map-class frame-relay voip128cir128

frame-relay cir 128000

frame-relay bc 1280

frame-relay fragment 80

frame-relay ip rtp priority 16384 16383 40

no frame-relay adaptive-shaping

frame-relay fair-queue

!

map-class frame-relay voip64cir64

frame-relay cir 64000

frame-relay bc 640

frame-relay fragment 80

frame-relay ip rtp priority 16384 16383 24

no frame-relay adaptive-shaping

frame-relay fair-queue

!

map-class frame-relay voip128

frame-relay cir 128000

no frame-relay adaptive-shaping

!

map-class frame-relay voip

frame-relay cir 32000

no frame-relay adaptive-shaping

frame-relay fair-queue

!

map-class frame-relay voip128cir64

frame-relay cir 64000

frame-relay bc 640

frame-relay fragment 80

frame-relay ip rtp priority 16384 16383 45

no frame-relay adaptive-shaping

frame-relay fair-queue

!

map-class frame-relay voip64cir32

frame-relay cir 32000

frame-relay bc 320

frame-relay fragment 80

frame-relay ip rtp priority 16384 16383 24

no frame-relay adaptive-shaping

frame-relay fair-queue

!

map-class frame-relay fragment40

no frame-relay adaptive-shaping

frame-relay fair-queue

access-list 2 permit 192.168.0.0 0.0.255.255

access-list 2 permit 10.10.0.0 0.0.255.255

access-list 2 permit 10.29.0.0 0.0.255.255

access-list 2 permit 100.100.0.0 0.0.255.255

access-list 2 permit 10.0.0.0 0.255.255.255

access-list 102 permit udp any any range 16384 37276

access-list 103 permit tcp any eq 1719 any

access-list 103 permit tcp any any eq 1719

access-list 103 permit tcp any eq 1720 any

access-list 103 permit tcp any any eq 1720

!

snmp-server engineID local 00000009020000E0FE06641C

snmp-server community Bethoven RO

!

voice-port 5/0/0

!

voice-port 5/0/1

!

voice-port 5/1/0

!

voice-port 5/1/1

!

dial-peer cor custom

!

!

!

dial-peer voice 200 pots

destination-pattern 200

port 5/0/0

!

dial-peer voice 201 pots

destination-pattern 201

port 5/0/1

!

dial-peer voice 100 voip

destination-pattern ...

session target ras

!

dial-peer voice 3400 voip

!

gateway

!

!

gatekeeper

zone local BIBLIOTECA BBVVA.COM.VE 192.168.2.1

no shutdown

!

La Victoria Site:

hostname La_Victoria

!

enable secret 5 $1$syG2$CRFKK/vAG.ui1osREeIOR/

!

!

class-map calidad

match access-group 102

class-map signaling

match access-group 103

!

!

policy-map voice-policy

class calidad

priority 36

class signaling

bandwidth 8

class class-default

fair-queue

!

memory-size iomem 25

ip subnet-zero

no ip domain-lookup

!

!

!

!

!

!

!

!

interface Serial0

bandwidth 128

no ip address

encapsulation frame-relay

no ip mroute-cache

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial0.410 point-to-point

description Enlace con Sede Principal

bandwidth 128

ip address 192.168.40.22 255.255.255.252

no ip mroute-cache

frame-relay class voipovfr

frame-relay interface-dlci 410

frame-relay ip rtp header-compression

!

interface FastEthernet0

ip address 192.168.9.1 255.255.255.0

speed auto

h323-gateway voip interface

h323-gateway voip id BIBLIOTECA ipaddr 192.168.2.1 1718

h323-gateway voip h323-id victoria

h323-gateway voip bind srcaddr 192.168.9.1

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.40.21

no ip http server

!

!

map-class frame-relay voipovfr

frame-relay cir 128000

frame-relay bc 1280

frame-relay mincir 128000

no frame-relay adaptive-shaping

service-policy output voice-policy

frame-relay fragment 80

!

map-class frame-relay voip128cir128

frame-relay cir 128000

frame-relay bc 1280

no frame-relay adaptive-shaping

frame-relay fair-queue

frame-relay fragment 80

frame-relay ip rtp priority 16384 16383 40

access-list 102 permit udp any any range 16384 37276

access-list 103 permit tcp any eq 1719 any

access-list 103 permit tcp any any eq 1719

access-list 103 permit tcp any eq 1720 any

access-list 103 permit tcp any any eq 1720

snmp-server engineID local 0000000902000001422DCEB4

snmp-server community victoria RO

snmp-server packetsize 2048

snmp-server enable traps snmp

snmp-server enable traps isdn call-information

snmp-server enable traps isdn layer2

snmp-server enable traps hsrp

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps frame-relay

snmp-server enable traps syslog

snmp-server enable traps rtr

snmp-server enable traps rsvp

snmp-server enable traps dial

snmp-server enable traps voice poor-qov

!

voice-port 1/0

!

voice-port 1/1

!

dial-peer voice 100 voip

destination-pattern ...

session target ras

!

dial-peer voice 260 pots

destination-pattern 260

!

dial-peer voice 261 pots

destination-pattern 261

!

gateway

New Member

Re: I'm having problems to activate LLQ QoS in a Data Network.

Hello,

Ok, couple things you might want to look into.

1) Several of the PVCs have no traffic shaping turned on at all. You'll need to shape all of your PVCs strictly to prevent oversubscription of the circuit. I'm assuming this is an E1 circuit? Make sure to traffic shape the same on both ends of the PVC.

2) You need to fragment all of the PVCs, even the ones not carrying voice since they share the same physical circuit. Again, this applies to both ends of every PVC. Fragment to the slowest PVC (32k?). 32k would be 40 bytes with a 10ms delay budget and 80 with a 20ms budget, I believe.

3) Depending on if you're attempting to oversubscribe any of these PVCs or not, you may want to set the DE bit on the non-critical traffic so if the telco discards, they don't discard your voice traffic.

Hope this helps.

Vance

Anonymous
N/A

Re: I'm having problems to activate LLQ QoS in a Data Network.

Ok, thanks You Vance. I will apply your suggestions and later I comment the results to you.

Daniel.

New Member

Re: I'm having problems to activate LLQ QoS in a Data Network.

Hi

Did you test Vance's suggestions for LLQ QOS for your voice traffic?

If so - what are the configs that you now use?

Thanks

Lucy

New Member

Re: I'm having problems to activate LLQ QoS in a Data Network.

Two things - limit your voice traffic to 96k, and apply an appropriate LLQ map class on both the 3660 and 1750 WAN connections that works with the CIR and how much bandwidth that you want to give to voice. One thing that can kill a voice connection is a 0k CIR WAN connection, which makes all traffic DE eligible regardless of being data or voice.

-Jeff

Blue

Re: I'm having problems to activate LLQ QoS in a Data Network.

If you do a "show policy interface " on one of your frame subinterfaces while a voice call is active you will see that the RTP packets are not hitting your priority queue. This is because you are trying to match on the access list, which does not work. If you set the IP precedence in your VOIP dial peers, then change your class map calidad to match IP precedence 5 instead of the access list you will have better luck.

195
Views
0
Helpful
7
Replies