Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Implemention QOS for Voice

Hi,

We have a 2Mbps LL 1:4

we are using CSICO ATA for Voice.

we are using cisco 2620 router .

Here are my questions.

1.Kindly check My config and say whether this QOS config will work for prioritising the Voice.

class-map match-all VOIP-RTP

match ip dscp ef

!

!

policy-map VOICE-QOS

class VOIP-RTP

priority 1024

interface Serial0/0

description ### STPI-GATEWAY-VASHI ###

bandwidth 2048

ip address 213.11.12.115 255.255.255.252

ip access-group 103 in

ip access-group 103 out

service-policy output VOICE-QOS

shutdown

2.How can i filter the HTTP,TELNET,SSH,RDP,FTP traffic.

Kindly help me.

Thanks

Ranga

3 REPLIES

Re: Implemention QOS for Voice

1. Assuming your device/switchports are trusting/setting your RTP to ef then the class-map is ok. Your policy-map is using half the bandwidth available. Cisco recommends only upwards to 33% allocated to the LLQ. This is a design recommendation. Do you plan to have that many calls? That is an estimated 12 or so G711 calls.

2. Can you explain whether you are looking to filter based on QoS or Security? Either way you can do this with ACLs. ACLs can be assigned to class-maps and you would match your traffic on IP or port. Of course ACLs can be used to filter the data traffic by assigning the ACL to the interface with the access-group command. NBAR and CBAC could be used for QOS/Security application aware filtering.

Please rate any helpful posts.

Thanks

Fred

New Member

Re: Implemention QOS for Voice

You also have to check what mappings your switch may have.

For example, some switches map IP Precidence 5 to DSCP 40. EF is 46. You would need to change your mapping to make IP Prec 5 map to DSCP 46.

New Member

Re: Implemention QOS for Voice

A more scalable config (that you dont have to redo too much) might include bandwidth guarantees for other classes of traffic as well...

Also, I like to go with the qos design guide recommendation and set aside a queue for voice signalling... like the following...

i also dont "match ip dscp ef" but rather just look for rtp audio... dont always have a marking switch/phone system behind your router... sometimes its a whitebox phone system sending rtp packets, and a dumb switch... I also go with a nested policy, which shapes all to the speed of the link, then decides which traffic will follow the rules of the child policy to leave the single queue ;)

class-map match-any manage

match protocol dhcp

match protocol dns

match protocol kerberos

match protocol ldap

match protocol snmp

match protocol syslog

class-map match-any bulk

match protocol exchange

match protocol ftp

match protocol pop3

match protocol smtp

class-map match-any voicesignal

match protocol h323

match protocol rtcp

class-map match-any transactional

match protocol citrix

match protocol pcanywhere

match protocol secure-telnet

match protocol sqlnet

match protocol sqlserver

match protocol ssh

match protocol telnet

match protocol tsrvrdp

class-map match-any video

match protocol rtp video

match protocol cuseeme

match protocol netshow

match protocol rtsp

match protocol streamwork

match protocol vdolive

class-map match-any voicebearer

match protocol rtp audio

!

policy-map Pol-S0/0/0.1-child

class voicebearer

set dscp ef

priority percent 25

class transactional

bandwidth percent 25

class voicesignal

bandwidth percent 5

class manage

bandwidth percent 5

policy-map Pol-S0/0/0.1-parent

class class-default

shape average 1444000

service-policy Pol-0/0/0.1-child

int s0/0/0.1

service-policy output Pol-S0/0/0.1-parent

(yes not all my classes are used in my policy; they are for future use... nice to have them in there now though, as they can always be allocated some bandwidth later on, at the expense of what is carved out now...)

Tschuss,

Joe

106
Views
0
Helpful
3
Replies