Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

inbound audio delay

I have a 2620 mgcp gateway running 12.2.15T with config listed below. I am running CM ver 3.3. About 2-3 times a day the receptionist recieves an inbound call but there is approximately a 5 second delay before she can hear the caller. However the caller can hear the receptionist just fine right away. Any ideas?

!

clock timezone CDT -6

clock summer-time CDT recurring

voice-card 1

codec complexity high ecan-extended

!

ip subnet-zero

ip cef

!

no ip domain lookup

!

ip multicast-routing

isdn switch-type primary-ni

!

!

voice call send-alert

voice call carrier capacity active

voice rtp send-recv

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 14 g729r8

!

voice class h323 1

h225 timeout tcp establish 1

!

no voice hpi capture buffer

no voice hpi capture destination

!

ccm-manager switchback immediate

ccm-manager fallback-mgcp

ccm-manager mgcp

no ccm-manager fax protocol cisco

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller T1 1/0

framing esf

linecode b8zs

cablelength short 133

pri-group timeslots 1-12,24 service mgcp

!

class-map match-all VOIP-Contrl

match access-group name VOIP-Control

class-map match-all VOIP-Bearer

match access-group name VOIP-Bearer

class-map match-all Call-Control

match ip dscp af31

class-map match-all Voice

match ip dscp ef

!

policy-map VOIP-Policy

class VOIP-Bearer

set dscp ef

class VOIP-Contrl

set dscp af31

policy-map VOIP-Policy-T1

class Voice

priority percent 70

class Call-Control

bandwidth percent 5

class class-default

fair-queue

!

interface FastEthernet0/0

ip address X.X.X.X 255.255.255.0

ip pim dense-mode

service-policy input VOIP-Policy

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr X.X.X.X

!

interface Serial0/0

bandwidth 1536

ip address X.X.X.X 255.255.255.252

ip pim dense-mode

service-policy output VOIP-Policy-T1

service-module t1 timeslots 1-24

service-module t1 remote-alarm-enable

!

interface Serial1/0:23

no ip address

no logging event link-status

no snmp trap link-status

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no isdn incoming alerting add-PI

no cdp enable

!

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 X.X.X.X

!

ip pim bidir-enable

!

!

ip access-list extended VOIP-Bearer

permit udp any any range 16384 32767

ip access-list extended VOIP-Control

permit tcp any any range 2000 2002

permit tcp any any eq 1720

permit tcp any any range 11000 11999

permit tcp any any eq 2428

permit udp any any eq 2427

permit udp any any eq 1719

permit udp any any eq 5060

!

!

linkdown linkup coldstart warmstart

call rsvp-sync

!

call application alternate DEFAULT

!

voice-port 1/0:23

echo-cancel erl worst-case 3

echo-cancel suppressor 10

!

mgcp

mgcp call-agent X.X.X.X service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp package-capability rtp-package

no mgcp timer receive-rtcp

!

mgcp profile default

!

dial-peer cor custom

!

dial-peer voice 117 pots

tone ringback alert-no-PI

preference 1

application mgcp

incoming called-number .

destination-pattern 9

direct-inward-dial

port 1/0:23

!

call-manager-fallback

limit-dn 7940 1

limit-dn 7960 2

ip source-address X.X.X.X port 2000 strict-match

max-ephones 24

max-dn 48

alias 1 XXXXXXX to 3001

3 REPLIES
Silver

Re: inbound audio delay

We also had the same exact problem for a customer. It was intermittent throught the day. Changed to phone load cmterm-7940-7960.P003-3-3-4.exe which resolved the problem.

You can find that load from this page.

http://www.cisco.com/cgi-bin/tablebuild.pl/ip-7900ser

--Partha

New Member

Re: inbound audio delay

We are having the same issue. I have worked with Cisco a few times with no luck. Its hard to capture the debug information they are looking for when it only happens every so often. About a month ago this was a huge issue and after rebooting the CM it seemed to resolve all of the issues, but now it is starting to happen again. We are running CM 3.3(2) and phone load P00305000400. I am doing the latest patch and OS upgrades this weekend. Have you had any luck since posting?

New Member

Re: inbound audio delay

I'm sure TAC has already covered this ground, but make sure you are running the same version of the attendant console on the client and the server. Mismatches can cause weird problems.

130
Views
0
Helpful
3
Replies
CreatePlease to create content