Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Incoming and outgoing VOIP Dial peer

I have the following setup

A 1760 router (hostname=RL01) where the FastEthernet 0/0 port is connected to the CallManager Subnet and a WIC-1T serial interface is connected second 1760 router (hostname=RL02).

On RL02 I have connected an analog phone to a FXS port. What I'm trying to accomplish is to make a phone call from my analog phone across the point-to-point link to and IP phone. See dial peer's below:

RL01 Config

interface FastEthernet0/0

ip address 172.17.13.99 255.255.255.0 {CallManager Subnet}

!

interface Serial0/0

ip address 172.17.15.1 255.255.255.0 {P-2-P link to remote Lan}

encapsulation ppp

no fair-queue

dial-peer voice 98 voip {VOIP Peer To remote analog phone}

destination-pattern 7099

session target ipv4:172.17.15.2

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 97 voip {VOIP peer to CallManager}

destination-pattern 6000

session target ipv4:172.17.13.10

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

RL02 Config

interface Serial0/0

ip address 172.17.15.2 255.255.255.0 {P-2-P link to remote Lan}

encapsulation ppp

clockrate 4000000

no fair-queue

dial-peer voice 1 pots {Analog Dial Peer}

destination-pattern 7099

port 2/0

forward-digits 4

!

dial-peer voice 99 voip {VOIP peer to Remote network}

destination-pattern .

session target ipv4:172.17.15.1

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

As a test I tried moving the analog phone to RL01 and put the same dial peer on it and I could sucessfully make phone calls to and from the IP Phones. When I have the analog phone on the remote roter RL02 I get reorder tone.

Here is a "debug voip ccapi inout" output from making a call from Analog to IP phone

*Mar 1 23:38:32.678: cc_api_call_setup_ind:

*Mar 1 23:38:32.682: cisco-username=172.17.15.2

*Mar 1 23:38:32.682: ----- ccCallInfo IE subfields -----

*Mar 1 23:38:32.682: cisco-ani=7099

*Mar 1 23:38:32.682: cisco-anitype=0

*Mar 1 23:38:32.682: cisco-aniplan=0

*Mar 1 23:38:32.682: cisco-anipi=0

*Mar 1 23:38:32.682: cisco-anisi=0

*Mar 1 23:38:32.682: dest=6000

*Mar 1 23:38:32.682: cisco-desttype=0

*Mar 1 23:38:32.682: cisco-destplan=1

*Mar 1 23:38:32.682: cisco-rdn=

*Mar 1 23:38:32.682: cisco-rdntype=-1

*Mar 1 23:38:32.682: cisco-rdnplan=-1

*Mar 1 23:38:32.682: cisco-rdnpi=-1

*Mar 1 23:38:32.682: cisco-rdnsi=-1

*Mar 1 23:38:32.682: cisco-redirectreason=-1

*Mar 1 23:38:32.682: //-1/xxxxxxxxxxxx/CCAPI/cc_api_call_setup_ind: (vdbPtr=0x8246B6A8, callInfo={called=6000,called_oct3=0x81,calling=7099,calling_oct3=0x80,calling_oct3a=0x0,calling_xlated=false,subscriber_type_str=Unknown,fdest=1,peer_tag=98, prog_ind=3,callingIE_present 1, src_route_label=, tgt_route_label= clid_transparent=0},callID=0x81DC7C5C)

*Mar 1 23:38:32.682: //-1/xxxxxxxxxxxx/CCAPI/cc_api_call_setup_ind:

*Mar 1 23:38:32.682: //-1/xxxxxxxxxxxx/CCAPI/cc_api_call_setup_ind: type 0 , prot 1

*Mar 1 23:38:32.682: //-1/xxxxxxxxxxxx/CCAPI/ccCheckClipClir:

*Mar 1 23:38:32.682: ccCheckClipClir: calling number is: "7099", calling oct3a is: 0x0

*Mar 1 23:38:32.682: //-1/xxxxxxxxxxxx/CCAPI/ccCheckClipClir:

*Mar 1 23:38:32.682: Calling Party number is User Provided

*Mar 1 23:38:32.682: //-1/xxxxxxxxxxxx/CCAPI/ccCheckClipClir:

*Mar 1 23:38:32.682: Leaving ccCheckClipClir

calling number is: "7099"

calling oct3 is: 0x80

calling oct3a is: 0x0

*Mar 1 23:38:32.686: //-1/xxxxxxxxxxxx/CCAPI/cc_api_call_setup_ind: (vdbPtr=0x8246B6A8, callInfo={called=6000, calling=7099, fdest=1 peer_tag=98}, callID=0x81DC7C5C)

*Mar 1 23:38:32.686: //59/xxxxxxxxxxxx/CCAPI/cc_insert_call_entry: Increment call volume: 0

*Mar 1 23:38:32.686: //59/xxxxxxxxxxxx/CCAPI/cc_insert_call_entry: current call volume: 1

*Mar 1 23:38:32.686: //59/xxxxxxxxxxxx/CCAPI/cc_insert_call_entry: entry's incoming TRUE.

*Mar 1 23:38:32.686: //59/xxxxxxxxxxxx/CCAPI/cc_insert_call_entry: is_incoming is FALSE

*Mar 1 23:38:32.686: //-1/xxxxxxxxxxxx/CCAPI/ccTDConstructHashProfileTab: profileTable[0x81DC44B4], numBuckets[11], numEntries[0]

*Mar 1 23:38:32.686: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtProfileTableBuildManager: Invoking necessary profileTable updaters...

*Mar 1 23:38:32.686: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtUpdateProfileTabFromContainer: Updating profileTable[0x81DC44B4] with objects in container[0x81DC2E90]

*Mar 1 23:38:32.686: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtUpdateProfileTabFromContainer: obtained key[5] for the tag[6]

*Mar 1 23:38:32.686: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtAddObjectToProfileBucket: profileTable[0x81DC44B4], tdObject[0x81DD6194]

*Mar 1 23:38:32.686: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtUpdateProfileTabFromContainer: obtained key[0] for the tag[5]

*Mar 1 23:38:32.690: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtAddObjectToProfileBucket: profileTable[0x81DC44B4], tdObject[0x81DD61F4]

*Mar 1 23:38:32.690: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtUpdateProfileTabFromContainer: obtained key[6] for the tag[19]

*Mar 1 23:38:32.690: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtAddObjectToProfileBucket: profileTable[0x81DC44B4], tdObject[0x82435728]

*Mar 1 23:38:32.690: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtUpdateProfileTabFromContainer: obtained key[0] for the tag[22]

*Mar 1 23:38:32.690: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtAddObjectToProfileBucket: profileTable[0x81DC44B4], tdObject[0x81DD62C4]

*Mar 1 23:38:32.690: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtProfileTableBuildManager:

*Mar 1 23:38:32.690: ccTDUtilDumpAllElemInProfileTab: profileTable[0x81DC44B4], numBuckets[11], numEntries[4]

*Mar 1 23:38:32.690: Bucket { 0 } ------>0x81DD61F4[0x81DD62C4,t-5,l-44,d-0x81DD6214,m-4,u-85112,g-FACE0FFF]------>0x81DD62C4[0x0,t-22,l-12,d-0x81DD62E4,m-4,u-85112,g-FACE0FFF]

*Mar 1 23:38:32.690:

*Mar 1 23:38:32.690: Bucket { 5 } ------>0x81DD6194[0x0,t-6,l-16,d-0x81DD61B4,m-2,u-85112,g-FACE0FFF]

*Mar 1 23:38:32.690:

*Mar 1 23:38:32.690: Bucket { 6 } ------>0x82435728[0x0,t-19,m-2,g-FACE0FFF 0x81DD6270,i-0<t-19,l-4,d-0x81DD6290,m-2,u-85112,g-FACE0FFF> ]

*Mar 1 23:38:32.690:

*Mar 1 23:38:32.690: //-1/xxxxxxxxxxxx/CCAPI/ccTDDestructTDUsrContainer: Container[0x81DC2E90]

*Mar 1 23:38:32.694: //-1/xxxxxxxxxxxx/CCAPI/cc_incr_if_call_volume: remote IP is 172.17.15.2

*Mar 1 23:38:32.694: //-1/xxxxxxxxxxxx/CCAPI/cc_incr_if_call_volume: hwidb is Serial0/0

*Mar 1 23:38:32.694: //-1/xxxxxxxxxxxx/CCAPI/cc_incr_if_call_volume: create entry in list: 1

*Mar 1 23:38:32.694: //-1/xxxxxxxxxxxx/CCAPI/cc_can_gateway: Call legs: In=1, Out=1

*Mar 1 23:38:32.694: //-1/xxxxxxxxxxxx/CCAPI/cc_can_gateway: Call legs: In=3, Out=3

*Mar 1 23:38:32.694: //-1/xxxxxxxxxxxx/CCAPI/cc_can_gateway: Call legs: In=1, Out=3

*Mar 1 23:38:32.694: //-1/xxxxxxxxxxxx/CCAPI/cc_can_gateway: Call legs: In=3, Out=1

*Mar 1 23:38:32.698: //-1/xxxxxxxxxxxx/CCAPI/cc_process_call_setup_ind: (event=0x825A996C)

*Mar 1 23:38:32.698: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_registration_lookup: matching parameters - called# [6000], calling# [7099], consultid []

*Mar 1 23:38:32.698: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search: Searching for node with called# [6000], calling# [7099], consultid []

*Mar 1 23:38:32.698: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_registration_lookup: No matching node

*Mar 1 23:38:32.698: //59/D21987098077/CCAPI/cc_process_call_setup_ind: >>>>CCAPI handed cid 59 with tag 98 to app "DEFAULT"

*Mar 1 23:38:32.698: //59/xxxxxxxxxxxx/SSAPP:-1:-1/sess_appl: ev(24=CC_EV_CALL_SETUP_IND), cid(59), disp(0)

*Mar 1 23:38:32.698: //59/xxxxxxxxxxxx/SSAPP:-1:-1/sess_appl: ev(SSA_EV_CALL_SETUP_IND), cid(59), disp(0)

*Mar 1 23:38:32.698: //59/xxxxxxxxxxxx/SSAPP:-1:-1/ssaCallSetupInd:

*Mar 1 23:38:32.698: //59/xxxxxxxxxxxx/CCAPI/ccCallSetContext: (callID=0x3B, context=0x81DC21E4)

*Mar 1 23:38:32.698: //59/D21987098077/SSAPP:98:-1/ssaCallSetupInd: cid(59), st(SSA_CS_MAPPING),oldst(0), ev(24)ev->e.evCallSetupInd.nCallInfo.finalDestFlag = 1

*Mar 1 23:38:32.702: //59/D21987098077/SSAPP:98:-1/ssaCallSetupInd: src route label=, tgt route label= tg_label_flag 0x0

*Mar 1 23:38:32.702: //59/D21987098077/SSAPP:98:-1/ssaCallSetupInd: finalDest cllng(7099), clled(6000) tgt_route_label()tg_label_flag 0x0

*Mar 1 23:38:32.702: //59/D21987098077/SSAPP:98:-1/ssaCallSetupInd: cid(59), st(SSA_CS_CALL_SETTING),oldst(0), ev(24)dpMatchPeersMoreArg result= 0

*Mar 1 23:38:32.702: //59/D21987098077/SSAPP:98:-1/ssaDebugPeers: ssaSetupPeer cid(59) peer list: tag(97) called number (6000)

*Mar 1 23:38:32.702: //59/D21987098077/SSAPP:98:-1/ssaSetupPeer: dialpeer tags in rotary= 97

*Mar 1 23:38:32.702: //59/D21987098077/SSAPP:98:-1/ssaSetupPeer: cid(59), destPat(6000), matched(0), prefix(), peer(81DDF044), peer->encapType (2)

*Mar 1 23:38:32.702: //-1/xxxxxxxxxxxx/CCAPI/cc_can_gateway: Call legs: In=1, Out=1

*Mar 1 23:38:32.702: //59/D21987098077/SSAPP:98:-1/ssaSetupPeer: cid(59), can't gateway with peer tag(97))

*Mar 1 23:38:32.702: //59/xxxxxxxxxxxx/CCAPI/ccTDUtilGetDataByValue: CallID[59], tagID[24], instID[-1]

*Mar 1 23:38:32.702: //59/xxxxxxxxxxxx/CCAPI/

3 REPLIES
Silver

Re: Incoming and outgoing VOIP Dial peer

On RL02 change the destination pattern from . to either .... or .T

dial-peer voice 99 voip {VOIP peer to Remote network}

destination-pattern ....

A . matches a single dialed digit, in which case if you dial 6000, there is no match and hence reorder tone.

Silver

Re: Incoming and outgoing VOIP Dial peer

Just point the voip dial-peer on RL02 to the callmanager instead of the next hop router

dial-peer voice 99 voip

destination-pattern .

session target ipv4:172.17.13.10

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

New Member

Re: Incoming and outgoing VOIP Dial peer

Thanks, this worked

I also had to setup another gateway in my CallManager to point to RL02. I thought you had to point everything to one gateway and route to your remote sites from there.

Cheers Ryan

182
Views
0
Helpful
3
Replies