Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Integrate B-ACD with UCM 6.1

Hi, I have a router 2821, I configured a B-ACD on the router and it's working fine (I can dial the CME extensions only). Now i want to dial the extensions of UCM 6.1 which is in the same network

the scenario as the following:

PSTN --> router 2821 with B-ACD --> extension 7132 on the UCM 6.1

is this doable or not?

Router IP 172.16.12.184

UCM 6.1 IP 172.16.35.20

application
service aa flash:app-b-acd-aa-2.1.0.0.tcl
  paramspace english index 1
  param number-of-hunt-grps 2
  param dial-by-extension-option 1
  param handoff-string aa
  paramspace english language en
  param max-time-vm-retry 2
  param aa-pilot 8025
  paramspace english location flash:
  param second-greeting-time 60
  param welcome-prompt _bacd_welcome.au
  param call-retry-timer 15
  param max-time-call-retry 700
  param voice-mail 5003
  param service-name queue
!
service queue flash:app-b-acd-2.1.0.0.tcl
  param queue-len 15
  param aa-hunt0 2222
  param queue-manager-debugs 1
  param number-of-hunt-grps 2
!
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 172.16.12.184 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.12.1
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
dial-peer voice 8025 voip
service aa
destination-pattern 8025
session target ipv4:172.16.12.184
incoming called-number 8025
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 7132 voip
destination-pattern 7132
session target ipv4:172.16.35.20
codec g711ulaw
!
!
!
telephony-service
max-ephones 3
max-dn 3
ip source-address 172.16.12.184 port 2000
auto assign 1 to 3
network-locale GB
network-locale 1 GB
network-locale 2 GB
network-locale 3 GB
network-locale 4 GB
max-conferences 12 gain -6
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1  dual-line
number 5445
!
!
ephone-dn  2  dual-line
number 5446
!
!
ephone-dn  3  dual-line
number 5447
!
!
ephone  1
no phone-ui speeddial-fastdial
no phone-ui snr
no multicast-moh
mac-address 001A.6C7B.5726
type CIPC
button  1:1
!
!
!
ephone  2
no phone-ui speeddial-fastdial
no phone-ui snr
no multicast-moh
!
!
!
ephone  3
no phone-ui speeddial-fastdial
no phone-ui snr
no multicast-moh
!
!
ephone-hunt 2 longest-idle
pilot 2222
list 5445

11 REPLIES
Hall of Fame Super Gold

Re: Integrate B-ACD with UCM 6.1

It should be possible, however not supported by cisco.

New Member

Re: Integrate B-ACD with UCM 6.1

Thanks for replay but still i need answer for the question

Hall of Fame Super Gold

Re: Integrate B-ACD with UCM 6.1

I have replied you above, what is that you do not understand ?

New Member

Re: Integrate B-ACD with UCM 6.1

What is the solution? how can i make a call to UCM extension 7132. With the current configuration pasted above when i make call to 7132 it drops so is there something missing in this configuration?

Super Bronze

Re: Integrate B-ACD with UCM 6.1

Are you able to make normal CME IP phone to CallManager calls?

Have you added the CME gateawy to CallManager as a H.323 gateway by IP Address and reset it?

Regards

Aaron              

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Re: Integrate B-ACD with UCM 6.1

Yes i can make call from IP phone registered with CME to IP phone registered with Callmanager and router is added as H323 gateway and is registered,

but i am unable to make any call from B-ACD to call manager IP Phone 7132

Super Bronze

Re: Integrate B-ACD with UCM 6.1

Hi

I see you have a dial-peer for 7132, however I don't see where you have programmed the B-ACD to use 7132?

You would need to add 7132 as the destination for a hunt group 'param aa-hunt1 7132' for example...

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Re: Integrate B-ACD with UCM 6.1

application
service aa flash:app-b-acd-aa-2.1.0.0.tcl
  paramspace english index 1
  param number-of-hunt-grps 2
  param dial-by-extension-option 1
  param handoff-string aa
  paramspace english language en
  param max-time-vm-retry 2
  param aa-hunt1 7132
  param aa-pilot 8025
  paramspace english location flash:
  param second-greeting-time 60
  param welcome-prompt _bacd_welcome.au
  param call-retry-timer 15
  param max-time-call-retry 700
  param voice-mail 5003
  param service-name queue
!
service queue flash:app-b-acd-2.1.0.0.tcl
  param queue-len 15
  param aa-hunt0 2222
  param aa-hunt1 7132
  param number-of-hunt-grps 2
  param queue-manager-debugs 1
!
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 172.16.12.184 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
!
interface ATM0/0/0
no ip address
no atm ilmi-keepalive
pvc 0/35
  pppoe-client dial-pool-number 1
!
!
interface ATM0/1/0
no ip address
no atm ilmi-keepalive
pvc 0/35
  pppoe-client dial-pool-number 2
!
!
interface ATM0/2/0
no ip address
no atm ilmi-keepalive
pvc 0/35
  pppoe-client dial-pool-number 3
!
!
interface Serial0/3/0
no ip address
shutdown
clock rate 2000000
!
interface Dialer1
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname 66100016786@256.saudi.net.sa
ppp chap password 0 81753092
!
interface Dialer2
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 2
ppp authentication chap callin
ppp chap hostname 90850513949@256.nesma.net.sa
ppp chap password 0 42834432
!
interface Dialer3
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 3
ppp authentication chap callin
ppp chap hostname 90850513949@256.nesma.net.sa
ppp chap password 0 42834432
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.12.1
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
dial-peer voice 8025 voip
service aa
destination-pattern 8025
session target ipv4:172.16.12.184
incoming called-number 8025
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 7132 voip
destination-pattern 7132
session target ipv4:172.16.35.20
codec g711ulaw
!
dial-peer voice 1532 voip
destination-pattern 1532
session target ipv4:172.16.100.40
codec g711ulaw
!
!
!
telephony-service
max-ephones 3
max-dn 3
ip source-address 172.16.12.184 port 2000
auto assign 1 to 3
network-locale GB
network-locale 1 GB
network-locale 2 GB
network-locale 3 GB
network-locale 4 GB
max-conferences 12 gain -6
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1  dual-line
number 5445
!
!
ephone-dn  2  dual-line
number 5446
!
!
ephone-dn  3  dual-line
number 5447
!
!
ephone  1
no phone-ui speeddial-fastdial
no phone-ui snr
no multicast-moh
mac-address 001A.6C7B.5726
type CIPC
button  1:1
!
!
!
ephone  2
no phone-ui speeddial-fastdial
no phone-ui snr
no multicast-moh
!
!
!
ephone  3
no phone-ui speeddial-fastdial
no phone-ui snr
no multicast-moh
!
!
ephone-hunt 2 longest-idle
pilot 2222
list 5445
!
!

where exactly you want me to change the configuration??

New Member

Re: Integrate B-ACD with UCM 6.1

the problem solved

the voice service voip solve the problem, why it solve the problem although the dialpeers working with H.323 that is I don't know

New Member

Re: Integrate B-ACD with UCM 6.1

I am trying the same thing B-ACD to UCM.  Sounds like you got it working to your 7132 number.  What did you do to voice service voip to solve the problem?  Can you post a config?

New Member

Re: Integrate B-ACD with UCM 6.1

I just got it working.  I added the allow-connections h323 to h323 in the voice service voip.

562
Views
0
Helpful
11
Replies