Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Intercom not working

Fresh newly installed web server - windows 2000 SP4. Installed Cisco IP Services SDK 3.3.3.

Trying to get intercom.asp script working.

Environment - CM 4.0 and lastest SR release.

Testing with 2 7940 phones. Phones subscribed to http://servername/CiscoIpServices/intercom/intercom.asp

phoneIP is set as a required field, with a default ip address included.

Accessing that webpage via Phone or Web page gives a

pause, and a HTTP 500.100 error screen.

Relevant errors -

msxml3.dll (0x800C0005)

The system cannot locate the resource specified.

/CiscoIPServices/includes/phonepush.asp, line 44

Line 44 phonepush.asp says - xmlhttp.Send(pushxml);

I have modified the intercom.asp script to use a valid directory login, and assigned the login to the two phones.

For the phoneIP I've tried the other phone IP address, and multicast multicast addresses, neither seem to work.

I've manually reinstalled the MSXML3.0 SP2 package that came with the SDK kit. I'm stuck.

Ideas?

-Jason

2 REPLIES
New Member

Re: Intercom not working

Well, problem solved.

General path to resolution...

installed MSXML services 4.0 SP2

unregistered (ie regsvr32 /u C:\winnt\system32\msxml**.dll)

deleted c:\winnt\system32\msxml*.dll

re-ran setup for MSXML services 4.0 SP2, chose to REMOVE.

ran Cisco IP Services MSXML 3.0 SP2.

It works now.

One last quesion for those reviewing this - Intercom pages the phones, and when finished, all the phones on the subnet still have the Services window open. Any way to time that out, clear the screen?

-Jason

New Member

Re: Intercom not working

you did all the msxml stuff on the server? not the client you are developing from?

190
Views
0
Helpful
2
Replies
CreatePlease to create content