Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Intercom Service Won't work :( Why not? - FIXED IT THANKS

Hi guys new to the Group,

I have been playing with the Latest SDK. I have managed to get Hootie to work but I am unable to get Intercom to work correctly.

When I set up the Service I add the IP Address of the phone I want to connect to. I then press the Services button and then the Intercom Service Option the phone I am wanting to speak with Enters the Intercom mode but my phone Shows a <!DOCTYPE HTML PUBLIC"-//W3C/DTD HTML 3.2 Final//EN"> Error Page.

Anybody got any Idea where I am going wrong?

Many Thanks

Dave :)

  • Other Collaboration Voice and Video Subjects
19 REPLIES
New Member

Re: Intercom Service Won't work :( Why not? - FIXED IT THANKS

Have you edited the source as specified???

<%

// - Required COM Servers: Microsoft MSXML

//

// - The 'includes' file(s) listed in the beginning of this file MUST be reachable

// at the specified web path.

//

// - When creating the Intercom Phone Service on CallManager, you MUST specify a

// a Phone Service Parameter for the IP address of the destination intercom

// phone. The Parameter Name must be 'phoneIP' and the parameter should

// be marked as 'Required'.

//

var pushuserid = "sdkapps";

var pushpassword = "sdkapps";

New Member

Re: Intercom Service Won't work :( Why not? - FIXED IT THANKS

Yes I figured it out, but thanks anyway.

Laters

Dave :)

New Member

Re: Intercom Service Won't work :( Why not? - FIXED IT THANKS

what was the answer for us still trying?

New Member

Re: Intercom Service Won't work :( Why not? - FIXED IT THANKS

Craig the attached are my Hootie files. I can't remember is I changed them from the originals.

The Main thing you need to do is make sure both parties are subscribed to the Hootie service, and when you want to speak to each other you both need to join the same group,

i.e. Hoot Group A

Hope this helps you.

Cheers

Dave :)

New Member

Re: Intercom Service Won't work :( Why not? - FIXED IT THANKS

Hi Dave,

I am trying to set up the intercom service for our school. I have set a specific username and password and have done as they say with the phoneIP variable. When I hardcode the remote IP to the phone I want to intercom to it works, however, they get the screen on their phone and on mine I get what you get Error Page, I should be getting the screen not the remote phone correct? How do I fix this error on my screen.

Thanks

Pat

New Member

Re: Intercom Service Won't work :( Why not? - FIXED IT THANKS

Hi Pat,

I found that the simplest thing was to set up a user called ouser (Omni User) with a password of 12345.

Then associated that user with all the phones but making sure there was No Primary Extension Associated with it. This seemed to work for me, I guess it's because the program needs to push to both phones but the program only gives you space for one user name and password.

Hope This Helps.

Dave :)

p.s. I then used a bit of the hootie code to create a list of Users to select to Intercom to rather than have to type a IP address every time. If you want me to post the code I will.

New Member

Re: Intercom Service Won't work :( Why not? - FIXED IT THANKS

Hi Dave,

Thanks for your reply... I tried what you said and still no luck... If I can see what you did with the code I would greatly appreciate it. At this point I would be really happy if I can get the one to one intercom to work. You can email me if you don't want to post it on here.

Thank You Very Much

New Member

Re: Intercom Service Won't work :( Why not? - FIXED IT THANKS

Hi,

Here is code I used. I have changed some bits but can't remember how much of It is custom,

Thanks

Dave.

New Member

Re: Intercom Service Won't work :( Why not? - FIXED IT THANKS

This code works great, I was able to one to one going smoothly. Have you or anyone been able to get a group multicast working?

When I try a multicast address I get the following:

Error Page

Any clues?

Thanks,

Gary

345
Views
0
Helpful
19
Replies