Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

IOS 12.4 and MGCP configuration

hey, having a little issue with configuring MGCP this image. normally, i configure the call agent, codec, mgcp profile and simply bind control and media to my ethernet interface. then create a dial-peer voice pots and issue application MGCPAPP.

thats not working. from what im reading i have to issue a service command. but then i haveto configure MGCP from the global configuration under the application command. as you can see, im getting a bit confused. can anyone help with the new way of doing MGCP. ?

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Re: IOS 12.4 and MGCP configuration

Is your GW registering with CCM?

What do you see when you run "sh ccm-manager"

here is a good MGCP troubleshooting doc:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a008017b2ad.shtml

Chris

Cisco Employee

Re: IOS 12.4 and MGCP configuration

Remove this:

-----------

application

service MGCPAPP mgcp

param mgcp mgcp

!

service session MGCPAPP

!

package mgcp 10.0.0.10

dial-peer voice 1 pots

service appmgcp

--------------------

add this:

mgcp

mgcp package-capa rtp-pack

mgcp dtmf-relay voip codec all out

ccm-manager redundant host

ccm-manager music-on-hold

------------------------

Please go to the call manager and make sure you have the right ports configured. Compare the name of the gateway. It has to be TEST@yourdomain.com.

After that, do a debug mgcp packet.

Then do "no mgcp"

and then "mgcp"

send me the debugs please. If possible, send a screen shot of the gateway configs from teh CCM

Note, the application (global) command is only as an alternative to adding applications under the dial peer. It is not necessary to be configured.

Thanks!

12 REPLIES
Cisco Employee

Re: IOS 12.4 and MGCP configuration

I configured MGCP on 12.4 just a few days ago. I do not recall any service commands..What exactly is happening when you say "thats not working"? Are the end points not registering? Can you please post a show ver, show run and debug mgcp packet ?

Thanks!

Bronze

Re: IOS 12.4 and MGCP configuration

this is a test lab im doing.when i add the gateway (2821) i get the endpoints as not found.

Hall of Fame Super Silver

Re: IOS 12.4 and MGCP configuration

Is your GW registering with CCM?

What do you see when you run "sh ccm-manager"

here is a good MGCP troubleshooting doc:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a008017b2ad.shtml

Chris

Cisco Employee

Re: IOS 12.4 and MGCP configuration

Remove this:

-----------

application

service MGCPAPP mgcp

param mgcp mgcp

!

service session MGCPAPP

!

package mgcp 10.0.0.10

dial-peer voice 1 pots

service appmgcp

--------------------

add this:

mgcp

mgcp package-capa rtp-pack

mgcp dtmf-relay voip codec all out

ccm-manager redundant host

ccm-manager music-on-hold

------------------------

Please go to the call manager and make sure you have the right ports configured. Compare the name of the gateway. It has to be TEST@yourdomain.com.

After that, do a debug mgcp packet.

Then do "no mgcp"

and then "mgcp"

send me the debugs please. If possible, send a screen shot of the gateway configs from teh CCM

Note, the application (global) command is only as an alternative to adding applications under the dial peer. It is not necessary to be configured.

Thanks!

Bronze

Re: IOS 12.4 and MGCP configuration

hey, wow thanks a lot, i did what you said and i still wasnt getting through. i didnt even to the debug. when i did the debug i saw that it was looking for a domain name. went through the config and sure enough i had an ip domain name yourdomain.com which is default. i missed that completely. Not feeling too smart right now but...hum....thanks again...great help. lets keep this on a down low..hehehe

New Member

Re: IOS 12.4 and MGCP configuration

Dear Expertise

Can anyone let me know how to connect local Telophone line to CCM.

What i want if some make a call to my land line it will connect to my cisco IP phones rather than connecting to my POTS phone.

====================================================

I have purchased the following things:

Cisco Router 2620

NM-2V

Vic-2fxo Card

=====================================================

Now i need to configure and dont know where to start.

Waiting for reply

Thanks

Hall of Fame Super Silver

Re: IOS 12.4 and MGCP configuration

The best solution for you would be to configure the router as a MGCP Gateway (you could also do H.323). With MGCP you will be able to control the routing from Callmanager. There is ton of material on MGCP configuration on Cisco.com, here is one of them that shows how to configure MGCP and FXO port to work with it:http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a008017825e.shtml#task24x

Chris

New Member

Re: IOS 12.4 and MGCP configuration

Replied by: lexiainfo - Sep 23, 2005, 6:38am PST

Firstly thank you for the reply

I have followed your instructions still unable to registered gateway through call manager. Here is the cisco 2620 config info.

=====================================================

melbournegroceries#sh running-config

Building configuration...

Current configuration : 917 bytes

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname melb

!

enable secret xxxx

enable password voip

!

ip subnet-zero

no ip finger

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

!

voice-port 1/1/1

!

!

dial-peer voice 4 pots

application MGCPAPP

port 1/1/1

!

dial-peer voice 3 pots

application MGCPAPP

port 1/1/0

!

dial-peer voice 2 pots

application MGCPAPP

port 1/0/1

!

dial-peer voice 1 pots

application MGCPAPP

port 1/0/0

!

!

interface FastEthernet0/0

ip address 192.168.0.120 255.255.255.0

speed auto

full-duplex

!

interface Serial0/0

no ip address

shutdown

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.121

no ip http server

!

snmp-server community yes RO

!

line con 0

transport input none

line aux 0

line vty 0 4

password voip

login

!

no scheduler allocate

end

melb#

=====================================================

=====================================================

melb#sh version

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.1(5), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Wed 25-Oct-00 11:43 by cmong

Image text-base: 0x80008088, data-base: 0x80CAC644

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

melb uptime is 1 hour, 7 minutes

System returned to ROM by power-on

System image file is "flash:c2600-is-mz_121-5"

cisco 2620 (MPC860) processor (revision 0x102) with 53248K/12288K bytes of memor

y.

Processor board ID JAD042701EE (1286926306)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

4 Voice FXO interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

melb#

=====================================================

Waiting for your reply thanks

Super Bronze

Re: IOS 12.4 and MGCP configuration

Hi

You don't have any global MGCP or CCM-manager config commands in...

Try these:

mgcp

mgcp call-agent

ccm-manager mgcp

ccm-manager redundant-hsot

Then do a show ccm-manager to see the reg status. If it doesn't register, post the output from the command...

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Re: IOS 12.4 and MGCP configuration

Thanks for the reply.

I have tried the the above commands. I am getting the below error

==================================================

melb(config)#mgcp

^

% Invalid input detected at '^' marker.

melb(config)#

==================================================

What will be the reason?

Thanks Aaron

Bronze

Re: IOS 12.4 and MGCP configuration

ammmm, the IOS version on your router is not voice FS

New Member

Re: IOS 12.4 and MGCP configuration

Are you trying to say we don't even need a dial-peer for MGCP? I am in the middle of configuring MGCP in 12.4. The "application mgcpapp"(under dial-peer) command has been replaced by "service mgcpapp". The "application"(globle) is used for SRST. If you configure MGCP with SRST, you might want to put that to make sure it will use the "Default" for alternate, which is H.323. I am not quite positive yet because I haven't got a chance to test my configs yet.

Please comment.

197
Views
5
Helpful
12
Replies
CreatePlease login to create content