Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Ios download failed

Hi

I would like to upgrade my flash memory 16 -> 32 Mo.

I installed the new flash and i was using the Xmodem method to download the ios.

After the process of sending has been finished i had a error message:

Erasing flash memory failed and the download aborted.

Could you please tell me where is the problem.

Thanks

6 REPLIES

Re: Ios download failed

Did the sending fail with the an invalid checksum, if the later is the case, try downloading the IOS software again from CCO and retry the the transfer.

I would ensure that the flash is completely free, and formatted prior to attempting the upload..

New Member

Re: Ios download failed

Hi,

Thank you for your response.

After Xmodem download finished i have these error messages:

" Ready to receive file c3660-is-mz.122-8.T4.bin ...

Erasing flash at 0x30000000sector erase failed at location 0x30000000, status 0x

20202020

flash sector will NOT erase...aborting

"

So i think that the flash memory is not formatted or partiioned..

Because, i was trying to use two new flash with two different routers and i have the same error message.

I was trying also with different ios that i have just dowloaded from CCO.

Could you please tell me how to proceed to format the flash and partionned.

Thank you for your help.

Re: Ios download failed

You are only able to partition your flash from within exec mode, with a maximum of 2 partitions, and each partition is configurable in size.

For example you can format 16Mb with 2 partitions each with 8Mb in each, this is achieved as follows:-

conf t

router(config)#partition flash: 2 8 8

This command creates 2 partions, the first partion is set to 8Mb and so is the second.The same applies if you have an external PCMCIA, partition slot0: 2 4 4.

Unfortunately, until you're able to boot from within rommon a valid image file your options are limited.

You shouldn't have any problems using xmodem, the fact that you have tried the flash in another router and have the same problems would suggest faulty module.

There are two flash simm banks within the 3660, have you tried copying a valid image file from one flash memory to another. I have done this on a 3640, where both the system and boot image had been deleted. Boot from one module and then try copying the image across.

New Member

Re: Ios download failed

Hi,

i cannot use partitiion command because when i power on the router i have rommon prompt...

Other thing, i cannot copied the valid image from one flash to another, because the first flash have 2*8Mo and the second have 1 module 32Mo( the new) and other new flash 2*32Mo.

I don't think that there is an failure flash module because i was trying two new flash and i have the same problem.

Thank you for your help.

Re: Ios download failed

Another alternative would be to xmodem the image to the external flash (PCMCIA) slot0:, to see if you still get the same error. If this succeeds then you could copy from slot0: to flash:.

Have you increased the baudrate when using xmodem, and also are you specifying any flags. eg xmodem -c -c donotes crc-16. for instance.

I have experienced problem in the past when xmodem fails at low baudrates.

New Member

Re: Ios download failed

Were you able to resolve this? I have run into the same problem and was hoping for some help.

Thanks!

121
Views
0
Helpful
6
Replies