Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IOS Software MTP

I have a requirement to provide an MTP to allow FastStart on a H.323 gateway working with CCM4.1(3). Since all codecs used will be G.729a, I have tried to configure a resource on a 3845 router. It has no DSP's or voice modules, so I have tried to configure it as a software only resource but can't seem to get it to register with CCM.

I have followed guideline in "Configuring Enhanced Conferencing and Transcoding for Vice Gateway Routers" but don't seem to see registration attempts on CCM. Router shows sccp admin state UP, Software MTP Oper State: ACTIVE_IN_PROGRESS - Cause Code: TCP_CONN_ERROR.

Can anyone confirm that I am right in the assumption that I need no other hardware to do this successfully? Any ideas as to what is going wrong?

4 REPLIES
Green

Re: IOS Software MTP

Paste your sh run

New Member

Re: IOS Software MTP

Cutdown running config:

interface GigabitEthernet0/0

description *** Trunk to switch ***

no ip address

duplex full

speed 1000

media-type sfp

negotiation auto

!

interface GigabitEthernet0/0.5

description *** VOIP VLAN5 ***

encapsulation dot1Q 5

ip vrf forwarding cust58

ip address n.n.243.1 255.255.255.128

no snmp trap link-status

!

interface GigabitEthernet0/0.6

description *** Back Office VLAN 6 ***

encapsulation dot1Q 6

ip vrf forwarding BackOffice

ip address n.n.243.130 255.255.255.192

no snmp trap link-status

!

interface Serial1/0

no ip address

encapsulation frame-relay IETF

load-interval 30

dsu bandwidth 44210

frame-relay traffic-shaping

!

interface Serial1/0.271 point-to-point

description *** PVC for VOIP ***

ip vrf forwarding cust58

ip address n.n.100.58 255.255.255.252

frame-relay class VOIP-1024kbps

frame-relay interface-dlci 271

!

interface Serial1/0.272 point-to-point

description *** PVC for Backoffice ***

ip vrf forwarding BackOffice

ip address n.n.100.62 255.255.255.252

frame-relay interface-dlci 272

!

sccp local GigabitEthernet0/0.5

sccp ccm n.n.243.211 identifier 10 version 4.1

sccp ccm n.n.243.210 identifier 20 version 4.1

sccp codec g711alaw mask

sccp codec g729r8 mask

sccp codec g729br8 mask

sccp codec g729abr8 mask

sccp codec gsmfr mask

sccp codec gsmefr mask

sccp

!

sccp ccm group 999

associate ccm 10 priority 1

associate ccm 20 priority 2

associate profile 12 register MTP00169D43E1A0

signaling dscp af31

audio dscp ef

!

dspfarm profile 12 mtp

codec g729ar8

maximum sessions software 20

associate application SCCP

!

!

gateway

timer receive-rtp 600

New Member

Re: IOS Software MTP

I have now replicated this in our lab and found that it can be made to work, with one major difference - not configuring vrf or running the resource in the global vrf. TAC have now confirmed this.

New Member

Re: IOS Software MTP

Hi Mark,

In your setup do you have supplementary services like transfer and hold working?

I have the same setup, the call is established successfully but I can not invoke services like hold or transfer.

Regards,

Evi

406
Views
0
Helpful
4
Replies