Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IP phone 7821, 7861 with CME ver 10

Hi,

I have just checked in supported firmware info for  CME ver 10 that new ip phones 7821, 7861 are not supported , for CM server are supported in ver 10.x and later and in older version with device pack.

sometimes cisco info is not updated, so I would like to know if any new IOS version could support these new model?

I have found a zip file in download cisco's site cmterm-78xx.10-1-1-9_REL.zip which include

sip78xx.10-1-1-9.loads
kern78xx.10-1-1-9.sbn
rootfs78xx.10-1-1-9.sbn
sboot78xx.10-1-1-9.sbn

but I don't know which version of IOS is the correct one.

Does any of you has tried to registered this model in CME as 3rd party SIP phone?

regards

31 REPLIES
Cisco Employee

IP phone 7821, 7861 with CME ver 10

Info is current, they're not currently supported on CME, that's on the roadmap.

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

IP phone 7821, 7861 with CME ver 10

Thanks Java

I will carry out some test with  the files included un the zip file.

Regards.

Hi Filiberto , you resolve

Hi Filiberto , you resolve the problem? the PDI team recommended me use the method Fast Track

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/release/notes/CME_ReleaseNotes.html#wp60035

 

 

Hello,Fast Track method

Hello,

Fast Track method helped?

Thanks.

New Member

No fast track didnt work as

No fast track didnt work as 7861 wont register.

Tried the unreleased CME version 11 issued by the TAC but same issue. Also in 7821 call transfer wont work with the latest firmware.

We have decided to use 79xx phones.

New Member

It works with me, please find

It works with me, please find the ios version and phone firmware in below plus phone config, note you must include the phone type under register pool config, here find the config:

!
boot system flash:c2900-universalk9-mz.SPA.154-1.T2.bin
!
voice register pool-type  7841
 xml-config maxNumCalls 6
 xml-config busyTrigger 6
 xml-config custom sshAccess 0
 phoneload-support
 num-lines 4
description Cisco IP Phone 7841
 reference-pooltype 6941
!
voice register pool-type  7861
 num-lines 16
 description Cisco IP Phone 7861
 reference-pooltype 6961
!
voice register global
 mode  cme
 source-address x.x.x.x port 5060
 max-dn 150
 max-pool 45
 load 7841 sip78xx.10-2-1-12.loads
 load 7861 sip78xx.10-1-1SR1-4.loads
 authenticate register
 authenticate realm all
 timezone 31
 time-format 24
 hold-alert
 tftp-path flash:
 file text
 create profile sync 0609704072092913
!
voice register dn  11
 number 611
 allow watch
 name 611
 label 611
!
voice register pool  11
 busy-trigger-per-button 1
 id mac BC67.1C31.6F6B
 type 7861
 number 1 dn 11
 cor incoming css-local default
 dtmf-relay sip-notify
 username 611 password 611
 codec g711ulaw
!

It small deployment so I did it with basic config but the phones wouldn’t register until I used the CME 10.5

Thanks!
Ibrahim

Ahmed Ossama CCIE#26611 +966531567747
New Member

Hi Ibrahim !!My name is

Hi Ibrahim !!

My name is Enrique Villasana, I have a CME ver 10 with 78XX Ip Phones. And using a configuration similar yours the 78XX Ip phone did not get registration. I upgraded the CME to ver 10.5 ( IOS 154-3.M2), and still have problems. I would like to share my current configuration, so if you can find something wrong I really apreciate you could let me know:....

voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  call start slow
 sip
  bind control source-interface GigabitEthernet0/0.3  <-- Voice VLAN int
  bind media source-interface GigabitEthernet0/0.3
  registrar server expires max 600 min 60
!
.
.
!
voice register global
 mode  cme
 source-address 10.2.50.254 port 5060  <-- Ip add of Voice VLAN int
 max-dn 180
 max-pool 42
 load 7821 sip78xx.10-1-1SR1-4
 load 7841 sip78xx.10-1-1SR1-4
 authenticate register
 timezone 14
 tftp-path flash:
 create profile sync 0008536074803216
!
!
voice register dn  1
 number 235
 pickup-call any-group
 name Reception Reception
 label Reception Reception
!
!
voice register pool  1
 busy-trigger-per-button 1
 id mac aaaa.bbbb.cccc
 type 7841
 number 1 dn 1
 template 1
 dtmf-relay rtp-nte
 username cisco password cisco
 description Reception
 codec g711ulaw
!
tftp-server flash:rootfs78xx.10-1-1SR1-4.sbn
tftp-server flash:sboot78xx.10-1-1SR1-4.sbn
tftp-server flash:sip78xx.10-1-1SR1-4.loads
tftp-server flash:kern78xx.10-1-1SR1-4.sbn

interface GigabitEthernet0/0.3
 description Voice VLAN
 encapsulation dot1Q 3
 ip address 10.2.50.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip traffic-export apply TAC size 10000000
!

I really appreciate your help !!

Thanks in advanced

 

Enrique Villasana

New Member

Dear filiberto.aguirre,

Dear filiberto.aguirre,

As per your advise i appiled that fast track commands but still facing same problems that is 7821 and 6921 phones are not getting registered on srst router after cucm down

Note:7940,7962 phones registration successfully on srst router after cucm down

Please find attachment of srst router configuration file

Please Please help me

New Member

Any one Please help me

Any one Please help me
New Member

Hi,this link should help

Hi,

this link should help using the Fast Track:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeadm/cmebasic.html#pgfId-1295535

 

Note Once the new SIP phone model is configured using the fast-track configuration approach, the new phone model can be provisioned using the existing voice register pool configuration option as shown below.


voice register pool 1
type 7821
id mac D824.BD27.9EAC
 
voice register global
mode cme
load 7821 sip78xx.10-1-1SR1-4.loads

 

Regards!

Ibrahim

New Member

hi everyone any luck to add

hi everyone any luck to add this phone as sip phone i tried but there is no login option ?? :(

New Member

Hi All   New SIP IP-phone

Hi All

   New SIP IP-phone 78xx is not supported on CME router based solutions "any version".

plus the 78xx datasheet show that 78xx only supported on CUCM ver. 8.5.1 and Later ONLY.

http://www.cisco.com/c/en/us/products/collateral/collaboration-endpoints/unified-ip-phone-7800-series/data-sheet-c78-729488.html

 

For New Conference IP-phone 8831  is not supported on the CME v. 10

but last update its working only on CME 9.5 with PSTN E1 voice cards.

 

my question to you why looking for CME? why you looking for Basic IPT features

No Cisco BE6K starting form 25 users with all Rich UC v10 capability 

BE6k is available with very cheapest price compare to CME or any other vendor.

 

http://www.cisco.com/web/partners/downloads/partner/WWChannels/technology/ipc/downloads/be_6000.pdf
 

 

 

New Member

Hi,Finally I could register 

Hi,


Finally I could register  ip phone 7821 with fast track method with CME 10.

I can make calls, transfer, conference by software.

some features don't work , pickup, corporate directory.

 

regards

New Member

Hai filiberto,

Hai filiberto,

Could you please share the fast track configuration commands 

Thanks in Advance

New Member

Hi mohammedmon,

Hi mohammedmon,

try this:


voice register pool-type  7821
 xml-config maxNumCalls 6
 xml-config busyTrigger 6
 xml-config custom sshAccess 0
 phoneload-support
 num-lines 2
 description Cisco IP Phone 7821
 reference-pooltype 6921
!
voice register global
 mode  cme
 source-address 192.168.1.253 port 5060
 max-dn 5
 max-pool 5
 load 7821 sip78xx.10-1-1SR1-4
 authenticate register
 authenticate realm all
 tftp-path flash:
 create profile sync 0002708777258415
 ntp-server 192.168.1.253 mode directedbroadcast
!
voice register dn  1
 number 4301
 name Help-Desk
 label Help-Desk
!
voice register pool  1
 busy-trigger-per-button 1
 id mac 2C3E.CF87.E439
 type 7821
 number 1 dn 1
 presence call-list
 dtmf-relay rtp-nte
 username cisco password cisco
 codec g711ulaw
 no vad

For the newest version of  CME you don't neet fast track , 78xx are included in type options for voice register pool .

regards

New Member

Dear Sir,

Dear Sir,

We have two Sites .example site A and Site B.call manager Bussiness Edition 6000 is placed in site-A and Site-B phones are registered on this BE 6000 through VPN.In Site-B there is a SRST Router  for  the redundancy 

In site-B there is cisco 7975,7962 ,cp 6921 and cp7861 iphones

After finishing the configuration 7675 and 7962 is able to register on srst router after loss the connectivity of BE 6000.but  cp 6921 and cp7861 iphones are not registering on srst router.Please help me

Find the configuration SRST Router Configuration. Please let me know if  i should make changes,Because this is the first time im doing this.please help me



version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AUH_SRST
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 0/1
logging queue-limit 10000
logging buffered 10000000
logging rate-limit 10000
no logging console
no logging monitor
enable password admin
!
no aaa new-model
clock timezone PCTime 4 0
!
!
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.50.129
ip dhcp excluded-address 192.168.50.130
!
ip dhcp pool VOICE
import all
network 192.168.50.128 255.255.255.128
default-router 192.168.50.130
option 150 ip 10.10.3.251 10.10.3.250
lease 30
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
trunk group AUH_FXO
hunt-scheme round-robin
!
cts logging verbose
!
crypto pki trustpoint TP-self-signed-2478824890
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2478824890
revocation-check none
rsakeypair TP-self-signed-2478824890
!
!
crypto pki certificate chain TP-self-signed-2478824890
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 32343738 38323438 3930301E 170D3136 30333235 31323432
34395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 34373838
32343839 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100E4CD 2139B19F 3BCE42FC 994431B7 E2D27BD5 374A9DBE 41737545 3E42F435
73969AB6 498B1026 710ACDFD EDC02DF2 2DA1F7B8 78ECBE76 9DDE349A 00449610
D655FC06 1D74AE58 A0A65B42 F231141D 8332DD1F D0F05F8F DB7B0BCE 6DC7577E
836A5D8A A72A9804 D7785951 C2E38BCC 7A762EAC 07C65C84 6EC1C511 6A116847
01B10203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 14162F30 7B18FC5F 4479F0BF 0AF244A2 6D778500 E7301D06
03551D0E 04160414 162F307B 18FC5F44 79F0BF0A F244A26D 778500E7 300D0609
2A864886 F70D0101 05050003 81810022 C97EB889 83830CFE 5A804C71 781A6C26
9FD6AFE6 48FC7530 C379C565 018A2CE3 9EB08D9C 60E4AED4 B4BC3A9B 4163C3A6
D413719C 7A41FE43 668D69F1 25F502AD CF3D75D2 2EAFA1AF C5E2D472 533BDBDC
2A0769EB 57AD8DCB B711275E EDE146DD CBA3D005 F76DCBB6 84FAAEF1 A35BB0B0
B376DC22 2F1D9DBD FDC5ACEF 5FA609
quit
voice-card 0
!
!
!
voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server expires max 600 min 60
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
!
!
!
voice iec syslog
voice register global
mode srst
!
!
!
voice translation-rule 1
rule 1 /[0-9]+/ /9&/
rule 2 /971/ /900971&/
!
!
voice translation-profile FROM_ISP
translate calling 1
!
!
!
!
application
global
service alternate default
!
!
license udi pid CISCO2921/K9 sn FCZ193661MR
hw-module pvdm 0/0
!
!
!
username admin privilege 15 password 0 admin
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
description #MANAGEMENT#
encapsulation dot1Q 10
ip address 192.168.22.5 255.255.255.248
!
interface GigabitEthernet0/0.60
description #vOICE vLAN#
encapsulation dot1Q 60
ip address 192.168.50.130 255.255.255.128
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.50.130
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.50.129
!
logging trap debugging
!
!
!
control-plane
!
!
voice-port 0/0/0
trunk-group AUH_FXO
translation-profile incoming FROM_ISP
cptone AE
timeouts call-disconnect 5
timeouts wait-release 5
timing guard-out 1000
connection plar opx 5333
caller-id enable
!
voice-port 0/0/1
trunk-group AUH_FXO
translation-profile incoming FROM_ISP
cptone AE
timeouts call-disconnect 5
timeouts wait-release 5
timing guard-out 1000
connection plar opx 5333
caller-id enable
!
voice-port 0/0/2
trunk-group AUH_FXO
translation-profile incoming FROM_ISP
cptone AE
timeouts call-disconnect 5
timeouts wait-release 5
timing guard-out 1000
connection plar opx 5333
caller-id enable
!
voice-port 0/0/3
trunk-group AUH_FXO
translation-profile incoming FROM_ISP
cptone AE
timeouts call-disconnect 5
timeouts wait-release 5
timing guard-out 1000
connection plar opx 5333
caller-id enable
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 1 pots
incoming called-number .
!
dial-peer voice 1000 voip
destination-pattern 5333
session target ipv4:10.10.3.250
incoming called-number .
voice-class codec 1
!
dial-peer voice 1001 voip
destination-pattern 53..
session target ipv4:10.10.3.250
voice-class codec 1
!
!
sip-ua
!
!
!
gatekeeper
shutdown
!
!
call-manager-fallback
secondary-dialtone 9
max-conferences 8 gain -6
transfer-system full-consult
timeouts interdigit 5
ip source-address 192.168.50.130 port 2000
max-ephones 25
max-dn 50 dual-line
system message primary MELCO_LOCAL
system message secondary MELCO_LOCAL
transfer-pattern .T
keepalive 20
call-forward pattern .T
call-forward busy 5333
call-forward noan 5333 timeout 45
time-zone 35
date-format dd-mm-yy
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password admin
login
transport input telnet
!
scheduler allocate 20000 1000
!
end

New Member

Hi,

Hi,

take into account that 69XX and 78XX are sip phones, you haven't enable sip module yet for srst.

the following config works for SRST sip phones

++++++++++++++++++++++++++++++++
voice service voip
 ip address trusted list
  ipv4 192.178.20.4   --->CM Pub
  ipv4 192.178.20.9  ----CM Subs
  ipv4 192.178.20.5
  ipv4 192.178.20.6
  ipv4 10.90.25.0 255.255.255.0   ----> network segment ip phones
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol pass-through g711ulaw
 sip
  registrar server
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729r8
 codec preference 4 g729br8
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
!
!
voice register global   ---->sip module
 mode srst
 timeouts interdigit 3
 system message Call Manager Fallback
 max-dn 20
 max-pool 20
!
voice register pool  1
 id network 10.90.25.0 mask 255.255.255.0 ----> network segment ip phones
 proxy 192.178.20.4 preference 2 monitor probe icmp-ping
 dtmf-relay rtp-nte
 codec g711ulaw
!
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

for long config you had better attach your file, don´t paste the complete config

regards

https://supportforums.cisco

Hi All

   New SIP IP-phone 78xx is not supported on CME router based solutions "any version".

plus the 78xx datasheet show that 78xx only supported on CUCM ver. 8.5.1 and Later ONLY.

http://www.cisco.com/c/en/us/products/collateral/collaboration-endpoints/unified-ip-phone-7800-series/data-sheet-c78-729488.html

 

For New Conference IP-phone 8831  is not supported on the CME v. 10

but last update its working only on CME 9.5 with PSTN E1 voice cards.

 

my question to you why looking for CME? why you looking for Basic IPT features

No Cisco BE6K starting form 25 users with all Rich UC v10 capability 

BE6k is available with very cheapest price compare to CME or any other vendor.

 

http://www.cisco.com/web/partners/downloads/partner/WWChannels/technology/ipc/downloads/be_6000.pdf

 

 

Hi Filiberto.I'm trying to

Hi Filiberto.

I'm trying to register a 8831 in a cme 10.0 with fast track method but not success yet.

Could you share your config.

This is what I have done

- Upload load file to flash

- command load in voice register global

- command voice register pool-type

- command voice register pool and voice register dn

 

Do I missin something?

Regards

New Member

To get 7861 to work you need

To get 7861 to work you need cme 10.5 with cisco IOS 15.4.3M

Voice register pool-type not supported in ios 15.4

7861 is supported in built.

here is working config

voice register global
 mode  cme
 source-address 172.168.1.1 port 5060
 max-dn 25
 max-pool 10
 load 7861 sip78xx.10-2-1-12.loads
 timezone 21
 time-format 24
 date-format D/M/Y
 tftp-path flash:
 create profile
 network-locale GB
!
voice register dn  1
 number 1010
 name 7861
 label NewSIP1
 mwi
!
voice register pool  1
 busy-trigger-per-button 2
 id mac XXXX.XXXX.XXXX
 type 7861
 number 1 dn 1
 presence call-list
 dtmf-relay rtp-nte
 username cisco password cisco
 codec g711ulaw

Ensure DHCP is properly configured and that all required tftp files are in flash

use tftp-server flash:XXXXXXXXXXX to make config files available to the phones

You need the following files in flash

sip78xx.10-1-1-9.loads
rootfs78xx.10-1-1-9.sbn
sboot78xx.10-1-1-9.sbn

Tested and working

 

New Member

Hi musteefaccie    thanks a

Hi musteefaccie    

thanks a lot for your info and detailed example you provided

regards

 

New Member

Hi musteefaccie , Please what

Hi musteefaccie ,

 

Please what the ip use in command line : source-address 172.168.1.1 port 5060

and how can i choose the number of port?

 

 

Cisco Employee

Hi,The command sets the

Hi,

The command sets the source address for phone registration. By default it is 5060 for SIP.

http://www.cisco.com/c/en/us/support/docs/voice-unified-communications/unified-communications-manager-express/99946-cme-sip-guide.html

HTH

Manish

New Member

Hi,Following is my

Hi,

Following is my configuration and my 7821 is in " Registering State " its not registered.

I have CM 10.0 Version 15.3(3)M3.

Any advise ?

 

voice register pool-type  7821
 xml-config maxNumCalls 2
 xml-config busyTrigger 2
 phoneload-support
 num-lines 2
 description ***Cisco IP Phone 7821 Ref to 6921***
 reference-pooltype 6921
!
voice register global
 mode  cme
 source-address 10.40.34.7 port 5060
 max-dn 500
 max-pool 265
 load 7821 sip78xx.10-1-1SR1-4.loads
 authenticate register
 timezone 31
 date-format D/M/Y
 tftp-path flash:
 create profile sync 001162432401740A

!         
voice register dn  68
 number 624
 name ABCD
 label ABCD
!        

!
voice register pool  68
 busy-trigger-per-button 1
 id mac ABC0.1244.EF87
 type 7821
 number 1 dn 68
 dtmf-relay rtp-nte
 no call-waiting
 description 66666666
 codec g711alaw
 no vad
!

tftp-server flash:kern78xx.10-1-1SR1-4.sbn
tftp-server flash:rootfs78xx.10-1-1SR1-4.sbn
tftp-server flash:sboot78xx.10-1-1SR1-4.sbn
tftp-server flash:sip78xx.10-1-1SR1-4.loads

 

New Member

Did you run under " voice

Did you run under " voice register global" the following commands?

 no create profile

 create profile

================

Best Regards

 

Enrique

New Member

Hi,Some weeks ago we tried

Hi,

Some weeks ago we tried this config with version  15.5.,  this version includes  phone type

78XX.  The phones registered without problem

 


!
voice register global
 mode  cme
 source-address 172.16.0.1 port 5060
 max-dn 200
 max-pool 42
 load 7821 sip78xx.10-2-1-12SR1-4
 load 7861 sip78xx.10-2-1-12SR1-4
 authenticate register
 timezone 9
 date-format D/M/Y
 voicemail 1411
 tftp-path flash:
 create profile sync 0170543039806239
 network-locale ES
 user-locale ES
 conference hardware
!

 

voice register dn  1
 number 1500
 call-forward b2bua noan 1411 timeout 20
 name Red 1
 label Network 1
 mwi
!
voice register dn  2
 number 1600
 call-forward b2bua noan 1411 timeout 15
 name Red 2
 label Network 2
 mwi

voice register pool  1
 busy-trigger-per-button 2
 id mac F09E.636F.3908
 type 7861
 number 1 dn 1
 number 2 dn 4
  presence call-list
 dtmf-relay rtp-nte
 username cisco password cisco
 codec g711ulaw
 no vad
 conference admin

 

 

 

 

New Member

Hi , i am facing same issue,

Hi , i am facing same issue, all config done only the load for IP phone 78 are not available.

IOS ver Version 15.4(2)T1

CME 10.0 .

 

Please advise what i did missed ? or the version is correct one.

 

 

New Member

Hi Mahan,Check musteefaccie

Hi Mahan,

Check musteefaccie comments,  he recommends

cme 10.5 with cisco IOS 15.4.3M, the complete example is below

regards

Fast track support for SIP

Fast track support for SIP phones

This feature is introduced in CME 10.0 - 15.3(3)M. It provides support for new SIP phone device without changing the IOS version. In the subsequent CME releases, these new phones would be added into the list of supported phones for CME with the necessary code changes. Currently all the new SIP phone devices which are not yet supported on CME can register to CME as 3rd party SIP phones and avail generic SIP line features.

15752
Views
24
Helpful
31
Replies