Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

IP Phone registration in ITS

When I reset a previously registered phone in a IOS Telephony Service environment (either via the reset or restart command or the **#** sequence) the IP Phone is unable to re-register unless I reload the router. When I type a “show ephone”, the status of the phone is UNREGISTERED.

The router I’m using is a 1760 and I’m running 122-15.T1 (I’ve tried different IOS levels with no luck). The problem is the same with any IP Phone model, 7960, 7940 or 7910.

Has anyone had the same problem that I have with the registration of IP Phones on ITS? Any help is appreciated.

Thanks

Gabriel

5 REPLIES
New Member

Re: IP Phone registration in ITS

Hi Gabriel,

we have version 12.2(11)YT1 and we have never had this kind of problem.

Are you running the DHCP server on the ITS itself?

Could you post the config?

Best regards

Nicola

New Member

Re: IP Phone registration in ITS

I'm running 12.2(15)T1. I tried 12.2(11)YT1 but I had the same problem. I'm running the dhcp and tftp server in the Router. Below is my config. Thanks!

ip dhcp excluded-address 172.18.9.9

ip dhcp excluded-address 172.18.9.10 172.18.9.20

!

ip dhcp pool voice

network 172.18.9.0 255.255.255.0

option 150 ip 172.18.9.9

default-router 172.18.9.9

dns-server 172.18.9.11

!

ip dhcp-server 172.18.9.9

!

!

interface FastEthernet0/0

ip address 192.168.9.9 255.255.255.0

!

ip http server

ip http path flash:

!

tftp-server flash:P00303020209.bin

tftp-server flash:P00403020209.bin

tftp-server flash:P00503010100.bin

tftp-server flash:S00103020002.bin

!

voice-port 2/0

!

voice-port 2/1

!

dial-peer voice 1 pots

application auto_att_flash

destination-pattern 9.T

port 2/0

!

telephony-service

load 7910 P004G302

load 7960-7940 P003G302

max-ephones 24

max-dn 96

ip source-address 172.18.9.9 port 2000

transfer-pattern 9..........

web admin system name admin password cisco

dn-webedit

time-webedit

!

!

ephone-dn 4

number 2002

name Angel

!

ephone-dn 6

number 2004

name Pedro

!

ephone 2

username "angel" password 123456

mac-address 0009.7C5F.BB09

paging-dn 20

button 1:4

!

ephone 3

username "pedro" password 123456

mac-address 0009.7C5F.BB8C

paging-dn 20

button 1:6

New Member

Re: IP Phone registration in ITS

hey,

I use the same hardware and ios as you did.

I use both dhcp and static ip address, but had never encountered your problem.

what is the debug ephone registe output ?

can you ping the phone?

what did the phone screen show ?

Good luck.

Eva

New Member

Re: IP Phone registration in ITS

There is no output on the "debug ephone registration" command related to that problem whatsoever. What is interesting though is that if I do a "sh ip dhcp bindings", I don't see the entry of the IP Phone with problems; It seems like the IP Phone cannot get the IP address from the DHCP server. This issue points that the problem may be on the DHCP server side rather that on the ITS. The message that appears in the IP Phone is "Configuring IP". Let me know if there's something specific (besides the 150 option) required on the dhcpd process. I posted the running-config on another message.

Thanks

Gabriel

New Member

Re: IP Phone registration in ITS

Do you copy the bin files in router's flash?

Please make sure the files are copied to flash.

The following listed my partial configuration for your reference.

ip dhcp excluded-address 165.249.132.1

ip dhcp excluded-address 165.249.132.2

ip dhcp excluded-address 165.249.132.3

ip dhcp excluded-address 165.249.132.90

!

ip dhcp pool phone

network 165.249.132.0 255.255.255.0

default-router 165.249.132.1

option 150 ip 165.249.132.1

!

ip dhcp pool ext2245

host 165.249.132.221 255.255.255.0

client-identifier 0100.044d.0771.0e

option 150 ip 165.249.132.1

default-router 165.249.132.1

ip http server

ip http path flash

!

!

!

tftp-server flash:SEPDEFAULT.cnf

tftp-server flash:XMLDefault.cnf.xml

tftp-server flash:P003G302.bin

tftp-server flash:P004G302.bin

!

!

!

telephony-service

timeouts interdigit 5

load 7910 P004G302

load 7960-7940 P003G302

ip source-address 165.249.132.1 port 2000

max-ephones 48

max-dn 48

voicemail 4001

mwi sip-server 165.249.132.254 transport tcp

mwi expires 86400

moh thank_you_for_holding.wav

time-format 24

date-format dd-mm-yy

admin-username xx

admin-password xx

dn-webedit

time-webedit

!

!

ephone-dn 1

number 223

name Leung_W_S

hold-alert 15 idle

!

!

ephone 1

username "user_1" password change

mac-address 0006.D781.C5EE

speed-dial 1 927663333

button 1:1 2:10

!

!

dir flash:

Directory of flash:/

1 -rw- 15370788 Mar 01 1993 00:17:08 c3725-is-mz.122-11.T3.bin

2 -rw- 47172 Mar 01 1993 01:09:24 thank_you_for_holding.wav

8 -rw- 226078 Mar 01 1993 01:30:02 admin_user.html

9 -rw- 4178 Mar 01 1993 01:30:28 ephone_admin.html

10 -rw- 520 Mar 01 1993 01:30:54 telephony_service.html

12 -rw- 29092 Mar 01 1993 02:10:18 logohome.gif

3 -rw- 58 Mar 01 1993 00:06:40 SEPDEFAULT.cnf

4 -rw- 253 Mar 01 1993 00:06:40 XMLDefault.cnf.xml

11 -rw- 496521 Mar 01 1993 01:31:26 music-on-hold.au

13 -rw- 35164 Mar 01 1993 02:40:36 normal_user.html

5 -rw- 700651 Mar 01 1993 01:43:30 CiscoIOSTSP.zip

6 -rw- 268008 Mar 01 1993 00:01:34 P003G302.bin

7 -rw- 258360 Mar 01 1993 00:02:02 P004G302.bin

31936512 bytes total (14458880 bytes free)

CISCO_HKG_LG_01#sho ver

Cisco Internetwork Operating System Software

IOS (tm) 3700 Software (C3725-IS-M), Version 12.2(11)T3, RELEASE SOFTWARE (fc2)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sun 22-Dec-02 12:45 by ccai

Image text-base: 0x60008940, data-base: 0x617C2000

ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)

CISCO_HKG_LG_01 uptime is 2 hours, 43 minutes

System returned to ROM by reload

System image file is "flash:c3725-is-mz.122-11.T3.bin"

cisco 3725 (R7000) processor (revision 0.1) with 119808K/11264K bytes of memory.

Processor board ID JMX0649L5CZ

R7000 CPU at 240Mhz, Implementation 39, Rev 3.3, 256KB L2 Cache

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990

204
Views
0
Helpful
5
Replies
CreatePlease to create content