Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ip phone unable to grab dhcp from router

Hi,

I've got a 2811 with a 7960 connected to HWIC-4ESW module. Configuration attached, and I can see the phone's CDP from the router. Phone is unable to grab DHCP from the router. Something wrong with the configuration?

Thanks

5 REPLIES
New Member

Re: ip phone unable to grab dhcp from router

Hi

OK, had a quick look. First thing you need to set is option 150 under your voice VLAN (VLAN20) to point to whatever you are using as your call processing agent (CallManager, CallManager Express, etc). Actually, it has to point to the TFTP server, but often that will be the same as your call processing agent.

Second thing - check that state of your VLAN interfaces. Is VLAN 20 UP UP ?

Third thing to do is to just plug in a standard PC into that port and see if that gets a 10.0.0.x address or not. If not, then probably need to check those VLAN interfaces again. Alternatively, plug the PC (via a crossover) into one of the main fast Ethernet ports and then give that port a configuration and see if you get an address out of that.

That should get you started!

Rgds

Mar

New Member

Re: ip phone unable to grab dhcp from router

Hi Mar,

I'm taking 1 step back, my phone can't even get an ip address let alone receive the option 150.

I have tried setting up my pc to the HWIC-4esw, but it doesn't grab the ip address too.

I've tried hardcoding the pc ipaddress, and it manage to ping both interfaces.

I've also tried, making sure both int vlan are "up up" before booting the cisco ip phone. All without any success of the phone getting an ip address.

Thanks

New Member

Re: ip phone unable to grab dhcp from router

Something else has just come to me. I am not that familiar with the 4ESW modules, but it is more than possible that one of those ports in the module needs to be set to have it's access VLAN as VLAN 20 in order to start populating the VLAN database correctly and the pumping out traffic.

Hope that is helpful. Please remember to rate helpful posts! :)

New Member

Re: ip phone unable to grab dhcp from router

I encoutered the same problem. Following configuration should be performed:

interface FastEthernet0/1/1

 description DOT1Q port to IP Phone

 switchport native vlan 50

 switchport mode trunk

 switchport voice vlan 150


http://www.cisco.com/en/US/docs/ios/lanswitch/configuration/guide/lsw_hwic_ethsw_ic_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1049928

Silver

Re: ip phone unable to grab dhcp from router

Have you created the vlans 10 and 20?

In some cases, it lets you configure the vlan on the ports and interface, but wont take effect unless you manually create them.

check with "show vlans" command

thanks

- abu

418
Views
0
Helpful
5
Replies