Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

IP phones & Vlans in multiple vendor enverioment

Hi,

I do have a multi vendor Environment (Cisco, Nortel, HP and Enterasys ), but the main are cisco.

To have every switch to work with which other I created 4 VLANs in all switches

VLAN 1 - the default vlan with no use

VLAN 2 - for Voice (use with Cisco IP phones 7940 and 7960) - 10.10.60.XXX

VLAN 3 - for data - 10.10.25.XXX

VLAN 4 - for managment of switches - 10.10.50.XXX

The protocol used to connect Cisco, Nortel, HP and Enterasys is 802.1Q.

They work well with which other.

With this VLAN configuration I manage to put in work IP phones and attached PC's to work well with Nortel, HP and Enterasys (VLAN 2 - for voice and VLAN 3 for Data)

The only thing that I had to do was to change in the Admin VLAN id of the phone to VLAN 2.

My problem is when I want to connect a phone to Cisco switches, I only manage to put the phone working, but the Pc attached to the phone doesn't work (he is on VLAN 3)!

We do have lots of 2950 SI and 3524 PWR, and here is the problem, we want that they act like the other switch vendors.

We don't want to use the vlan for voice that is bulti-in on the Cisco switchs, because the other vendors switchs doesn´t understand it.

Can you give me some help.

Cisco 2950 SI - IOS 12.1(11) EA1

Cisco 3524 PWR - IOS 12.0(5)WC3b

The main configuration of the switch is the following

- TO CONNECT TO OTHER VENDOR SWITCHES - Work OK!

interface FastEthernet0/1 duplex full

speed 100

switchport trunk encapsulation dot1q

switchport trunk native vlan 3

switchport mode trunk

- NORMAL port

interface FastEthernet0/7

switchport access vlan 3

spanning-tree portfast

- VLANs interfaces

interface VLAN2

no ip directed-broadcast

ip nat outside

no ip route-cache

shutdown

!

interface VLAN3

no ip directed-broadcast

no ip route-cache

shutdown

!

interface VLAN4

ip address 10.10.50.130 255.255.255.0

no ip directed-broadcast

no ip route-cache

Which configuration should I put in the interface to permit that an IP phone let the VLAN 3 work on the PC and itselft work in VLAN 2!

Thanks in advance

MP

3 REPLIES
New Member

Re: IP phones & Vlans in multiple vendor enverioment

On your normal port, adding the "switchport voice vlan 2" command, should turn the command into a pseudo-trunk port (but it only supports 2 vlans...). The PC traffic will go into the native vlan (3 in your example), and the cisco phones will use vlan 2 (discovered via CDP with the switch) by adding an 802.1q header to the voice packets. Offhand I can't see that there would be any vendor interoperability issues with this configuration - the configuration only affects the port itself, and the phone connected to it.

http://www.cisco.com/en/US/products/hw/switches/ps628/products_configuration_guide_chapter09186a00800d84c0.html is a useful guide for your 2950 switch.

Hope that's of help.

New Member

Re: IP phones & Vlans in multiple vendor enverioment

Thank for your help.

Yes, to conf the voice vlan is with switchport voice vlan 2, but I still can't access the data network with the following config

interface FastEthernet0/6

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 2

spanning-tree portfast

With this conf the phone works ok!, but the pc attached doesn't respond, it is on VLAN 3 (10.10.25.XXX)

VLAN2 is 10.10.60.XXX

Maybe the problem is with the IP Phone itself, it doesn't let the pc respond!

In terms of IP phone conf I do introduced in the Admin. VLAN id = 2, and Operational VLAN Id =2

Thanks very much for your help

MP

New Member

Re: IP phones & Vlans in multiple vendor enverioment

I did manage to solve roblem with this configuration.

for ex. int that I have one IP phone and one Pc

interface FastEthernet0/6

switchport trunk encapsulation dot1q

switchport trunk native vlan 3 ------ my data net

switchport mode trunk

switchport voice vlan 2 --------------- my voice net

switchport priority extend cos 5

spanning-tree portfast

end

491
Views
5
Helpful
3
Replies
CreatePlease to create content