Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP Precedence Not working?

Hello,

We have Polycom Video conferencing equipment that supports IP Precedence. We also have Cisco 1720 routers that are connected to an IP VPN WAN over Qwest. Each site has a full T1 Bandwidth to all the other sites on the WAN. We are having HUGE performance issues with 4 or 5 sites on an IP video call. We have set the IP Precedence to 5 on the VC equipment as well as on the Incoming Serial and outgoing Ethernet interfaces on all the routers.

Here is essentially what we did on all the routers:

First create a standard IP access list (in config mode):

ROUTER(config)#

access-list 10 permit 10.10.1.4

access-list 10 permit 10.1.9.14

access-list 10 permit 192.168.222.99

access-list 10 permit 10.2.7.109

access-list 10 permit 192.168.133.143

access-list 10 permit 192.168.222.11

access-list 10 permit 10.13.10.136

ROUTER(config)#

route-map ipprec permit 10

match IP address 10

set IP precedence 5

ROUTER(config-if)#

int s0

ip policy route-map ipprec

ROUTER(config-if)#

int fa0

ip policy route-map ipprec

But we still have horrible performance. Incoming video frame rates of 1-10 per second. Choppy audio, etc. Any ideas? I can't imagine the server software is causing this much of a problem, and the average Round Trip delay on the Qwest network is at max 150MS. I appreciate any input!

Thanks,

Tim

4 REPLIES
New Member

Re: IP Precedence Not working?

IP Prec alone does not guarantee QoS for video confernecing. IP Prec interacts with protocols on your routing platforms to prioritize certain traffic through queues in the face of network congestion. So while you may have set such on your routers, there is no telling what your SP may have done across their network. You need to speak with your SP about an SLA. Video quality is a function of throughput, packet loss, jitter, latency, etc... So while end-end delay may be no more that 150ms as you describe, if the other variables are not up to minimal standards, you will see performance hits on your video.

New Member

Re: IP Precedence Not working?

Well, I just checked our SLA and this is what is says:

"Qwest's goal is to maintain an average roundtrip POP-to-POP (e.g. VPN Edge Gateway to VPN Edge Gatweway) on-network delay of 75 milliseconds."

I should also point out that this is an SLA for the month. i.e. they are saying that the average delay of 75 millisceonds is based on monthly performance of all the POP-to-POP trunks throughout the month.

New Member

Re: IP Precedence Not working?

If your confident that your network service provider is giving you acceptable performance levels, one last point to check is NIC speed negotiation on your VC units. There is a known issue with some VC endpoints that cannot properly negotiate NIC settings (i.e., 10 vs. 100, half vs. full-duplex). This may cause horrible video performance even on a clean network. Manually setting the NIC or switch port to a specific setting should clear the issue up. Hope this helps...

Anonymous
N/A

Re: IP Precedence Not working?

Hi Tim,

We have nearly same kind of setup. We are using Polycom FX and we have configured it to use IP Precedence and works great. Here are some tips that might help you..

class-map match-all video-signalling

match access-group 103

class-map match-all video

description QoS for Video Conf to IL

match access-group 104

policy-map video

description QoS for VoIP/Video to IL

class video-signalling

bandwidth 64

class video

priority 900

service-policy output video ---- Tobe applied on the Serial Interface

access-list 103 remark Qos for VC signaling to IL

access-list 103 permit tcp any any range 3230 3231

access-list 104 permit ip any any precedence critical

Try this config, might solve your problem. Thanks... Pranav

131
Views
0
Helpful
4
Replies