Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ISDN SETUP ISSUES

Hello,

I have tried about every variation of ISDN config and cannot get the incoming setups to work. As far as I know now it is telling me blah about the bearer cap but I thought that was usually for a voice call coming in on a data line.

Anythoughts would help.

ul 14 15:39:37.932: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x0279

Jul 14 15:39:37.932: Bearer Capability i = 0x8090A2

Jul 14 15:39:37.932: Channel ID i = 0xA18390

Jul 14 15:39:37.932: Calling Party Number i = 0x21, 0x83, '5555551212', Plan:ISDN, Type:National

Jul 14 15:39:37.932: Called Party Number i = 0xA1, '2345678900', Plan:ISDN, Type:National

Jul 14 15:39:37.936: ISDN Se0:23: Incoming call id = 0x02CF, dsl 0

Jul 14 15:39:37.936: ISDN Se0:23: NegotiateBchan: bchan 16 intid 0 serv_st 0 chan_st 0 callid 0x0000 ev 0x90 n/w? 0

Jul 14 15:39:37.936: Negotiated int_id 0 bchan 0 cr=0x8279 callid=0x02CF lo_chan 16 final int_id/bchan 0/16 cause 0x0

Jul 14 15:39:37.936: ISDN Se0:23: LIF_EVENT: ces/callid 1/0x2CF CALL_INCOMING

Jul 14 15:39:37.936: ISDN Se0:23: CALL_INCOMING dsl 0 bchan 15

Jul 14 15:39:37.936: extract_sa: no 0x71 ie to extract

Jul 14 15:39:37.936: ISDN Se0:23: CALL_INCOMING: call type is VOICE ULAW, bchan = 15

Jul 14 15:39:37.936: ISDN Se0:23: Event: Received a call id 0x2CF with a bad bearercap from 9172178812 on B16

Jul 14 15:39:37.940: ISDN Se0:23: CCPRI_ReleaseCall(): bchan 16, call id 0x2CF, call type VOICE

Jul 14 15:39:37.940: CCPRI_ReleaseChan released b_dsl 0 B_Chan 16

Jul 14 15:39:37.940: ISDN Se0:23: LIF_EVENT: ces/callid 1/0x2CF CALL_CLEARED

Jul 14 15:39:37.940: ISDN Se0:23: received CALL_CLEARED call_id 0x2CF

Jul 14 15:39:37.940: no resend setup, no redial

Jul 14 15:39:37.940: no resend setup, no redial

Jul 14 15:39:37.940: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8279

Jul 14 15:39:37.940: Cause i = 0x80BA - Bearer capability not available

9 REPLIES
Community Member

Re: ISDN SETUP ISSUES

Forgot conf

!AS5300 ISDN FAS-----

isdn switch-type primary-5ess

isdn voice-call-failure 0

!

interface Serial0:23

no ip address

isdn switch-type primary-5ess

no cdp enable

!

Re: ISDN SETUP ISSUES

Jason,

Have you set a voice codec statement and applied it to the incoming dial peer so the AS-5300 knows what codec it should use?

AS5300s are a little more picky than your normal gateway and take a little more setting up. Any chance you could post the whole config (passwords ommitted) so it'll be easier to tell.

Paul

Community Member

Re: ISDN SETUP ISSUES

Thanks and sure...I used the config I had from another 5300 that was pretty much the same 5ess etc so I just cut n pasted most everything. This one I think the carrier is just sending something extra or missing it (the noteable diff I see was the new carrier sends ANI)...

I pulled all the radius and access stuff because I am positive that is not part of the issue.

!

resource-pool disable

!

call rsvp-sync

clock timezone EST -5

ip subnet-zero

!

isdn switch-type primary-5ess

isdn voice-call-failure 0

!

signaling-class cas test

voice rtp send-recv

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g723r63

codec preference 3 g711ulaw

!

!

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller T1 0

framing esf

clock source line primary

linecode b8zs

cablelength short 133

pri-group timeslots 1-24

!

controller T1 1

framing esf

clock source line secondary 1

linecode b8zs

cablelength short 133

pri-group timeslots 1-24

!

interface Ethernet0

ip address

no ip route-cache

no ip mroute-cache

!

interface Serial0:23

no ip address

isdn switch-type primary-5ess

isdn negotiate-bchan

no cdp enable

!

interface Serial1:23

no ip address

isdn switch-type primary-5ess

isdn guard-timer 3000

isdn T203 10000

no cdp enable

!

interface FastEthernet0

ip address

duplex full

speed auto

!

interface Dialer0

no ip address

no cdp enable

!

interface Dialer1

no ip address

no cdp enable

!

ip classless

no ip http server

ip pim bidir-enable

!

logging trap debugging

!

!

voice-port 0:D

!

voice-port 1:D

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 212 voip

destination-pattern 212T

session target ipv4:

!

dial-peer voice 718 pots

destination-pattern 1718.......

port 1:D

!

alias exec u undebug all

line con 0

line aux 0

end

Re: ISDN SETUP ISSUES

I can't see anything in your config that matches the incoming dialled digits.

You need a

dial-peer voice xx voip

destination-pattern 234T

session target ipv:

voice codec 1

type of statement. As far as I can tell your incoming calls don't go anywhere becasue you haven't told them where to go nor which codec to use.

paul

Community Member

Re: ISDN SETUP ISSUES

ok I did the voice codec as below same thing though the digits were just fakes I typed in. Here is a real example

voice class codec 2

codec preference 1 g711ulaw

codec preference 2 g711alaw

!

!

interface Serial0:23

no ip address

isdn switch-type primary-5ess

isdn negotiate-bchan

no cdp enable

!

!

dial-peer voice 212609 voip

destination-pattern 212T

voice-class codec 2

session target ipv4:

!

ul 14 18:40:23.200: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x0283

Jul 14 18:40:23.200: Bearer Capability i = 0x8090A2

Jul 14 18:40:23.200: Channel ID i = 0xA18383

Jul 14 18:40:23.200: Calling Party Number i = 0x21, 0x83, '5555551212', Plan:ISDN, Type:National

Jul 14 18:40:23.200: Called Party Number i = 0xA1, '2126093474', Plan:ISDN, Type:National

Jul 14 18:40:23.204: ISDN Se0:23: Incoming call id = 0x02D9, dsl 0

Jul 14 18:40:23.204: ISDN Se0:23: NegotiateBchan: bchan 3 intid 0 serv_st 0 chan_st 0 callid 0x0000 ev 0x90 n/w? 0

Jul 14 18:40:23.204: Negotiated int_id 0 bchan 0 cr=0x8283 callid=0x02D9 lo_chan 3 final int_id/bchan 0/3 cause 0x0

Jul 14 18:40:23.204: ISDN Se0:23: LIF_EVENT: ces/callid 1/0x2D9 CALL_INCOMING

Jul 14 18:40:23.204: ISDN Se0:23: CALL_INCOMING dsl 0 bchan 2

Jul 14 18:40:23.204: extract_sa: no 0x71 ie to extract

Jul 14 18:40:23.204: ISDN Se0:23: CALL_INCOMING: call type is VOICE ULAW, bchan = 2

Jul 14 18:40:23.204: ISDN Se0:23: Event: Received a call id 0x2D9 with a bad bearercap from 5555551212 on B3

Jul 14 18:40:23.208: ISDN Se0:23: CCPRI_ReleaseCall(): bchan 3, call id 0x2D9, call type VOICE

Jul 14 18:40:23.208: CCPRI_ReleaseChan released b_dsl 0 B_Chan 3

Jul 14 18:40:23.208: ISDN Se0:23: LIF_EVENT: ces/callid 1/0x2D9 CALL_CLEARED

Jul 14 18:40:23.208: ISDN Se0:23: received CALL_CLEARED call_id 0x2D9

Jul 14 18:40:23.208: no resend setup, no redial

Jul 14 18:40:23.208: no resend setup, no redial

Jul 14 18:40:23.208: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8283

Jul 14 18:40:23.208: Cause i = 0x80BA - Bearer capability not available

Community Member

Re: ISDN SETUP ISSUES

ok I did the voice codec as below same thing though the digits were just fakes I typed in. Here is a real example

voice class codec 2

codec preference 1 g711ulaw

codec preference 2 g711alaw

!

!

interface Serial0:23

no ip address

isdn switch-type primary-5ess

isdn negotiate-bchan

no cdp enable

!

!

dial-peer voice 212609 voip

destination-pattern 212T

voice-class codec 2

session target ipv4:

!

ul 14 18:40:23.200: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x0283

Jul 14 18:40:23.200: Bearer Capability i = 0x8090A2

Jul 14 18:40:23.200: Channel ID i = 0xA18383

Jul 14 18:40:23.200: Calling Party Number i = 0x21, 0x83, '5555551212', Plan:ISDN, Type:National

Jul 14 18:40:23.200: Called Party Number i = 0xA1, '2126093474', Plan:ISDN, Type:National

Jul 14 18:40:23.204: ISDN Se0:23: Incoming call id = 0x02D9, dsl 0

Jul 14 18:40:23.204: ISDN Se0:23: NegotiateBchan: bchan 3 intid 0 serv_st 0 chan_st 0 callid 0x0000 ev 0x90 n/w? 0

Jul 14 18:40:23.204: Negotiated int_id 0 bchan 0 cr=0x8283 callid=0x02D9 lo_chan 3 final int_id/bchan 0/3 cause 0x0

Jul 14 18:40:23.204: ISDN Se0:23: LIF_EVENT: ces/callid 1/0x2D9 CALL_INCOMING

Jul 14 18:40:23.204: ISDN Se0:23: CALL_INCOMING dsl 0 bchan 2

Jul 14 18:40:23.204: extract_sa: no 0x71 ie to extract

Jul 14 18:40:23.204: ISDN Se0:23: CALL_INCOMING: call type is VOICE ULAW, bchan = 2

Jul 14 18:40:23.204: ISDN Se0:23: Event: Received a call id 0x2D9 with a bad bearercap from 5555551212 on B3

Jul 14 18:40:23.208: ISDN Se0:23: CCPRI_ReleaseCall(): bchan 3, call id 0x2D9, call type VOICE

Jul 14 18:40:23.208: CCPRI_ReleaseChan released b_dsl 0 B_Chan 3

Jul 14 18:40:23.208: ISDN Se0:23: LIF_EVENT: ces/callid 1/0x2D9 CALL_CLEARED

Jul 14 18:40:23.208: ISDN Se0:23: received CALL_CLEARED call_id 0x2D9

Jul 14 18:40:23.208: no resend setup, no redial

Jul 14 18:40:23.208: no resend setup, no redial

Jul 14 18:40:23.208: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8283

Jul 14 18:40:23.208: Cause i = 0x80BA - Bearer capability not available

Cisco Employee

Re: ISDN SETUP ISSUES

Hi

A couple of remarks. If you decode the bearer capability you get this

Information Transfer Capability:

Speech

Transfer Mode:

Circuit Mode

Information Transfer Rate:

64 Kbps

User Information Layer 1 Protocol:

G.711 u-Law Speech

Also a Paul pointed out your voip peer is not correct:

dial-peer voice 212609 voip

destination-pattern 212T

voice-class codec 2

session target ipv4:

You need to have an ip address of ccm specified for this command: session target ipv4

like session target ipv4:10.48.80.41

Ullie

Cisco Employee

Re: ISDN SETUP ISSUES

.

Cisco Employee

Re: ISDN SETUP ISSUES

Try adding isdn incoming-voice voice to interface Serial 0:23.

Also, look at show version and make sure you have some voice resources listed.

197
Views
0
Helpful
9
Replies
CreatePlease to create content