Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Issue with Set Variables on routing script

I'm having an issue with the text entered variables on "Call Entered Digits" to come up.

We have 5 call entered digits that route to individual "SET" boxes for setting the peripheral data.

CED #1 goes to another VRU script.

CED #2 and #3 both bring up the "value" in the set field, but #4 and #5 do not.

#4 and #5 revert to the value that comes up when a caller does not enter any digits.

Why are CEDs 4 & 5 not showing the proper values in the Agent Enterprise box?

3 REPLIES
Community Member

Re: Issue with Set Variables on routing script

Whats diffenrt between 2, 3 & 4,5

can write your call flow here

Community Member

Re: Issue with Set Variables on routing script

Attached is the call flow.

The problem lies in the CED 4&5. No matter when you enter in either number, the value will show up on the agent side as "Other", which is the same thing you get when a CED is not entered.

Now what's interesting is that if a caller presses "1" and is routed to the "Credit Cards" VRU script, then if they press 3, the value comes up correct.

What I can't figure out is why the CEDs for the first script don't recognize 4 or 5.

- I have even gone so far as to copy the "SET" box in my script and paste for all occurances, then rename... but still the same results. There are ZERO differences between the SET boxes, other than the different name values.

Call flow:

CED:

1= RUN VRU SCRIPT “Credit Cards”

2= SET VARIABLE = “Free Fillin’” --> GO TO SCRIPT “Tesoro_agent_selection”

3= SET VARIABLE = “G4G” --> GO TO SCRIPT “Tesoro_agent_selection”

4= SET VARIABLE = “Employment” --> GO TO SCRIPT “Tesoro_agent_selection”

5= SET VARIABLE = “SVC” --> GO TO SCRIPT “Tesoro_agent_selection”

VRU SCRIPT “Credit Cards” --> CED:

1 SET VARIABLE - XFER to FLEET

2 SET VARIABLE - XFER to BANK

3= SET VARIABLE = “SVC” --> GO TO SCRIPT “Tesoro_agent_selection”

Community Member

Re: Issue with Set Variables on routing script

After monitoring my script, I found that the first CED is not recognizing the digits entered.

When testing the script, I entered 5, but the script registers the call as a FAIL, which sends to

SET VARIABLE = "Other" --> GO TO SCRIPT “Tesoro_agent_selection”

I went over the CED and it's identical to my second one, but the second one works and the first does not. Any ideas?

The only thing I can figure is that there is a setting somewhere on my Rogger that does not allow more than 3 CEDs, because it seems that on CED #1, only the first 3 are recognized and on CED #2, there are only 3, which are all recognized. If there is such a setting, where would I find it?

129
Views
0
Helpful
3
Replies
CreatePlease to create content