Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Issues Setting up Voice Monitoring

I have tried to set up voice monitoring but can not get it to work in our test lab.

I have a 2950 and I have my phones and test servers plugged into this switch.

Here is a sample of my configuration:

(Interface my server is listening on)

interface FastEthernet0/1

switchport mode trunk

no ip address

spanning-tree portfast

The rest of my interfaces look like the following:

interface FastEthernet0/2 (etc.)

switchport trunk native vlan 164

switchport mode trunk

switchport voice vlan 166

no ip address

spanning-tree portfast trunk

Span session:

monitor session 1 destination interface Fa)/1

monitor session source remote vlan 166.

Any idea what I'm doing wrong? When I initiate a recording on from the Supervisor it looks like a file is created but no data is captured.

3 REPLIES
Blue

Re: Issues Setting up Voice Monitoring

Why is your FastEthernet0/1 port a trunk? Is the CRS server plugged into this port? Or do you have a separate VOIP Monitor server? Either way the port should not be a trunk.

adignan - berbee

New Member

Re: Issues Setting up Voice Monitoring

VOIP Monitor Server 4.2 Best Practices Configuration Guide

Check this link it gives very good overview.

http://www.cisco.com/en/US/products/sw/custcosw/ps1001/products_tech_note09186a008010e6ba.shtml

The "monitor session source remote vlan" is used for RSPAN configuration. If the agent phones and the CRS server VoIP Monitor interface is connected to the same switch, you don't need RSPAN configuration.

Below is the SPAN configuration specific to 2950.

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat2950/12114ea1/2950scg/swspan.htm

Sample Config:

!

interface FastEthernet0/22

switchport access vlan 102

switchport voice vlan 114

no ip address

mls qos trust cos

spanning-tree portfast

!

interface FastEthernet0/23

switchport access vlan 102

switchport voice vlan 114

no ip address

mls qos trust cos

spanning-tree portfast

!

!

interface FastEthernet0/24

description ***CRS VoIP Monitor Interface***

switchport access vlan 201

no ip address

mls qos trust cos

spanning-tree portfast

!

monitor session 1 source vlan 114 rx

monitor session 1 destination interface fa0/24

In the above sample config, voice vlan 114 is spanned to port fa 0/24 where the CRS Server VoIP Monitor interface is connected. The phones are connected to port 23 & 22. In this config, assumption is, you are using separate NIC for monitoring/recording. Based on certain switches you will have to use the 2nd NIC on the server for monitoring/recording purpose. The Best practices guide talks about how to configure the 2nd NIC.

New Member

Re: Issues Setting up Voice Monitoring

I made the modifications you outlined. One thing I noticed when I went to my Desktop Administrator is that non of my Agents phones show up under the Voice Monitor window. Any idea why?

122
Views
0
Helpful
3
Replies
CreatePlease login to create content