Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

ITS - autoattendant TCL script

Hi,

Can someone show me a working IOS ITS config with TCL scripted auto attendant?

I could not find any proper documents describing how to configure it.

The incoming calls in my config are not passed to the AA. After dialing in you hear no prompts, but can dial any extension. The call is routed normally.

Thanks for the help,

Attila

Here's what I have:

Current configuration : 2765 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname c2620-ITS24

!

!

clock timezone Budapest 1

clock summer-time budapest recurring

ip subnet-zero

!

!

!

ip dhcp pool phone1

host 192.168.100.101 255.255.255.0

client-identifier 0100.07eb.20a8.f3

default-router 192.168.100.1

option 150 ip 192.168.100.1

!

ip dhcp pool phone2

host 192.168.100.102 255.255.255.0

client-identifier 0100.07eb.182e.71

default-router 192.168.100.1

option 150 ip 192.168.100.1

!

ip dhcp pool phone3

host 192.168.100.103 255.255.255.0

client-identifier 0100.07eb.0639.8b

default-router 192.168.100.1

option 150 ip 192.168.100.1

!

!

!

voice call carrier capacity active

!

!

!

!

!

!

!

!

!

mta receive maximum-recipients 0

!

!

!

!

interface FastEthernet0/0

ip address 192.168.100.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 10.192.168.2 255.255.255.0

!

interface Serial0/1

no ip address

shutdown

!

ip classless

ip route 158.67.184.0 255.255.255.0 10.192.168.1

ip http server

ip http path flash

ip pim bidir-enable

!

!

!

tftp-server flash:P003G302.bin

tftp-server flash:P004G302.bin

tftp-server flash:SEPDEFAULT.cnf

tftp-server flash:XMLDefault.cnf.xml

call rsvp-sync

!

call application voice autoattendant flash://its_CISCO.2.0.0.0.tcl

call application voice autoattendant aa-pilot 150

call application voice autoattendant operator 100

call application voice autoattendant language 1 en

call application voice autoattendant set-location en 0 flash://

!

voice-port 1/0/0

!

voice-port 1/0/1

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 9 pots

destination-pattern 9...........

port 1/0/0

forward-digits 11

!

dial-peer voice 150 pots

application autoattendant

incoming called-number .

port 1/0/0

!

!

telephony-service

transfer-pattern 9...........

load 7910 P004G302

load 7960-7940 P003G302

ip source-address 192.168.100.1 port 2000

max-ephones 24

max-dn 192

moh music-on-hold.au

admin-username admin

admin-password cisco

dn-webedit

time-webedit

!

!

ephone-dn 1

number 100

name titkarno

!

!

ephone-dn 2

number 101

name Dancso Attila

!

!

ephone-dn 3

number 102

name Fejes Zoltan

!

!

ephone-dn 15

number 150

application autoattendant

!

!

ephone 1

username "titkarno" password 12345

mac-address 0007.EB20.A8F3

speed-dial 1 101

speed-dial 2 102

button 1:1

!

!

!

ephone 2

username "adancso" password 12345

mac-address 0007.EB18.2E71

speed-dial 1 100

speed-dial 2 102

button 1:2

!

!

!

ephone 3

username "zfejes" password 12345

mac-address 0007.EB06.398B

speed-dial 1 100

speed-dial 2 101

button 1:3

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

ntp server 195.13.23.5 prefer

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: ITS - autoattendant TCL script

Hi Attila,

change the order of the POTS dial peers to this -

!

dial-peer voice 150 pots

application autoattendant

incoming called-number .

port 1/0/0

!

dial-peer voice 9 pots

destination-pattern 9...........

port 1/0/0

forward-digits 11

You need to have TCL application bound to the first POTS dial peer that references the voice port as IOS hunts through the dial peers top down. Since you currently have the 'normal' dial peer first, it will just answer the call and give you a secondary dial tone.

1 REPLY
Silver

Re: ITS - autoattendant TCL script

Hi Attila,

change the order of the POTS dial peers to this -

!

dial-peer voice 150 pots

application autoattendant

incoming called-number .

port 1/0/0

!

dial-peer voice 9 pots

destination-pattern 9...........

port 1/0/0

forward-digits 11

You need to have TCL application bound to the first POTS dial peer that references the voice port as IOS hunts through the dial peers top down. Since you currently have the 'normal' dial peer first, it will just answer the call and give you a secondary dial tone.

173
Views
0
Helpful
1
Replies
CreatePlease to create content