Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

JTAPI subsystem not running

I am trying to set up a 4 port Auto Attendant on a Call Manager system I have running. The Call Manager version is 3.1(3c) and the Application Manager version is 1.2a. I have managed to get the application engine running, but the JTAPI subsystem never gets past INITIALIZING. I have seen several messages with the JTAPI susbsystem in the PARTIAL_SERVICE mode. I have re-installed the JTAPI client from the publisher and still get the same thing. This is a co-resident install with the Application Manager running on the subscriber. Has anyone seen this before?

3 REPLIES
New Member

Re: JTAPI subsystem not running

Couple of things to try:

1) Uninstall the JTAPI client and reinstall from CM. I tried upgrading the JTAPI client once and it didn't work until I uninstalled and reinstalled from the control panel.

2) Verify your entire App admin config makes no references to PC names. Change all the PC names to IP addresses of the server. ( I believe the Engine config and the directory config make references to the server name/IP) I know the JTAPI looks for CM's IP address....

3) Verify all LDAP users created for AA have matching passwords in CM and the JTAPI config under Appadmin. All make sure that all the appropriate devices are associated and the user has "enable CTI application use" selected.

-Mike

New Member

Re: JTAPI subsystem not running

From my experience 97% of the time it is a misconfigured cti route point or cti port. As stated earlier check your resources setup in APP admin cti ports and cti route point are correct. And make sure the user has cti enabled and no primary extension.

Also check under jtapi configuration that CTI port groups are correct i.e sequential port numbers that you set-up in CM

Have a look at your trace file you might find the error in the url below.

http://cisco.com./univercd/cc/td/doc/product/voice/sw_ap_to/apps_22/error222.htm

Re: JTAPI subsystem not running

Do you by any chance have the attendant console installed on the publisher as well?

if so have a look at this.

Q. Are there any known problems with IVR/ICD when it is a co-resident with Attendant Console?

A. Cisco CallManager Attendant Console and IVR/ICD both use RMI for communication. The default RMI communication port is 1099. If Attendant Console starts up before IVR/ICD, it binds to port 1099 first. However, if Attendant Console starts up after ICD/IVR is up and the port 1099 is already taken, it looks for the first available port after 1099. Attendant Console will work fine in either situation. However, IVR/ICD will run into problems if 1099 port is already taken when it starts up. You will see the following error in the IVR/ICD logs:

java.rmi.server.ExportException:

Port already in use: 1099.

There are two possible options to correct this problem:

Ensure that Cisco Telephony Call Dispatcher service starts after IVR/ICD.

Change the default RMI port in the IVR/ICD configuration.

This is from http://www.cisco.com/en/US/customer/products/sw/voicesw/ps2351/products_qanda_item09186a00800b0a20.shtml#Q12

Paul

106
Views
0
Helpful
3
Replies
CreatePlease login to create content