Cisco Support Community
Community Member

Key:Services, SoftKey:Exit inconsistencies are driving me nuts

I tried it on 7912, 60, 61 and 7970, with various phone loads (including the latest) on CM 4.1.x and found inconsistencies in how the phones behave to Key: Services and SoftKey:Exit. This is my code:

- <CiscoIPPhoneExecute>

<ExecuteItem Priority="0" URL="RTPMRx:" />

<ExecuteItem Priority="0" URL="Key:Services" />


I found that on 7912 and 7960 Key:Services stops the RTPMx created by the earlier Execute command. Whereas, it works just fine on 7961 and 7970. I tried to replace Key:Services with SoftKey:Exit, but the same issue. I want to clear the phone screen after RTPMRx command.

We would hope that by now SDKs and APIs have matured enough and the inconsistencies we saw in the earlier phone loads would have been fixed, but turns out that is not the case.


Re: Key:Services, SoftKey:Exit inconsistencies are driving me nu

Welcome to our world. There's just one thing to be done here: open a case. It doesn't do us any good just complaining, we need to get Cisco to fix the bugs. Obviously it doesn't hurt if you go via your PM as well and mention that you are unhappy with the quality of the APIs (it's a very valid complaint.. speaking of which.. stay away from CCM 5.x if you can for now.. it is giving me a lot of grief)

CreatePlease to create content