Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Key:Soft1 doesnt work after Key:Speaker

I am trying to run CiscoIPPhoneExecute using the specials URI.

Something like this:

<CiscoIPPhoneExecute>

<ExecuteItem URL= "Key:Speaker"/>

<ExecuteItem URL= "Key:Soft1"/>

</CiscoIPPhoneExecute>

But the second URI is ignored by the phone and doesnt make effect.

Someone know why?

Thanks

4 REPLIES
Community Member

Re: Key:Soft1 doesnt work after Key:Speaker

Hi Tsakata,

I dont have a solution for you, but when I tried the above URL's individualy Key:Speaker worked as expected, but Key:Soft1 did nothing?

I also found this explanation in the sdk dev notes...

If the soft key set is changing and disabled while the event is being processed, the request is

discarded.

Verification of available soft keys is achieved with the QA web pages provided by the phones web server

that indicate the active soft key set.

The interesting bit for me is the QA web pages does anyone have any more info on how to use them?

Cheers,

Phooey.

Community Member

Re: Key:Soft1 doesnt work after Key:Speaker

Hi Phooey,

Regarding the sdk dev notes, I already have read this.

I tried to do in 2 steps, in 2 separeted xml files, and works.

file 1

file 2

When you call the file1, and after 2 seconds, call the file2, it works.

If you put together the 2 URL, in the same file, doesnt work.

Do you know, why?

Thanks,

Sakata

Silver

Re: Key:Soft1 doesnt work after Key:Speaker

My guess is that because lifting the handset, hitting speaker button/line button exits the XML application. You'll see this happen with any XML app. That is why the other ExecuteItem commands are not executed.

Thats also why using two seperate files works. Once the line is opened, the rest of the ExecuteItems are ignored in the original request, but you can push a new IPPhoneExecute and the phone will respond.

The 7970 may work differently since it has the ability to keep an XML app open in the background (though though that functionality may not be implemented yet). In addition, the 7970 supports java on the phone so there are many more options and opportunities there...

Community Member

Re: Key:Soft1 doesnt work after Key:Speaker

Thanks for the tips.

Regards,

Sakata

268
Views
0
Helpful
4
Replies
CreatePlease to create content