Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Lan QoS on 3550

I was reading through the Campus QoS SRND and for the class maps they use match-all instead of match any...given the type of access list i thought it would be match any?

class-map match-all Voice-Control

match access-group name Voice-Control

class-map match-all Voice

match access-group name Voice

ip access-list extended Voice

remark Match UDP ports for Bearer Traffic

permit udp any any range 16384 32767

ip access-list extended Voice-Control

remark match voip control traffic

remark sccp

permit tcp any any range 2000 2002

remark h323 fast start

permit tcp any any eq 1720

remark h323 slow start

permit tcp any any range 11000 11999

remark h323 mgcp

permit udp any any eq 2427

4 REPLIES
New Member

Re: Lan QoS on 3550

Dear Friend

If you use match all, all setence have match to trafiic accomplish with class.

If you use match any, enough only one setence match to traffic accomplish with class.

IN this case use match-any, match all is default class method in ios.

Best Regards

Joao Medeiros

New Member

Re: Lan QoS on 3550

Hi,

The match-all or match-any statement refers to the subsequent match lines under the class map;

i.e.

class-map match-all Voice-Control

match access-group name Voice-Control

match interface F0/0

Traffic to fall into this class would have to be defined in the ACL and also present on the FastEthernet interface also, whereas

class-map match-any Voice-Control

match access-group name Voice-Control

match interface F0/0

Traffic would fall into the class if it was defined in the ACL or present on the FastEthernet interface.

HTH.

Bill.

New Member

Re: Lan QoS on 3550

I understand the difference between the two. I was questioning why in the SRND the configuration specified match-all instead of match-any. If you used the match-all in the case above you wouldn't get many matches.

New Member

Re: Lan QoS on 3550

Hi,

In the SRND configuration you posted, either the match-all or match-any statements can be used interchangeably because there is only one match statement under each class map.(match access-group voice, and match access-group voice-control. In the voice control case, any line in the ACL that is matched will drop into this class.

Bill.

80
Views
0
Helpful
4
Replies
CreatePlease to create content