Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Making sure Qos is working?

Hi All,

This question has probably been asked a million times but I cannot find a solid answer. We had our routers setup by an external company and I'm not sure if they completely finished the Qos settings on the routers. How do I check?

I am new to QoS so bear with me.


Our setup can be seen in the diagram attached.

The user switches are running AutoQos on each port

interface GigabitEthernet6/0/46

description ### CISCO VOICE & DATA PORT ###

switchport access vlan 5

switchport mode access

switchport voice vlan 10

srr-queue bandwidth share 10 10 60 20

queue-set 2 <-- Not sure why this is set on some switches and not on others

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

service-policy input AutoQoS-Police-CiscoPhone

!

There is a global QoS config set automatically by AutoQos template.

The Etherchannel-Trunk ports from the user switches to the Core switches and vice versa have the following commands set

mls qos trust dscp

priority-queue out

Q1: What Qos settings need to be added to the core switch? I have no phones are attached to it.

Currently we have the following global Qos values set

mls qos

mls qos map cos-dscp 0 8 16 24 32 46 48 56

Q2: What Qos settings need to be added to the router subinterface ports and global configs.

mls qos is not set globally but there are a bunch of policy-maps and class-maps?

Subinterface ports

interface GigabitEthernet0/0.10

description ### VOICE VLAN INTERFACE ###

encapsulation dot1Q 10

ip address 192.168.10.254 255.255.255.0

!

Interface 0/1 to Private network (class-maps and policy maps)

class-map match-all AllTraffic
match any
class-map match-any JTAPI
match access-group 110
class-map match-any voip-sig
match access-group name voip-signal
match ip dscp af31
match ip dscp cs3
class-map match-any voip-rtp
match ip rtp 16384 16383
match ip dscp ef
!
!
policy-map llq-voip
class voip-rtp
  priority 256
class voip-sig
  bandwidth 16
class JTAPI
  set dscp cs3
  bandwidth 20
class class-default
  fair-queue
  random-detect dscp-based
policy-map shape-wan
class AllTraffic
  shape average 50000000
  service-policy llq-voip
policy-map mark-all
class voip-rtp
  set dscp ef
class voip-sig
  set dscp cs3
class class-default
  set dscp default
!
!

ip access-list extended voip-signal
permit tcp any any eq 1720
permit tcp any eq 1720 any
permit tcp any any eq 2000
permit tcp any eq 2000 any
permit tcp any any range 11000 11999
permit tcp any range 11000 11999 any
permit tcp any any eq 2748
permit tcp any eq 2748 any
permit tcp any any eq 8404
permit tcp any eq 8404 any
permit tcp any any eq 42027
permit tcp any eq 42027 any
permit tcp any any range 59000 59025
permit tcp any range 59000 59025 any
!

interface GigabitEthernet0/1

description ### Private Network ###

ip address 192.168.255.2 255.255.255.252

duplex full

speed 100

service-policy input mark-all

service-policy output shape-wan

!

Still looking into what all these values mean.

Regards

Everyone's tags (5)
4 REPLIES

Making sure Qos is working?

Hello

make

show policy-map int GigabitEthernet0/1

and

show policy-map interface GigabitEthernet6/0/46

and copy-paste here

New Member

Making sure Qos is working?

show policy-map interface GigabitEthernet6/0/46 (This is off the Melbourne 3750G-USER01 switch)

GigabitEthernet6/0/46

  Service-policy input: AUTOQOS-SRND4-CISCOPHONE-POLICY

    Class-map: AUTOQOS_VOIP_DATA_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp ef (46)

    Class-map: AUTOQOS_VOIP_SIGNAL_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp cs3 (24)

    Class-map: AUTOQOS_DEFAULT_CLASS (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name AUTOQOS-ACL-DEFAULT

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
        0 packets, 0 bytes
        5 minute rate 0 bps

show policy-map int GigabitEthernet0/1 (Off the Melbourne 2800 Router )

GigabitEthernet0/1

  Service-policy input: mark-all

    Class-map: voip-rtp (match-any)
      422882260 packets, 73717373837 bytes
      5 minute offered rate 117000 bps, drop rate 0 bps
      Match: ip rtp 16384 16383
        422145770 packets, 73561857794 bytes
        5 minute rate 114000 bps
      Match: ip dscp ef (46)
        736511 packets, 155520147 bytes
        5 minute rate 2000 bps
      QoS Set
        dscp ef
          Packets marked 422882281

    Class-map: voip-sig (match-any)
      400358097 packets, 44842004330 bytes
      5 minute offered rate 31000 bps, drop rate 0 bps
      Match: access-group name voip-signal
        396250102 packets, 44527028287 bytes
        5 minute rate 31000 bps
      Match: ip dscp af31 (26)
        2787234 packets, 234418763 bytes
        5 minute rate 0 bps
      Match: ip dscp cs3 (24)
        1320764 packets, 80557256 bytes
        5 minute rate 0 bps
      QoS Set
        dscp cs3
          Packets marked 400358262

    Class-map: class-default (match-any)
      18847301096 packets, 13836330525020 bytes
      5 minute offered rate 16131000 bps, drop rate 0 bps
      Match: any
      QoS Set
        dscp default
          Packets marked 18847294088

  Service-policy output: shape-wan

    Class-map: AllTraffic (match-all)
      18031038728 packets, 11420761193505 bytes
      5 minute offered rate 12704000 bps, drop rate 0 bps
      Match: any
      Traffic Shaping
           Target/Average   Byte   Sustain   Excess    Interval  Increment
             Rate           Limit  bits/int  bits/int  (ms)      (bytes)
         50000000/50000000  312500 1250000   1250000   25        156250

        Adapt  Queue     Packets   Bytes     Packets   Bytes     Shaping
        Active Depth                         Delayed   Delayed   Active
        -      0         850797478 4183363168 170360913 3101776193 no

      Service-policy : llq-voip

        Class-map: voip-rtp (match-any)
          341581698 packets, 27282557780 bytes
          5 minute offered rate 56000 bps, drop rate 0 bps
          Match: ip rtp 16384 16383
            341574850 packets, 27281749554 bytes
            5 minute rate 56000 bps
          Match: ip dscp ef (46)
            6851 packets, 808418 bytes
            5 minute rate 0 bps
          Queueing
            Strict Priority
            Output Queue: Conversation 264
            Bandwidth 256 (kbps) Burst 6400 (Bytes)
            (pkts matched/bytes matched) 2940781/225999928
            (total drops/bytes drops) 537/661802

        Class-map: voip-sig (match-any)
          247531259 packets, 23679757170 bytes
          5 minute offered rate 82000 bps, drop rate 0 bps
          Match: access-group name voip-signal
            247480960 packets, 23672100642 bytes
            5 minute rate 82000 bps
          Match: ip dscp af31 (26)
            49905 packets, 7602622 bytes
            5 minute rate 0 bps
          Match: ip dscp cs3 (24)
            401 packets, 54278 bytes
            5 minute rate 0 bps
          Queueing
            Output Queue: Conversation 265
            Bandwidth 16 (kbps) Max Threshold 64 (packets)
            (pkts matched/bytes matched) 779747/105298466
        (depth/total drops/no-buffer drops) 0/765/0

        Class-map: JTAPI (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 110
            0 packets, 0 bytes
            5 minute rate 0 bps
          QoS Set
            dscp cs3
              Packets marked 0
          Queueing
            Output Queue: Conversation 266
            Bandwidth 20 (kbps) Max Threshold 64 (packets)
            (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

        Class-map: class-default (match-any)
          17441925990 packets, 11369798942000 bytes
          5 minute offered rate 12554000 bps, drop rate 0 bps
          Match: any
          Queueing
            Flow Based Fair Queueing
            Maximum Number of Hashed Queues 256
        (total queued/total drops/no-buffer drops) 0/380841/0
             exponential weight: 9

   dscp    Transmitted      Random drop      Tail drop    Minimum Maximum  Mark
           pkts/bytes       pkts/bytes       pkts/bytes    thresh  thresh  prob
   af11       0/0               0/0              0/0           32      40  1/10
   af12       0/0               0/0              0/0           28      40  1/10
   af13       0/0               0/0              0/0           24      40  1/10
   af21       0/0               0/0              0/0           32      40  1/10
   af22       0/0               0/0              0/0           28      40  1/10
   af23       0/0               0/0              0/0           24      40  1/10
   af31       0/0               0/0              0/0           32      40  1/10
   af32       0/0               0/0              0/0           28      40  1/10
   af33       0/0               0/0              0/0           24      40  1/10
   af41       0/0               0/0              0/0           32      40  1/10
   af42       0/0               0/0              0/0           28      40  1/10
   af43       0/0               0/0              0/0           24      40  1/10
    cs1 13779821/19479353285      2/2948           0/0           22      40  1/10
    cs2       0/0               0/0              0/0           24      40  1/10
    cs3       0/0               0/0              0/0           26      40  1/10
    cs4       0/0               0/0              0/0           28      40  1/10
    cs5       0/0               0/0              0/0           30      40  1/10
    cs6 1460106/221012238       0/0              0/0           32      40  1/10
    cs7       0/0               0/0              0/0           34      40  1/10
     ef       0/0               0/0              0/0           36      40  1/10
   rsvp       0/0               0/0              0/0           36      40  1/10
default 246455719/11349551197230 257261/380315020 123578/179057908   20      40  1/10


    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any

Hope this helps?

Do I need any class-maps policy-maps set on the Melbourne 3750X-CORE and 3750X switches.

* I am looking at basic Qos rules Voip packets take priority ... leave all other data packets untouched.

Thanks for having a look. Cheers

Making sure Qos is working?

probably qos works on GigabitEthernet0/1

but not shure on another

New Member

Making sure Qos is working?

If I have AutoQos set on the 3750-User01 with all the qos maps and thresholds do these need to be applied to all the switches in our network for qos to run properly?

mls qos map policed-dscp 0 10 18 to 8

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos srr-queue input bandwidth 70 30

mls qos srr-queue input threshold 1 80 90

mls qos srr-queue input priority-queue 2 bandwidth 30

mls qos srr-queue input cos-map queue 1 threshold 2 3

mls qos srr-queue input cos-map queue 1 threshold 3 6 7

mls qos srr-queue input cos-map queue 2 threshold 1 4

mls qos srr-queue input dscp-map queue 1 threshold 2 24

mls qos srr-queue input dscp-map queue 1 threshold 3 48 49 50 51 52 53 54 55

mls qos srr-queue input dscp-map queue 1 threshold 3 56 57 58 59 60 61 62 63

mls qos srr-queue input dscp-map queue 2 threshold 3 32 33 40 41 42 43 44 45

mls qos srr-queue input dscp-map queue 2 threshold 3 46 47

mls qos srr-queue output cos-map queue 1 threshold 3 4 5

mls qos srr-queue output cos-map queue 2 threshold 1 2

mls qos srr-queue output cos-map queue 2 threshold 2 3

mls qos srr-queue output cos-map queue 2 threshold 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 0

mls qos srr-queue output cos-map queue 4 threshold 3 1

mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45

mls qos srr-queue output dscp-map queue 1 threshold 3 46 47

mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35

mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39

mls qos srr-queue output dscp-map queue 2 threshold 2 24

mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63

mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7

mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15

mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14

mls qos queue-set output 1 threshold 1 100 100 50 200

mls qos queue-set output 1 threshold 2 125 125 100 400

mls qos queue-set output 1 threshold 3 100 100 100 400

mls qos queue-set output 1 threshold 4 60 150 50 200

mls qos queue-set output 1 buffers 15 25 40 20

mls qos

Regards

3084
Views
0
Helpful
4
Replies
CreatePlease to create content