Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MAPI Registry entries missing.

Problem: The Unity System Profile entry was deleted from the following hive:

HKEY_CURRENT_USER > Software > Microsoft > Windows NT > CurrentVersion > Windows Messaging Subsystem > Profiles.

Since the Unity System Profile entry was deleted it has not been re-created automatically by Unity (which was what we were expecting they would). We've tried manually adding the Unity System Profile entry in the hope that the this key would then have been populated, but this hasn't worked. Unfortunately this key cannot be restored from backup now. We've tried - it ain't happening.

Unity is functioning as before (as far as we can tell), but we'd like to know what the possible implications of these missing values are. The account that was logged on when the keys were deleted was not the account that the AvCsMgr service uses, but it was an account that several other Unity services use (AvCsNodeMgr, AvDSAD, AvDSGlobalCatalog, MSSQLSERVER). The Unity svr has been rebooted since & all services start ok & functionality appears ok.

What are the implications of this registry entry not being there any more are & can we recreate them manually? Will it affect communicating with the GC is my main concern.

Having checked for the same registry entries on our failover Unity server the Unity System Profile entry is not on that svr now either which we find a bit baffling (we've a working reg backup of the failover svr that previously had these entries). Are egistry entries added/deleted as part of the failover 'keepalive' monitoring process?

Yep, we know we should've tested the reg backup before making the changes & they've worked every other time we've needed them (were's Murphy?), but it's happened now so I'd just like to understand the implications of this key not being there in this profile.

Cheers for any assistance folks,

NJ.

PS. I'm in Europe so I apologise for any delays in me responding.

8 REPLIES
Gold

Re: MAPI Registry entries missing.

If this is 4.0(1) or later Unity will need to try to long on an Exchnage mailbox before the profile is recreated. You can do this by calling in to the system and trying to logon to your mailbox.

Hope this helps,

Keith

New Member

Re: MAPI Registry entries missing.

Cheers Keith.

We're on 4.0(2). I've tried logging onto an existing mailbox & also created a new user & enrolled, but no new profiles are being recreated.

Gold

Re: MAPI Registry entries missing.

Are you able to login to the mailbox or do you get a failure?

New Member

Re: MAPI Registry entries missing.

I imported a new subscriber using the local Windows account that has 'lost' the profile entries (the account that was used to install the AvCsMgr still has the entries). The user imported into Unity ok. I enrolled the user ok & the account/mailbox works as expected no probs, but I still don't have the Unity System Profile hive in the registry when I log onto the Unity svr with this account.

Should I be concerned about this?

I being chucked out of the building now by security so I won't be responding again tonight. Cheers for the help again.

Gold

Re: MAPI Registry entries missing.

If you can logon to the mailbox there has to be a profile in there. Can you search the extire registry for Unity System Profile?

New Member

Re: MAPI Registry entries missing.

There is a Unity System Profile hive under HK_Users which has a whole load of entries under it including a DCA entry which points to the GC(DC) that the MAPI profile points to. If this entry is under HK_Users does it matter that it isn't there for the HK_Current_User?

Gold

Re: MAPI Registry entries missing.

It's not a problem. If you login as the account the AvCsMgr service is running as it will be under HKEY_CURRENT_USER. You have nothing to worry about. :-)

New Member

Re: MAPI Registry entries missing.

Nice one. That's what I was hoping you would say. It is under the other account.

Thankyou very much for the quick response Keith.

NJ.

664
Views
0
Helpful
8
Replies
CreatePlease login to create content