Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

MGCP and cptone command, and impedance command changing

Hi,

I have noticed that on some model routers and with certain hardware, if you're using MGCP and not a default impedance setting, when MGCP pushes the config down the 'cptone US' command is issued. On some model routers 'cptone US' automatically sets the impedance to 600real. Well, have a client where there analog lines are far out and impedance complex1 works best for them and that is also best-match result from the THL tone sweep commands.

I know a workaround would be to remove the ccm-manager config command from gateway, but then the call manager doesn't have full control of gateway and thats not really a permament fix. Any ideas on how to fix this so the cptone command isn't sent down by MGCP ? I know I can also change locale on CCM side to get different cptone command pushed down that sets impedance to complex1, but then also get different ring which don't want.

cptone changes impedance automatically on 2800 series and XM series routers that I've seen so far. On 1760, 3725, 3745, 3640, 2620, etc entering cptone commands doesn't change the impedance configured if it's something other then the default.

1 REPLY

Re: MGCP and cptone command, and impedance command changing

Update on this...

Played around with downloading tones from call manager, this way they are custom tones, and when manually entering 'cptone C1' on voice port it does not override the impedance setting.

But when this is pushed from CCM, CCM config-download first issues a 'cptone us' command then a few seconds later does a 'cptone Custom1' command so the impedance still gets wiped.

So much for that idea...

645
Views
0
Helpful
1
Replies
CreatePlease login to create content