Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

MGCP error ?

Hi,

I get the following error on the MGCP router.

ct 1 10:46:32.869: cmapp_xml_tftp_download_file: Unable to read file tftp://10

.1.1.3/nts.nts.com.cnf.xml, rc=-2

Oct 1 10:46:32.869: cmapp_xml_get_xml_file: Could not read file tftp://10.1.1.3

/nts.nts.com.cnf.xml, len = 0

Oct 1 10:46:32.869: cmapp_xml_tftp_download_file: Unable to read file tftp:///n

ts.nts.com.cnf.xml, rc=-2

Oct 1 10:46:32.869: cmapp_xml_get_xml_file: Could not read file tftp:///nts.nts

.com.cnf.xml, len = 0

Oct 1 10:46:32.869: cmapp_xml_tftp_download_file: Unable to read file tftp:///n

ts.nts.com.cnf.xml, rc=-2

Oct 1 10:46:32.869: cmapp_xml_get_xml_file: Could not read file tftp:///nts.nts

.com.cnf.xml, len = 0

The sh ccm-manager shows that the CM is registered and also the backup CM

sh ccm-manager

MGCP Domain Name: nts.nts.com

Priority Status Host

============================================================

Primary Registered 10.1.1.3

First Backup Backup Ready 10.1.1.2

Second Backup None

Current active Call Manager: 10.1.1.3

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 14:50:23 Arabian Oct 1 2005 (elapsed time: 00:00:11)

Last MGCP traffic time: 14:50:23 Arabian Oct 1 2005 (elapsed time: 00:00:11)

Last failover time: 14:42:23 Arabian Oct 1 2005 from (10.1.1.3)

Last switchback time: 14:43:08 Arabian Oct 1 2005 from (10.1.1.2)

Switchback mode: Graceful

MGCP Fallback mode: Not Selected

Last MGCP Fallback start time: None

Last MGCP Fallback end time: None

MGCP Download Tones: Disabled

Configuration Auto-Download Information

=======================================

No configurations downloaded

Current state: Downloading XML file

Configuration Download statistics:

Download Attempted : 1

Download Successful : 0

Download Failed : 0

Configuration Attempted : 0

Configuration Successful : 0

Configuration Failed(Parsing): 0

Configuration Failed(config) : 0

Last config download command:

Configuration Error History:

FAX mode: cisco

Any advise ?

Thanks

renzil

6 REPLIES

Re: MGCP error ?

Renzil,

Can you paste your configs ? Have you matched up the name of router with domain name on the Callmanager gateway config page ?

New Member

Re: MGCP error ?

Hi,

Yes thts done.

nts#sh run

Building configuration...

Current configuration : 2236 bytes

!

! Last configuration change at 14:41:44 Arabian Sat Oct 1 2005

! NVRAM config last updated at 14:41:45 Arabian Sat Oct 1 2005

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname nts

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

memory-size iomem 20

clock timezone Arabian 4

clock calendar-valid

network-clock-participate wic 1

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

!

!

ip domain name nts.com

ftp-server enable

isdn switch-type primary-4ess

!

voice-card 0

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller E1 0/1/0

!

controller E1 0/1/1

!

!

!

interface FastEthernet0/0

ip address 10.1.1.100 255.255.255.0

duplex auto

speed auto

!

interface Service-Engine0/0

ip unnumbered FastEthern

shutdown

service-module ip address 10.1.1.101 255.255.255.0

service-module ip default-gateway 10.1.1.100

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.1

ip route 10.1.1.101 255.255.255.255 Service-Engine0/0

!

!

ip http server

no ip http secure-server

ip http path flash:

!

disable-eadi

!

!

!

control-plane

!

!

!

voice-port 0/0/0

timing hookflash-out 50

!

voice-port 0/0/1

timing hookflash-out 50

!

voice-port 0/2/0

!

voice-port 0/2/1

!

ccm-manager redundant-host 10.1.1.2

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.1.1.3

ccm-manager config

!

mgcp

mgcp call-agent 10.1.1.3 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

!

line con 0

line aux 0

line 66

no activation-character

no exec

transport preferred none

transport input all

transport output all

line vty 0 4

password telnet

login

!

ntp clock-period 17180784

ntp master

ntp server 10.1.1.2

end

Brgds

Renzil

Re: MGCP error ?

Your E1 controllers doesnt seem to be configured with MGCP backhaul.

controller E1

no shut

pri-group timeslots 1-31 service mgcp

This should add a serial interface as follows

int s1:15

isdn switch-type

isdn bind-l3 ccm-manager

isdn incoming-voice voice

That should take care of it.

A dial-peer for MGCP as follows should be automatically pushed to the config.

dial-peer voice 1000 pots

application mgcapp

port 1/0:15

HTH

Sankar.

Re: MGCP error ?

Forgot to add that you will need to set the switch-type for ISDN, as well as linecode and framing for the e1 controller (ask your service provider).

New Member

Re: MGCP error ?

Hi Shankar,

Can u tell me what this error means

Oct 3 05:38:53.927: cmapp_xml_tftp_download_file: Unable to read file tftp://10

.1.1.3/S0_SU1_DS1-0@nts.nts.com.cnf.xml, rc=-2

Oct 3 05:38:53.927: cmapp_xml_get_xml_file: Could not read file tftp://10.1.1.3

/S0_SU1_DS1-0@nts.nts.com.cnf.xml, len = 0

Oct 3 05:38:53.927: cmapp_xml_convert_ep_name_to_file_name: Converted ep_name S

0/SU1/DS1-0 to file_name S0_SU1_DS1-0

Oct 3 05:38:53.927: cmapp_xml_tftp_download_file: Unable to read file tftp:///S

0_SU1_DS1-0@nts.nts.com.cnf.xml, rc=-2

Oct 3 05:38:53.927: cmapp_xml_get_xml_file: Could not read file tftp:///S0_SU1_

DS1-0@nts.nts.com.cnf.xml, len = 0

Oct 3 05:38:53.927: cmapp_xml_convert_ep_name_to_file_name: Converted ep_name S

0/SU1/DS1-0 to file_name S0_SU1_DS1-0

Oct 3 05:38:53.927: cmapp_xml_tftp_download_file: Unable to read file tftp:///S

0_SU1_DS1-0@nts.nts.com.cnf.xml, rc=-2

Oct 3 05:38:53.927: cmapp_xml_get_xml_file: Could not read file tftp:///S0_SU1_

DS1-0@nts.nts.com.cnf.xml, len = 0

Oct 3 05:38:53.927: cmapp_xml_exec_fsm: New state = CMAPP_XML_FILE_DNLD, ep = 6

52DC1F8

Oct 3 05:38:53.927: cmapp_xml_find_ep_by_name: Checking for ep_name [*]

Oct 3 05:38:53.927: cmapp_xml_exec_fsm: Endpoint is [*]

Oct 3 05:38:53.927: cmapp_xml_exec_fsm: endpoint = * state = CMAPP_XML_FILE_DNL

D, event = CMAPP_XML_EVT_FILE_DNLD_TIMER

Oct 3 05:38:53.927: cmapp_xml_file_retry_timer_expired: state = CMAPP_XML_FILE_

DNLD, event = CMAPP_XML_EVT_FILE_DNLD_TIMER

I notice that in the sh ccm-manager it shows that both the primary and backup CM are registered but no successful download. i.e Attempted download - 4 but successful download - 0

Any suggestions ?

Thanks

Brgds

New Member

Re: MGCP error ?

Check the CallManager event viewer for the failed tftp and registration request.

996
Views
0
Helpful
6
Replies
CreatePlease to create content