Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MGCP Fallback Mode in IOS 12.2(11)T- FXS Dial Tone Problem

I currently have a 3640 w/ 12.2(11)T that is acting as a remote site SRST gateway. It is talking to a central 3.2 Call Manager. I configured the 3640 to be a MGCP gateway, with SRST and MGCP Fallback.

I am running into an issue w/ the FXS interface on the 3640. I have an analog phone connected that is able to place and receive calls while the 3640 is running in MGCP mode. When the WAN fails and H.323/SRST kicks in, the phone can still receive calls but is unable to place them. It gets a fast busy signal.

Here is the 3640 config:

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname XXXX

!

voice-card 1

!

voice-card 2

!

ip subnet-zero

!

!

!

!

!

!

voice call carrier capacity active

!

!

!

!

!

!

!

!

!

mta receive maximum-recipients 0

ccm-manager fallback-mgcp

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server X.X.X.X

ccm-manager config

!

controller T1 2/0

framing sf

linecode ami

!

controller T1 2/1

framing sf

linecode ami

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address X.X.X.X 255.255.254.0

!

interface FastEthernet0/0.250

encapsulation dot1Q 250

ip address X.X.X.X 255.255.255.0

!

interface Serial0/0

no ip address

encapsulation frame-relay

frame-relay class XXXX

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial0/0.101 point-to-point

bandwidth 384

ip address 192.168.10.1 255.255.255.0

frame-relay interface-dlci 101

!

router eigrp 100

network 10.0.0.0

network X.X.X.X

network 192.168.10.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip http server

ip pim bidir-enable

!

!

!

map-class frame-relay XXX

frame-relay cir 384000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 384000

service-policy output voice-policy

frame-relay fragment 320

access-list 101 permit ip any host X.X.X.X

access-list 101 permit ip host X.X.X.X any

!

call rsvp-sync

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/0/2

!

voice-port 1/0/3

!

voice-port 1/0/4

!

voice-port 1/0/5

!

voice-port 1/0/6

!

voice-port 1/0/7

!

mgcp

mgcp call-agent XXXX 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp package-capability rtp-package

mgcp package-capability sst-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 999100 pots

application mgcpapp

destination-pattern 2599

port 1/0/0

!

!

!

call-manager-fallback

limit-dn 7910 1

limit-dn 7940 2

ip source-address X.X.X.X port 2000

max-ephones 48

max-dn 96

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

password cisco

login

!

!

end

4 REPLIES
New Member

Re: MGCP Fallback Mode in IOS 12.2(11)T- FXS Dial Tone Problem

I haven't set this up before, but I imagine you need a dial-peer defined for the fxs to make calls in h323 mode. I usually have a dial-peer with the destination-pattern of 9 pointing to the voice port that is connect to the PSTN.

Re: MGCP Fallback Mode in IOS 12.2(11)T- FXS Dial Tone Problem

Actually, with the 12.2.11 code, you need to add the following under the cal-manager-fallback to enable pstn access:

Call-manager-fallback

access-code pri 9 direct-inward-dial

access-code fxo 8

...

These are required for call-manager-fallback starting in 12.2.4 code.

New Member

Re: MGCP Fallback Mode in IOS 12.2(11)T- FXS Dial Tone Problem

Port 1/0/0 is an FXS port, not a trunk port. I don't think you need an access code for an FXS port. I may need them when I configure the PRI and T1 voice ports to the PSTN. I have a T1 for LD and a PRI for local/DID.

New Member

Re: MGCP Fallback Mode in IOS 12.2(11)T- FXS Dial Tone Problem

Have you tried adding a simple pots dial-peer with a destination of 9T pointing out the PRI. The fallback code supports the IP Phones but not the directly connected FXS port

276
Views
0
Helpful
4
Replies
CreatePlease login to create content