Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MGCP gateway dosen't "hear" overlapping digits

Hi.

I'm working with a 2821 running 12.3(14)T7, CCM version 4.1(3)sr3b. Assuming that we have an E1 interface connected to an ISDN EURO PRI access with number 0554366XXX. When the Telco (Telecom Italia) forward to our PRI a non en-bloc call, we receive the first part of the number (0554366) and no digit after, in order to get to the extension required. With en-bloc call (for expamle, from mobile phones), everything works fine. Keep in mind that the same gateway configured as H.323 works fine.

This is the gw sh run:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VoiceGateway_Panciatichi

!

boot-start-marker

boot system flash:c2800nm-spservicesk9-mz.123-14.T7.bin

boot system flash:c2800nm-ipvoice-mz.123-14.T7.bin

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

network-clock-participate wic 0

ip subnet-zero

!

!

ip cef

no ip dhcp use vrf connected

!

!

no ip domain lookup

no ftp-server write-enable

isdn switch-type primary-net5

!

voice-card 0

no dspfarm

!

!

voice rtp send-recv

!

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 g729r8

!

!

!

!

!

!

!

!

!

!

!

username cisco privilege 15 secret xxxx

!

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31 service mgcp

!

!

!

interface GigabitEthernet0/0

ip address 151.95.x.x.255.254.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 151.95.x.x.255.254.0

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn send-alerting

isdn sending-complete

no cdp enable

!

ip classless

ip route 0.0.0.0 0.x.x.x.95.72.1

ip route 0.0.0.0 0.x.x.x.95.74.1

!

!

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 5 life 86400 requests 10000

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0:15

cptone IT

!

ccm-manager redundant-host 151.95.36.5

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 151.95.36.5

ccm-manager config

!

mgcp

mgcp call-agent 151.95.36.6 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/0

mgcp bind media source-interface GigabitEthernet0/0

!

mgcp profile default

!

!

!

dial-peer voice 1 pots

service mgcp

direct-inward-dial

port 0/0/0:15

!

!

!

line con 0

login local

line aux 0

line vty 0 4

privilege level 15

login local

line vty 5 15

privilege level 15

login local

!

scheduler allocate 20000 1000

!

end

Any ideas?

Thanks,

Iacopo.

  • Other Collaboration Voice and Video Subjects
2 REPLIES
Silver

Re: MGCP gateway dosen't "hear" overlapping digits

actually since this a MGCP gateway problem screenshots of your CCM config would be most helpful in getting a full understanding of the config.

New Member

Did you ever get a solution

Did you ever get a solution to this?

192
Views
0
Helpful
2
Replies
This widget could not be displayed.