Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MGCP Gateway Won't Register

I'm trying to figure out why a 3825 won't register. This is the first time I've ever tried to configure this so it's probably something simple.

Here's the relevant router config:

ccm-manager redundant-host 10.29.23.1 10.0.23.1

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.0.23.1

ccm-manager config

!

mgcp

mgcp call-agent 10.0.23.2 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

In CCM administration, I've configured an MGCP gateway and I've verified (20 or 30 times!) that the MGCP domain is correct, taking into account that I've configured a domain using "ip domain name xyz".

I've tried debugging MGCP and I see that I'm getting a 500 response. That really seems to indicate a configuration problem but I can't figure out where.

What else should I look for?

Thanks!

John

6 REPLIES
Green

Re: MGCP Gateway Won't Register

Hi John,

Please paste the debug and check if you select the correct slot and card when you configured the GW.

The 10.0.23.1 should have TFTP service ON.

If you configured under the router ip domain name xyz

in CCM configured name of router lets say is MYROUTER.xyz

New Member

Re: MGCP Gateway Won't Register

I am seeing a lot of stuff like the following (from debug mgcp):

*Jun 26 20:57:43.103: S0/SU0/DS1-1/23:NO-MATCH, 10.0.23.2:2427, 10.29.23.1:2427

*Jun 26 20:57:43.103: S0/SU1/DS1-*/*:NO-MATCH, 10.0.23.2:2427, 10.29.23.1:2427

*Jun 26 20:57:43.103: S0/SU1/DS1-0/*:NO-MATCH, 10.0.23.2:2427, 10.29.23.1:2427

I haven't selected the any cards yet because the cards we have are not available in the dropdown list on the gateway configuration page. We are using VWIC-2MFT-T1 modules but those are not available for selection. I assumed that once I entered the name of the gateway that CallManager would poll the gateway or something. If it doesn't, how am I supposed to tell CallManager about the VWICs?

New Member

Re: MGCP Gateway Won't Register

Even stranger, I clicked on "Help" and I see that the VWICs should be one of the options listed, yet they are not there. That's bizarre.

New Member

Re: MGCP Gateway Won't Register

Ah, I think I'm getting closer. I had to select "NM-4VWIC-MBRD" as the module in Slot 0. That opened up another section of the page where I can configure the subunits. At that point I can select the correct module.

I've reset the gateway in CallManager and restarted MGCP on the router but it still is not registering.

New Member

Re: MGCP Gateway Won't Register

Whoo hoo! I got it to register. I finished configuring the gateway in CCM and reset it, and then I restarted MGCP on the router. It took a moment but it seems to have registered.

Green

Re: MGCP Gateway Won't Register

Excellent!

567
Views
0
Helpful
6
Replies