Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

MGCP Problems

We're having a weird issue that happened on a 3825 that we configured yesterday and on a 2821 that we configured today. The gateway registers with CCM and is able to get its config, but subsequent changes to the gateway from CCM don't propagate to the gateway and we're unable to reset it or restart. The only way to get things back to "normal" is to go the router CLI, enter "no mgcp" and then "mgcp" to restart the process.

It's very annoying and since I'm pretty new to CallManager, I'm not pleased with weirdness like this.

I have a TAC case open about it but we haven't begun any troubleshooting.

Any thoughts?

5 REPLIES

Re: MGCP Problems

What IOS version are you running ? Are you using ccm-manager config command ?

New Member

Re: MGCP Problems

We are using that command. This is on 12.4(8). We just tried adding the following commands:

mgcp bind control source-interface a.b.c.d

mgcp bind media source-interface a.b.c.d

I don't know why those are necessary but they seem to be helping.

Re: MGCP Problems

The bind commands are used to specify which interface address to use for media and control packets from the MGCP gateway.

This is sometimes necessary, in cases where you have a remote MGCP gateway across the wan. You lan address behind the remote gateway is routable within HQ, but wan address is not known to all routers in the HQ. In this case you can bind the source address of mgcp packets to the ethernet interface of the remote MGCP gateway.

New Member

Re: MGCP Problems

They shouldn't have been necessary in this case, but it does seem to have helped. It's very odd. We just tried them for fun and it seems to have helped.

New Member

Re: MGCP Problems

We configured another 2821 MGCP gateway and had exactly the same problem: after the gateway downloads its config, subsequent config changes from CCM are not applied and CCM cannot reset or restart the gateway. With TAC support, I upgraded to 4.1(3)ES62 and configured yet another 2821--same problem.

And the workaround seems to be the same. Adding the "mgcp bind" commands seems to solve the problem. Very weird. I'd really like to know why this is happening.

Another weird thing: the first time the router registers to CallManager, non-MGCP interfaces on the router bounce. This is on a VWIC-2MFT-T1. One interface is a data T1, the second is a voice PRI. When the router registers, the data T1 bounces. Really bizarre.

226
Views
0
Helpful
5
Replies
CreatePlease to create content