Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MGCP - Reorfer tone when using 4507R and WS-X4604-GWY

I have a 4507R with a AGM (WS-X4604-GWY) I have 4 VLANS on the switch

VLAN1 - Shutdown

VLAN2 - Users1

VLAN3 - Users2

VLAN4 - Voice

VLAN5 - Management VLAN

I have the SUPIV engine and the Gig6/1 is set for trunking and its native VLAN is set to 5

I have on the AGM the main

Gig0/0 - Set to an IP address on VLAN5

Gig0/0.2 - VLAN2

Gig0/0.3 - VLAN3

Gig0/0.4 - VLAN4

I have the dial-pper of

dial-peer voice 100 pots

application mgcpapp

incoming called-number .

direct-inward-dial

destination-pattern 9T

port 1/0:23

dial-peer voice 101 pots

application mgcpapp

incoming called-number .

direct-inward-dial

destination-pattern 9T

port 1/1:23

I can make calls out just fine, anywhere.

I can call interanlly anywhere.

When you try to call in you get one ring ang then, Sorry you have dialed an incorrect number if you feel you etc..

I am running MGCP I can get to the callmanager from the AGM.

Config

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname WO_LSB_4507_MPOP_1GW

!

no logging console

!

memory-size iomem 25

ip subnet-zero

ip host-routing

no ip domain lookup

!

ip audit notify log

ip audit po max-events 100

!

isdn switch-type primary-ni

voicecard mode toll-by-pass

!

voice call send-alert

voice rtp send-recv

!

!

!

!

!

!

!

!

!

ccm-manager redundant-host 10.110.0.3

ccm-manager mgcp

!

controller T1 1/0

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

!

controller T1 1/1

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

arp timeout 600

!

interface GigabitEthernet0/0

ip address 10.110.2.4 255.255.254.0

no negotiation auto

!

interface GigabitEthernet0/0.2

encapsulation dot1q 2

ip address 10.103.0.4 255.255.254.0

!

interface GigabitEthernet0/0.3

encapsulation dot1q 3

ip address 10.104.0.4 255.255.254.0

!

interface GigabitEthernet0/0.4

encapsulation dot1q 4

ip address 10.110.2.4 255.255.254.0

!

interface Serial1/0:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial1/1:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

router eigrp 200

redistribute connected

redistribute static

network 10.0.0.0

no auto-summary

!

ip default-gateway 10.0.255.9

ip classless

no ip http server

!

!

!

call rsvp-sync

!

voice-port 1/0:23

!

voice-port 1/1:23

!

mgcp

mgcp call-agent 10.110.0.2 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

no mgcp timer receive-rtcp

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 100 pots

application mgcpapp

incoming called-number .

destination-pattern 9T

direct-inward-dial

port 1/0:23

!

dial-peer voice 101 pots

application mgcpapp

incoming called-number .

destination-pattern 9T

direct-inward-dial

port 1/1:23

!

!

line con 0

line vty 0 4

login

!

voicecard sccp manager 10.110.0.2 port 2000

voicecard sccp local GigabitEthernet0/0

!

end

Any Ideas would greatly be appreciated.

2 REPLIES
Silver

Re: MGCP - Reorfer tone when using 4507R and WS-X4604-GWY

Sometimes direct-inward-dial causes problems. May be you can try the config without it.

New Member

Re: MGCP - Reorfer tone when using 4507R and WS-X4604-GWY

Thanks for the reply, I got it working I took out the incoming called-number . out of the config and everything was in harmony -:)

94
Views
0
Helpful
2
Replies