Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MGCP w/PRI on ICS7750

Does anyone have a sample configuration for a PRI line on an MRP using MGCP? I can't seem to figure out where my problem is. My other slot has an FXS card in it and that works just fine. The PRI works fine with H.323.

Thanks

Steve

5 REPLIES
Blue

Re: MGCP w/PRI on ICS7750

Better yet, why don't you post your config?

Re: MGCP w/PRI on ICS7750

Are you remembering to "isdn l3-bind ccm-manager" on the Serial x/x:[23|15] interface that is created after you declare the [TE]1 circuit as a PRI with "pri-group" on the controller?

This is often overlooked.

Of course, if you're running a recent version of IOS and a recent version of CallManager, you can always use ccm-manager config to let CallManager configure the gateway for you -- there's a lot to overlook, this is typically a pretty good idea.

New Member

Re: MGCP w/PRI on ICS7750

I do not have that. I will try it this evening. I will also try the autoconfig. I am running CM 3.3(3)

Here is my config...

Current configuration : 4875 bytes

!

version 12.2

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname slot2_MFT_FXS

!

enable password xxxx

!

memory-size iomem 20

tdm clock T1 0/0 both export line

voice-card 0

!

voice-card 1

!

ip subnet-zero

!

!

no ip domain lookup

!

!

isdn switch-type primary-dms100

!

voice call carrier capacity active

!

voice class codec 99

codec preference 1 g711ulaw

codec preference 2 g729br8

codec preference 3 g729r8

!

!

!

!

!

!

!

!

!

ccm-manager redundant-host 10.0.6.6

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.0.6.6

ccm-manager config

!

controller T1 0/0

framing esf

linecode b8zs

pri-group timeslots 1-24

!

!

!

interface FastEthernet0/0

ip address 10.0.6.4 255.255.0.0

speed auto

!

interface Serial0/0:23

ip address 10.200.200.5 255.255.255.252

no logging event link-status

isdn switch-type primary-dms100

isdn incoming-voice voice

no cdp enable

ip rtp header-compression passive

!

router eigrp 1

network 10.0.0.0

auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip http server

ip pim bidir-enable

!

!

logging 10.0.6.1

!

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

snmp-server host 10.0.6.1 public

call rsvp-sync

!

voice-port 0/0:23

echo-cancel coverage 32

no comfort-noise

!

voice-port 1/0

output attenuation 0

!

voice-port 1/1

output attenuation 0

!

mgcp

mgcp call-agent 10.0.6.1 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp restart-delay 15

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

dial-peer cor custom

!

dial-peer voice 5940 voip

destination-pattern 5940

progress_ind setup enable 3

session target ipv4:10.0.6.3

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

no vad

!

dial-peer voice 91 voip

fax-relay ecm disable

fax protocol cisco

!

dial-peer voice 2 pots

application mgcpapp

port 0/0:23

!

dial-peer voice 3 pots

application mgcpapp

port 1/0

!

dial-peer voice 4 pots

application mgcpapp

port 1/1

!

num-exp 9906 39906

num-exp 8298 6582

num-exp 4898 6584

num-exp 2249 6583

num-exp 6400 3113

!

line con 0

exec-timeout 0 0

password xxxx

line vty 0 4

password xxxx

login

line vty 5 15

password xxxxx

login

!

no exception crashinfo

no scheduler allocate

end

Blue

Re: MGCP w/PRI on ICS7750

jdiegmueller is right add the command isdn l3-bind ccm-manager to your serial interface, see below:

interface Serial0/0:23

ip address 10.200.200.5 255.255.255.252

no logging event link-status

isdn l3-bind ccm-manager

isdn switch-type primary-dms100

isdn incoming-voice voice

no cdp enable

ip rtp header-compression passive

New Member

Re: MGCP w/PRI on ICS7750

One other thought. I think you need to specify in your PRI group, the MGCP service.

pri-group timeslots 1-24 service mgcp

100
Views
0
Helpful
5
Replies
CreatePlease to create content