Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Migrating from Ex5.5 to Ex2003; Unity 4.0.2 upgrade to 4.0.3

Hi,

We currently have a customer with: NT4 domain and multiple exchange 5.5 sites.

They have an Exchange organization with approx. 15 Exch. sites. Unity cannot service multiple Exch5.5 sites. (Exch. Organization is first installed in The Netherlands, other country's are visible as seperate sites in this org.) Centralized mail distribution by use of WAN links to their country's via NLD.

The customer has got a Unity 4.0.2 with CCM 3.3.2 integration and the W2k server is joined into their NT4 domain, including the Ex5.5. users.

This week they upgraded their NT4 domain to the W2k3 Active Directory. Only thing is to reboot the Unity server (Cisco documentation).

--> These questions are base on an expirience at another customer, i had seen that this customer was able to import users into unity from other OU's in the AD then the Unity was pointing to (Un3.1.5 + E2K).<--

First: The customer askes if it is possible to already update the schema in this stage (Unity 4.0.3CD1 utility with changed ldif-scripts) without interference of the current live system with Ex5.5 integration.

Second: They currently have a CCM cluster in the Netherlands and are enrolling other country's like France and Hungary .

Question: is it possible to provide these country's with Unified messaging as well?

The Customer will first of all upgrade the Ex5.5 to Ex2003 in the Netherlands.

I assume that in this case all other country's should also first of all upgrade their NT4 accounts to Active Dir. accounts. or not?

The AD Root will be used with seperate OU's per country.

Then The Netherlands site is ready for Unity 4.0.3. but still not servicing other country's.

Example: Customer ROOT

Netherlands

Users (+E2k3)

Distribution lists

France

Users (adc disabled accounts?)

Distribution lists

In this example my OU's are administrative groups.

So my next question is; how to provide UM to the other country's.

My opinion is to have a synchronization from Active Directory to Exchange 5.5. (2-way AD connection agreement) Then these Exch5.5 accounts will be visible in the OU of France as disabled accounts.

Then it is possible to import them into Unity.

Ofcourse this is a temporary solution until the other country's are migrate to E2k3 as well.

Thanks in advance.

Kind Regards,

Julien

1 ACCEPTED SOLUTION

Accepted Solutions
Gold

Re: Migrating from Ex5.5 to Ex2003; Unity 4.0.2 upgrade to 4.0.3

If you have a two-way ADC agreement the Unity 2.X servers will be completely dead in the water. Basically the ADC will manipulate the 5.5 directory data is such a way that Unity can no longer read it. Since the 5.5 directory is Unity's database in 2.X things get ugly.

If you can stay away please do because you're playing with fire! If you must do this make sure to replicate one-way from 5.5 to AD only -- NOT from AD to 5.5.

5 REPLIES
Gold

Re: Migrating from Ex5.5 to Ex2003; Unity 4.0.2 upgrade to 4.0.3

1. If the customer has already run Exchange 2003 /ForestPrep than you can run ADSchemaSetup on the Schema Master. You can't run ADSchemaSetup before /ForestPrep.

2. Unity 4.0(3) can support mixed Exchange 2003 and Exchange 5.5 but the key here is the location of the Exchange servers. It is not support for Unity to service subscriber homed on an Exchange server located across a WAN link from Unity. You need a Unity server in each physical location.

See http://www.cisco.com/en/US/products/sw/voicesw/ps2237/prod_release_note09186a00801b92bc.html#383616

Hope this helps,

Keith

New Member

Re: Migrating from Ex5.5 to Ex2003; Unity 4.0.2 upgrade to 4.0.3

Thanks Keith!

This really helps.

When will the Unity 4.x Design guide be updated to release 4.0.3 inclusing Ex2003 support.

Is it possible to also "read" Ex2003 when Ex2000 is mentioned.(differences are not that big).

http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_implementation_design_guide_book09186a00801187ba.html

Question: The customer still got 3 other Unity's within their domain on seperate Ex5.5 site's (Un 2.4.5 (2) and 2.4.6 (1))

What will exactly happen to these 2.4 servers when AD2003 and Ex5.5 are replicated.

This is a question related to the design guide as well.

-->

http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_implementation_design_guide_chapter09186a00801187c8.html

"A Cisco Unity server that services Exchange 5.5 mailboxes in a mixed-mode environment is not affected by standard directory replication between the Exchange 5.5 directory and Active Directory. However, the Cisco Unity Exchange 5.5 location object can be affected if a customer changes the object and attribute mapping in the Active Directory Connector to allow that object to be replicated to Active Directory and back.

Versions of Cisco Unity prior to Cisco Unity 3.0 may be severely affected if replication is set up between Exchange 5.5 and Active Directory, depending on how replication is set up.

"

Thanks in advance,

Julien.

Gold

Re: Migrating from Ex5.5 to Ex2003; Unity 4.0.2 upgrade to 4.0.3

If you have a two-way ADC agreement the Unity 2.X servers will be completely dead in the water. Basically the ADC will manipulate the 5.5 directory data is such a way that Unity can no longer read it. Since the 5.5 directory is Unity's database in 2.X things get ugly.

If you can stay away please do because you're playing with fire! If you must do this make sure to replicate one-way from 5.5 to AD only -- NOT from AD to 5.5.

New Member

Re: Migrating from Ex5.5 to Ex2003; Unity 4.0.2 upgrade to 4.0.3

Yes, i already thought this would be very dangerous!

Thanks.

So this will bring up a new question.

We currently still have 1 Unity 4.0.3 with Dual-switch. This site in The Netherlands has got traditional PBX and CCM 3.3.2.

The other 3 sites with 2.x still have Ex5.5 and traditional pbx's.

These Unity 2.4.x servers will ofcourse be upgraded a.s.a.p.(Probably Dec 03 or Jan 04) because of the End_Of_Life & support of it.

But right now there's NO option to directly upgrade the systems because of licensing and server availability (Costs).

Because all customer sites are still having Ex5.5 and are going to migrate to AD we will experience these replication problems if we do not take care of this (2-way is needed).

The question is: Can we only replicate Ex5.5 and AD with a 2-way replication NOT on Site level but only replicate the recipients from Ex5.5?

Then we do not touch the Unity db, isn't it?

Is this possible or should we upgrade to 3.1 (read 4.0.3) or higher first before migrating.

Thanks,

Kind Regards, Julien

New Member

Re: Migrating from Ex5.5 to Ex2003; Unity 4.0.2 upgrade to 4.0.3

Many thanks,

We adjusted the replication process for the other Unity sites with 2.4.x.

The replication is a 2-way agreement with replication only for private and public stores.

This will do the trick to leave the current Unity 2.4 db's in Ex5.5. as it is.

Further more we will ofcourse upgrade them a.s.a.p.

Regards, Julien

99
Views
0
Helpful
5
Replies
CreatePlease login to create content