Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

Minimum Command for MGCP T1 PRI

Hi all,

CCM 4.13 (no special engineer or patch install, Publisher and Subscriber.

There are minmum command for MGCP, after register CCM, CCM will upload the rest of command to MGCP Voice Gateway.

For some reason, I couldnt make MGCP download file from CCM, I have to manually type all the command and it works.

However, I want to know why the MGCP could not download file from CCM???

Here is my configure:

network-clock-participate wic 0

!

controller T1 0/0/0

framing esf

linecode b8zs

pri-group timeslots 1-3,24 service mgcp

!

interface FastEthernet0/0.11

description HQ-Data

encapsulation dot1Q 11

ip address 192.168.200.1 255.255.255.0

!

interface FastEthernet0/0.111

description HQ-Voice

encapsulation dot1Q 111

ip address 10.1.200.1 255.255.255.0

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

voice-port 0/0/0:23

!

ccm-manager redundant-host 10.1.200.21

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.1.200.20 10.1.200.21

!

mgcp

mgcp call-agent 10.1.200.20 service-type mgcp version 0.1

mgcp bind control source-interface FastEthernet0/0.111

mgcp bind media source-interface FastEthernet0/0.111

!

mgcp profile default

Anyone can tell what I am missing??

Ken

P.S. here is debug mgcp events:

*Aug 15 14:26:28.247: * mgcp_msg_ack: Setting the restart method to NONE

*Aug 15 14:26:28.247: mgcpapp_process_socket

HQ#

*Aug 15 14:26:43.243: MGCP sys msg: (15)

*Aug 15 14:26:43.243: xlate sys msg: (15, 4524AF5C)

*Aug 15 14:26:43.243: sys msg values: (INVALID MGCP EVENT, 0, , 0, CALL_IDLE)

*Aug 15 14:26:43.243: process mgcp_handle_cmapp_event

*Aug 15 14:26:43.243: mgcp_cmapp_send_keepalive send NTFY KeepAlive

*Aug 15 14:26:43.243: send_mgcp_empty_notify_msg: endpt *, complete_endpt *@HQ

*Aug 15 14:26:43.243: * mgcp_get_ca_addr_port:

*Aug 15 14:26:43.243: * mgcp_get_ca_addr_port: Used endpoint NE 10.1.200.20:2427

*Aug 15 14:26:43.243: mgcp_get_preffered_ip

*Aug 15 14:26:43.243: * mgcp_get_ca_addr_port: NE addr 10.1.200.20:2427

*Aug 15 14:26:43.243: * mgcp_enq_retx_msg: trans_id 234089142,ntfy_ent 10.1.200.20:2427

*Aug 15 14:26:43.243: * mgcp_root_get_profile:

*Aug 15 14:26:43.243: mgcp_add_trans_id_rec: Add trans id (234089142, 45B26378) record

*Aug 15 14:26:43.243: mgcp_stw_timer_start timer type 0, duration 500

*Aug 15 14:26:43.243: send_mgcp_empty_notify_msg NTFY Packet sent successf

HQ#ully - *

*Aug 15 14:26:43.247: MGC stat - 10.1.200.20, total=43, succ=22, failed=20

*Aug 15 14:26:43.247: mgcpapp_process_mgcp_msg : <NEW MGCP MSG From CA>

*Aug 15 14:26:43.247: * mgcp_msg_ack

*Aug 15 14:26:43.247: MGC stat - 10.1.200.20, total=43, succ=23, failed=20

*Aug 15 14:26:43.247: * mgcp_msg_ack: Removing msg : NTFY 234089142 *@HQ MGCP 0.1

X: 0

O:

*Aug 15 14:26:43.247: * mgcp_msg_ack: Setting the restart method to NONE

*Aug 15 14:26:43.247: mgcpapp_process_socket

1 REPLY

Re: Minimum Command for MGCP T1 PRI

Also key in,

ccm-manager config

HTH

Sankar

PS: please remember to rate posts

340
Views
5
Helpful
1
Replies
CreatePlease to create content