Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MLA shows error "Unable to add users to the group"

When I try to add user to the group ReadOnly with MLA, I search for the user I want to add.

This works OK - shows that AD integration works.

Then, when I try to add to the group,

I get the following pop-up window:

Unable to add users to the group:ReadOnly

System encountered internal error

The debug shows:

[...]

03/10/06:12:49:23:MLADebug:186408195: DEBUG: /ccmadmin/mlaSearchResultsProcess.asp: Going to add user: L1204316

03/10/06:12:49:23:MLADebug:186408195: ERROR: /ccmadmin/mlaSearchResultsProcess.asp: ASP:addUserSelection(): failed, Error Code=-53 Error details= DSA is unwilling to perform

03/10/06:12:49:23:MLADebug:186408195: DEBUG: /ccmadmin/mlaSearchResultsProcess.asp: ASP:addUserSelections: done

03/10/06:12:49:23:MLADebug:186408195: ERROR: /ccmadmin/mlaSearchResultsProcess.asp: failed to add users enum=DSA is unwilling to perform, msg=Unable to add users to the group:ReadOnlySystem encountered internal error

[...]

CCM version: 4.1.3 SR2

integrated with AD.

Is there anything that has to be done to AD to enable adding users to the MLA group?

What does it mean "DLA is unwilling to perform" ?

Thanks for your help

Pawel Jachimowicz

3 REPLIES

Re: MLA shows error "Unable to add users to the group"

Check bug CSCeb47250

If you add a user to CallManager global directory with an empty first name field and then try to add

the user to a MLA group, you receive the error "Unable to Add users to the group, Operation failed".

Workaround: Enter something into the first name field

--------------------------------------------

If that is not your case please try uninstalling and reinstalling MLA

New Member

Re: MLA shows error "Unable to add users to the group"

Dear Sir,

May I know that how to uninstalling & reinstalling MLA, please help us more information.

thanks

KH

New Member

Re: MLA shows error "Unable to add users to the group"

Hi there,

Here is the fix

You need to make some changes in the SQL Database as the search base is wrong you cant assign users to groups.

In SQL manager CCM0300 database in tables Select the MLAParameter

(return allrows)

change some paths on the following NAMEs to your companies as per AD integration

"MLAUserBase" ou=Logins,dc=ap,dc=yourcompany,dc=com

and "MLADirBase"

ou=MultiLevelAdmin,ou=Cisco,dc=ap,dc=yourcompany,dc=com

Go into CCMAdmin and MLA parametres and check this was updated and you can assign a user to superuser group.

logon with the new user.

regards

Allan

104
Views
0
Helpful
3
Replies
CreatePlease login to create content