Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

moh from router flash

we're using moh from router flash with multicast configuration in ccm. so router pretend to give moh give same multicast ip address. but when i put a PSTN call on hold and type sh ccm-manager music-on-hold, i find the followings:

========================================

Current active multicast sessions : 1

Multicast RTP port Packets Call Codec Incoming

Address number in/out id Interface

===================================================================

239.1.1.1 16384 0/0 354 g711ulaw

========================================

it seems no packet flow, why?

7 REPLIES
New Member

Re: moh from router flash

Hi,

Can you supply the 'sh ephone summ' output.

Thanks.

New Member

Re: moh from router flash

************************************

hairpin_block:

Max 48, Registered 0, Unregistered 0, Deceased 0, Sockets 0

ephone_send_packet process switched 0

Max Conferences 8 with 0 active (3 allowed)

Skinny Music On Hold Status

Active MOH clients 0 (max 196), Media Clients 0, B-ACD Clients 0

File music-on-hold.au type AU Media_Payload_G711Ulaw64k 160 bytes

Moh multicast on 239.1.1.1 port 16384 via 165.46.23.141

************************************

New Member

Re: moh from router flash

Can you post the router config please?

Re: moh from router flash

You do not appear to have an incoming interface on the show ccm-manager music-on-hold.

Ensure that you have specified which ip interfaces you want multicast packets sent to. This is as follows, you can list upto four, you simply list the ip-addresses consecutively:

multicast moh 239.1.1.1 port 16384 route

Regards

Allan.

HTH...

New Member

Re: moh from router flash

Hi Mike

You need a loopback interface and stream the MoH to it for the PSTN users. See the following config example:

interface Loopback1

description ** LOOPBACK FOR MOH **

ip address 10.2.4.1 255.255.255.255

!

interface FastEthernet0/0.20

description ** VOICE VLAN **

encapsulation dot1Q 20

ip address 10.2.20.10 255.255.255.0

!

ccm-manager music-on-hold

!

call-manager-fallback

moh music-on-hold.au

multicast moh 239.1.1.1 port 16384 route 10.2.20.10 10.2.4.1

Regards

Stefan

New Member

Re: moh from router flash

Hi, I'm having the same problem. I'm trying to configure a 2811 to run MOH from flash and i get no sound or tone.

Here is part of the config:

interface Loopback0

ip address 10.10.10.1 255.255.255.0

---------------------------------------

interface FastEthernet0/0.10

description VLAN 10 for Data

encapsulation dot1Q 10

ip address 10.10.165.1 255.255.255.0

no snmp trap link-status

no cdp enable

!

interface FastEthernet0/0.15

description VLAN 15 for Voice

encapsulation dot1Q 15

ip address 192.168.165.1 255.255.255.0

no snmp trap link-status

----------------------------------------

ccm-manager redundant-host 172.16.1.12 172.16.1.11

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 172.16.1.11

ccm-manager config

---------------------------------------

mgcp

mgcp call-agent 172.16.1.14 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

----------------------------------------

call-manager-fallback

max-conferences 2 gain -6

ip source-address 192.168.165.1 port 2000

max-ephones 24

max-dn 24

system message primary CM Failed, NOW on SRST

default-destination 7007

moh TheRoadToLucia_ULAW.wav

multicast moh 239.1.1.9 port 16384 route 192.168.165.1 10.10.10.1

---------------------------------------------

This is the sh ephoen summary command output

ephone-1 Mac:0011.21CE.E12B TCP socket:[-1] activeLine:0 DECEASED

mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 debug:1

IP:172.16.1.59 Telecaster 7960 keepalive 0

Max 24, Registered 0, Unregistered 0, Deceased 1, Sockets 0

ephone_send_packet process switched 0

Max Conferences 8 with 0 active (2 allowed)

Skinny Music On Hold Status

Active MOH clients 0 (max 96), Media Clients 0

File TheRoadToLucia_ULAW.wav type WAVE Media_Payload_G711Ulaw64k 160 bytes

Moh multicast on 239.1.1.9 port 16384 via 192.168.165.1

via 10.10.10.1

File play position 345646 file type 2

Play offset 3520, Write offset 24000,File start 46 end 1572846 current type 2

Data at 467396A4, size 32000

RTP ssrc 37872A51 timestamp_offset 0 position 2B9E reposition 0

Max process service interval 224736 (last 217314)

Min interval 20000, missed 0 run 321 (us)

moh_process_service counter 4472422

Max Media process interval 290675 (last 208190) run 7 (us)

File system max access time 50248 (us) (last 42266) with late-reads 0

0 clients interrupt service, 0 process level

0 no-conversion, 0 a-to-mu, 0 mu-to-a

0 packets serviced at interrupt, 0 at process

----------------------------------------------

I hope you guys can help me, it is driving me crazy.

Also I call from my cell to the remote location told them to put me on hold and type the show ccm-manager music-on-hold i get this:

Current active multicast sessions : 0

We have all IP phones 7960

Also call manager is correcly configured.

The wav file is the number 3 and i assigned IP 239.1.1.9

THANK YOU IN ADVANCE

Zeek

Re: moh from router flash

As you are already aware, when configuring the base ip address, the base ip address will be incremented by CallManager.

However, you may have multiple audio-sources, are these in fact three multicast audio-sources?

Although the audio file may be number three, you need to ensure that within the MMoH Server in CCM you do have three sources listed.

The reason being, is that there maybe actuall only two multicast audio-sources listed for example, wav number 1 and wav number 3.

In this situation the audio-source will be number two, therefore the first base ip address for wav 3 would actually be 239.1.1.5 G711 u-law. Remember the base address in CCM is still 239.1.1.1 you only increment the address on the multicast moh command.

Also verify that the device pool which the MGCP endpoint is associated with has the appropriate MRGL with the MMoH. I assume that you have specified the MRG for Multicast, and enabled MoH on the server?

Regards

Allan.

240
Views
0
Helpful
7
Replies
CriarFaça o para criar o conteúdo