Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MoH Multicasting and the WAN

I'm having trouble getting MMoH over the WAN. I thought I had the config correctly from the Router perspective. MMoH works locally but not over the WAN. Below is a sample config. Any sugestions would be great

CoudersportVG#sh run

Building configuration...

Current configuration : 4735 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CoudersportVG

!

boot-start-marker

boot-end-marker

!

logging buffered 4096 debugging

enable secret xxxxx.

!

no aaa new-model

ip subnet-zero

!

!

ip dhcp excluded-address 10.40.0.1 10.40.0.254

!

ip dhcp pool VoiceVlan

network 10.40.0.0 255.255.0.0

default-router 10.40.0.254

option 150 ip 10.10.0.1

!

!

ip multicast-routing

no ftp-server write-enable

voice-card 1

!

!

!

voice rtp send-recv

!

!

!

!

!

!

!

!

!

!

ccm-manager redundant-host 10.10.0.1

ccm-manager mgcp

ccm-manager music-on-hold

!

!

class-map match-all AS400

match access-group 101

class-map match-all Voice-Control

match ip dscp af31

class-map match-all Voice

match ip dscp ef

!

!

policy-map Lan-Edge

class Voice

set cos 5

class Voice-Control

set cos 3

class AS400

set cos 2

class class-default

set cos 0

policy-map Wan-Edge

class Voice

bandwidth percent 33

class Voice-Control

bandwidth percent 2

class AS400

bandwidth percent 20

class class-default

fair-queue

!

!

!

!

interface FastEthernet0/0

no ip address

ip pim sparse-dense-mode

duplex auto

speed auto

no keepalive

!

interface FastEthernet0/0.4

encapsulation dot1Q 4

ip address 10.4.1.1 255.255.0.0

ip pim sparse-dense-mode

service-policy output Lan-Edge

!

interface FastEthernet0/0.40

encapsulation dot1Q 40

ip address 10.40.0.254 255.255.0.0

ip pim sparse-dense-mode

service-policy output Lan-Edge

!

interface FastEthernet0/0.41

encapsulation dot1Q 41

ip address 192.168.41.254 255.255.255.0

!

interface BRI0/0

no ip address

shutdown

!

interface Serial0/0

no ip address

encapsulation frame-relay

frame-relay lmi-type ansi

!

interface Serial0/0.41 point-to-point

ip address 192.168.254.10 255.255.255.252

ip pim sparse-dense-mode

frame-relay interface-dlci 41

class FR-MAP

frame-relay ip rtp header-compression

!

interface Serial0/0.42 point-to-point

ip address 192.168.254.22 255.255.255.252

ip pim sparse-dense-mode

frame-relay interface-dlci 42

!

interface Serial0/0.43 point-to-point

ip address 192.168.254.18 255.255.255.252

ip pim sparse-dense-mode

frame-relay interface-dlci 43

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

router eigrp 100

offset-list 10 out 30 Serial0/0.43

network 10.4.0.0 0.0.255.255

network 10.40.0.0 0.0.255.255

network 192.168.1.0

network 192.168.41.0

network 192.168.254.8 0.0.0.3

network 192.168.254.16 0.0.0.3

network 192.168.254.20 0.0.0.3

distribute-list 10 out Serial0/0.42

no auto-summary

!

ip classless

ip http server

ip pim rp-address 192.168.11.254

!

!

!

map-class frame-relay FR-MAP

frame-relay cir 1536000

frame-relay bc 15360

frame-relay be 0

frame-relay mincir 1536000

service-policy output Wan-Edge

access-list 10 deny 10.40.0.0 0.0.255.255

access-list 10 permit any

access-list 101 permit ip any host 10.1.10.234

access-list 101 permit ip host 10.1.10.234 any

!

!

control-plane

!

!

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/0/2

!

voice-port 1/0/3

!

voice-port 1/1/0

!

voice-port 1/1/1

!

voice-port 1/1/2

!

voice-port 1/1/3

!

mgcp

mgcp call-agent 10.10.0.2 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp bind control source-interface FastEthernet0/0.40

mgcp bind media source-interface FastEthernet0/0.40

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

!

dial-peer voice 900 pots

application mgcpapp

port 1/0/0

!

dial-peer voice 901 pots

application mgcpapp

port 1/0/1

!

dial-peer voice 902 pots

application mgcpapp

port 1/0/2

!

dial-peer voice 903 pots

application mgcpapp

port 1/0/3

!

dial-peer voice 904 pots

application mgcpapp

port 1/1/0

!

dial-peer voice 905 pots

application mgcpapp

port 1/1/1

!

dial-peer voice 906 pots

application mgcpapp

port 1/1/2

!

dial-peer voice 907 pots

application mgcpapp

port 1/1/3

!

dial-peer voice 912 pots

preference 5

destination-pattern .T

port 1/1/0

forward-digits all

!

dial-peer voice 913 pots

preference 6

destination-pattern .T

port 1/1/1

forward-digits all

!

dial-peer voice 914 pots

preference 7

destination-pattern .T

port 1/1/2

forward-digits all

!

dial-peer voice 915 pots

preference 8

destination-pattern .T

port 1/1/3

forward-digits all

!

!

call-manager-fallback

max-conferences 4

limit-dn 7910 1

limit-dn 7935 1

limit-dn 7940 2

limit-dn 7960 2

ip source-address 10.40.0.254 port 2000

max-ephones 48

max-dn 100

!

!

line con 0

line aux 0

line vty 0 4

password xxxx!

!

!

end

  • Other Collaboration Voice and Video Subjects
2 REPLIES

Re: MoH Multicasting and the WAN

Hello.

Check TTL in the CCM MOH server configuration.

New Member

Re: MoH Multicasting and the WAN

Apparently I missed a very basic setting....Hops for the audio source.

233
Views
0
Helpful
2
Replies