Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MTP Configuration for SIP DTMF relay using callmanager 5.0

My set up is like i have a sip trunk from ccm 5.0 to a nextone session border controller.

I have configured 2811 has an MTP device for outband to inband dtmf conversion..

When ever i place a call to any ivr device n press any digits as requested...it doesnt work..

Configuration for cisco 2811 router are as follows.

Current configuration : 2180 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname xxxx

!

boot-start-marker

boot system flash c2800nm-ipvoice-mz.124-5.13.T4.

boot-end-marker

!

card type t1 0 0

! card type command needed for slot/vwic-slot 1/1

!

no aaa new-model

!

resource policy

!

no network-clock-participate slot 1

network-clock-participate wic 0

!

!

ip cef

!

!

isdn switch-type primary-4ess

!

voice-card 0

dspfarm

dsp services dspfarm

!

voice-card 1

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

controller T1 0/0/0

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

!

!

!

!

interface FastEthernet0/0

ip address 172.24.6.75 255.255.252.0

duplex full

speed 100

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ntt

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip route 0.0.0.0 0.0.0.0 172.24.6.1

!

ip http server

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0:23

!

ccm-manager redundant-host 172.24.6.72

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 172.24.6.72

ccm-manager config

!

mgcp

mgcp call-agent 172.24.6.73 2427 service-type mgc

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

sccp local FastEthernet0/0

sccp ccm 172.24.6.73 identifier 2 version 5.0.1

sccp ccm 172.24.6.72 identifier 1 version 5.0.1

sccp ip precedence 3

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 2811 register 2811_MTP

!

dspfarm profile 2811 mtp

codec g711ulaw

maximum sessions hardware 8

associate application SCCP

!

!

!

line con 0

password xxx

line aux 0

line vty 0 4

password xxx

login

!

scheduler allocate 20000 1000

!

end

MTP is configured and registered correctly with ccm5.0 but somehow it is not able to do the dtmf conversion..

Attached is the ccm trace also.

guys plz help me to set this mtp for dtmf conversion

Thanks in advance ...

Shirish

1 REPLY
New Member

Re: MTP Configuration for SIP DTMF relay using callmanager 5.0

ccm5 is not publically available yet afaik, where did you get it?

437
Views
0
Helpful
1
Replies