Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MWI not working for a few users

I have an installation of:<br>Call Manager 3.1(2c) - upgraded from CM 3.08<br>Unity 2.4.6.161 - upgraded from Unity 2.4.6.102<br>TSP 6.0.1<br>Exchange 5.5<br><br>There are 100 users. Almost all work fine but for a few of the users, when they receive new messages (from the PSTN or internal), they receive the wav exchange email, but they do not get a light MWI. Furthermore, when they dial into their phone, they hear "no new messages".<br><br>The working phones and not working phones are in the same partitions, and CSS. I tried reseting their MWI and phone, and deleting and recreating subscriber account. I can dial the MWI number to turn the light on/off.<br><br>Thanks.<br><br><br>

  • Other Collaboration Voice and Video Subjects
1 REPLY
Anonymous
N/A

Re: MWI not working for a few users

I don't think this has anything to do (at least on the surface) with MWI codes being sent correctly or not... if you call in over the phone and hear no new messages, that's your problem. The Notifier (guy that handles all the notification triggers including MWIs) works off the inbox state changes and it only triggers MWIs when it see's new, unread messages in your inbox that match the voice mail criteria (media flag and message class gotta match what we're looking for).

If the conversation doesn't think you have any messages neither does the notifier.

You say a WAV file shows up in the inbox... what's the message class on this messages? You can check this by right clicking the column header in your inbox, selecting "field chooser" and adding a column... you want the 'Message Class' column under the "all mail fields" section. This will show you the message class of all your messages in the inbox. Voice mail messages should all be "IPM.Note.Voice.Unity". If they're just IPM.Note (as I susptect) these are not tagged as voice mail messages, they're just normal emails with an attached WAV file.

If that's the case, how are these users attaching to Exchange via Outlook? Via IMAP/POP3 by any chance?


Jeff Lindborg
Unity Technical Lead/Answer Monkey
Cisco Systems
lindborg@cisco.com
http://www.AnswerMonkey.net (new page for Unity support tools and scripts)

88
Views
0
Helpful
1
Replies
This widget could not be displayed.